summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/sdl_sound/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/sdl_sound/PKGBUILD')
-rw-r--r--abs/not_built/extra/sdl_sound/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/not_built/extra/sdl_sound/PKGBUILD b/abs/not_built/extra/sdl_sound/PKGBUILD
new file mode 100644
index 0000000..cf47cae
--- /dev/null
+++ b/abs/not_built/extra/sdl_sound/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 22259 2008-12-24 15:26:14Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=sdl_sound
+pkgver=1.0.3
+pkgrel=2
+pkgdesc="A library to decode several popular sound file formats, such as .WAV and .MP3"
+arch=('i686' 'x86_64')
+url="http://icculus.org/SDL_sound/"
+license=('LGPL')
+depends=('sdl' 'libmikmod' 'libvorbis' 'flac' 'speex' 'smpeg')
+options=('!libtool')
+source=(http://icculus.org/SDL_sound/downloads/SDL_sound-$pkgver.tar.gz
+ flac.patch)
+md5sums=('aa09cd52df85d29bee87a664424c94b5'
+ '302aa9dc94cc71dd3339ca3177d36e1c')
+
+build() {
+ cd ${srcdir}/SDL_sound-${pkgver}
+
+ CFLAGS="$CFLAGS -I/usr/include/smpeg" \
+ CXXFLAGS="$CXXFLAGS -I/usr/include/smpeg" \
+ ./configure --prefix=/usr
+
+ make || return 1
+ make DESTDIR=${pkgdir} install
+}
+