summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/xfconf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/not_built/extra/xfconf/PKGBUILD')
-rw-r--r--abs/not_built/extra/xfconf/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/abs/not_built/extra/xfconf/PKGBUILD b/abs/not_built/extra/xfconf/PKGBUILD
new file mode 100644
index 0000000..f6b97cf
--- /dev/null
+++ b/abs/not_built/extra/xfconf/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 87984 2010-08-18 20:44:29Z andyrtr $
+# Maintainer: tobias <tobias funnychar archlinux.org>
+
+pkgname=xfconf
+pkgver=4.6.2
+pkgrel=2
+pkgdesc="a simple client-server configuration storage and query system"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.xfce.org/"
+groups=('xfce4')
+# http://www.xfce.org/documentation/requirements
+# keep dbus and gtk2, see also http://bugs.archlinux.org/task/14536
+depends=( "libxfce4util>=4.6.2" "dbus-glib>=0.86" 'dbus>=1.2.24' 'gtk2>=2.20.1')
+makedepends=('pkgconfig' 'perl-extutils-depends' 'perl-extutils-pkgconfig' 'glib-perl' 'intltool' 'chrpath')
+options=('!libtool' '!emptydirs')
+replaces=('libxfce4mcs' 'xfce-mcs-manager' 'xfce-mcs-plugins')
+conflicts=('libxfce4mcs' 'xfce-mcs-manager' 'xfce-mcs-plugins')
+source=(http://archive.xfce.org/src/xfce/${pkgname}/4.6/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('5ff93c15077c6dbbcd38c437bc1ab2ef')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var --disable-static --with-perl-options=INSTALLDIRS="vendor"
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${startdir}/pkg install || return 1
+ # remove unneeded dynloader bootstrap file
+ rm ${pkgdir}/usr/lib/perl5/vendor_perl/auto/Xfce4/Xfconf/Xfconf.bs
+
+ # fix insecure rpath, http://bugs.archlinux.org/task/19980
+ chrpath -d ${pkgdir}/usr/lib/perl5/vendor_perl/auto/Xfce4/Xfconf/Xfconf.so
+}