summaryrefslogtreecommitdiffstats
path: root/linhes/linhes-system/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/linhes-system/PKGBUILD')
-rwxr-xr-xlinhes/linhes-system/PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/linhes/linhes-system/PKGBUILD b/linhes/linhes-system/PKGBUILD
index ec03819..c8c960a 100755
--- a/linhes/linhes-system/PKGBUILD
+++ b/linhes/linhes-system/PKGBUILD
@@ -1,21 +1,21 @@
pkgname=linhes-system
pkgver=9.0.0
-pkgrel=3
+pkgrel=4
arch=('x86_64')
#install=$pkgname.install
pkgdesc="Everything that makes LinHES a system"
license=('GPL2')
-depends=('cronie' 'libnotify' 'linhes-templates' 'pacman-contrib' 'openssh' 'ttf-overlock')
+depends=('cronie' 'dbus-python' 'libnotify' 'linhes-templates' 'pacman-contrib' 'openssh' 'ttf-overlock')
binfiles="add_storage.py balance_storage_groups.py empty_storage_groups.py remove_storage.py
checkXFSfrag.sh enableIRWake.sh idle.py lh_system_start.sh jobqueue_helper.py
- diskspace.sh find_orphans.py
+ diskspace.sh find_orphans.py optimize_mythdb.py
create_media_dirs.sh be_check.py
myth2mkv myth2mp3"
source=($binfiles
'myth_mtc.cron' 'paccache.cron' 'xfs_defrag.cron'
'readme_is_xml' 'add_storage.readme'
'79-cronie.hook' 'fstrim.hook' 'openssh.hook'
- '10-monitor.conf'
+ '10-monitor.conf' 'x11vnc.override.conf'
'system-sudo.rules'
'lh_system_start.sh.desktop')
@@ -34,6 +34,9 @@ package() {
#startup files
install -D -m600 "$srcdir/lh_system_start.sh.desktop" "$pkgdir/home/mythtv/.config/autostart/lh_system_start.sh.desktop"
+ #systemd files
+ install -m644 -D $srcdir/x11vnc.override.conf $pkgdir/etc/systemd/system/x11vnc.service.d/override.conf
+
#readme files
install -m644 -D $srcdir/readme_is_xml $pkgdir/etc/gen_is_xml.d/readme_is_xml
install -m644 -D $srcdir/readme_is_xml $pkgdir/etc/gen_lib_xml.d/readme_gen_xml
@@ -67,10 +70,11 @@ sha256sums=('96f67b5428debb7dac909893c56a7637bf6545c068732822981d4080125c53d9'
'11168c9cd3b117decaab6bc665c183b4aab917cf0a976bce4c1b5e4686a27bc9'
'ae34515e144830f424d3bd3f6b1b446892d62beed20bca6f0fb19b0bbb779f27'
'23358a7bff4968eccd469613b81b1415c2ae0ebe77f14f74426697333e4d88d7'
- '3d75c92c19da1f21da751f6425d9403eae58a1f5f665b39d72e6d2ff0e9c5494'
+ '1178b1c9797c50e5808558a2e7c826bbc4243bbf81f09d94d36fa26124f921e0'
'91bdec992bb2c933e15625c181f2195c402060b879168ebf35944cb064c904b9'
- 'f046b10e9f8686a8f5d1a48220506c0e22cc3b630f787d9f5e6b9044a22e7b26'
+ 'cedd34e448d3d45ab0f9fff40c115401f45bdea5b99215d0aff514a759ae2b7c'
'76f023c0cde7fea269234f1b29c32b117b91769217d4b1b8a3922daceb25f9f8'
+ 'e371c6a289c68fe200d7da856c20a8c579efa23178f4d62235f7359d7f6e49a1'
'bffcc13e4b480f720feb2b3c781bc4247c63303250c3d885022c699573d45a33'
'0254a21644473ba7953501a223f13b9b55d7ec290c80a567724ca1ac13e02e30'
'9ea1b5583cd38f53bb79d9e4ccae91a028db0b6850162d7991b19122c564b9c9'
@@ -84,5 +88,6 @@ sha256sums=('96f67b5428debb7dac909893c56a7637bf6545c068732822981d4080125c53d9'
'4c29e0b71071ae9556cf2dbd75de560d028577fe5eb993113105112c4b445eac'
'890482242434e333024c7819e8bf3c889dc16548d0a1745479c8523930fb32f7'
'dead17906b33a7f9d66ad13bb1c083a23438f45ece9bd5ec41ff86eda01c132a'
+ '2c9152ed542bb9c3aa516c6009125a757065100a060e0fa597243d4cbd92844f'
'a9d0a94ff442453f0bec0b2e8afd591cf17b2845b6ae45ff300530114efd30af'
'0b9868a563036c81f8fdb8ab8bbad51934aca2a07e9d7634e24214791afda8e2')