summaryrefslogtreecommitdiffstats
path: root/linhes/qbittorrent-vuetorrent-bin/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linhes/qbittorrent-vuetorrent-bin/PKGBUILD')
-rw-r--r--linhes/qbittorrent-vuetorrent-bin/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/linhes/qbittorrent-vuetorrent-bin/PKGBUILD b/linhes/qbittorrent-vuetorrent-bin/PKGBUILD
new file mode 100644
index 0000000..6e35ce2
--- /dev/null
+++ b/linhes/qbittorrent-vuetorrent-bin/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Francesco Minnocci <ascoli dot minnocci at gmail dot com>
+# Contributor: Falk Höppner <falk hoppner se>
+
+pkgname=qbittorrent-vuetorrent-bin
+_pkgname=vuetorrent
+pkgver=1.5.1
+pkgrel=1
+pkgdesc='The sleekest looking WebUI for qBittorrent made with Vue.js!'
+arch=('any')
+url='https://github.com/WDaan/VueTorrent'
+license=('GPL3')
+provides=("qbittorrent-${_pkgname}")
+conflicts=("qbittorrent-${_pkgname}")
+optdepends=(
+ 'qbittorrent: for use with qbittorrent'
+ 'qbittorrent-nox: for use with qbittorrent-nox'
+)
+install=qbittorrent-vuetorrent.install
+source=("${_pkgname}-$pkgver.zip::https://github.com/WDaan/VueTorrent/releases/download/v$pkgver/${_pkgname}.zip")
+sha512sums=('9dcf41b28c6bdbb2365da400f25b558666203c7adb9f8abcd39133233f397bfa006901581098a0d142f67cb964f18990d1480e39ca514a46d22cc806bc2d14e6')
+
+package() {
+ cd "$srcdir/vuetorrent"
+ find . -type f -exec install -D '{}' "$pkgdir/usr/share/$pkgname/{}" ';'
+}
+# vim:set ts=2 sw=2 et: