From 4dad47a79b322c6ff9706f0ee56c25dfd676d0e6 Mon Sep 17 00:00:00 2001
From: James Meyer
Date: Wed, 15 Jul 2009 20:52:27 -0500
Subject: linhes config: remove / from share name for samba
---
abs/core-testing/LinHES-config/mv_config.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/abs/core-testing/LinHES-config/mv_config.py b/abs/core-testing/LinHES-config/mv_config.py
index d5a247d..1ac4fea 100755
--- a/abs/core-testing/LinHES-config/mv_config.py
+++ b/abs/core-testing/LinHES-config/mv_config.py
@@ -10,7 +10,7 @@ NOOPDEBUG="FALSE"
BACKUPFILE="mythconverg.sql.gz"
BACKUPPATH="/myth/backup/"
TEMP_TEMPLATES="/tmp/templates"
-SMEDIA="/myth"
+SMEDIA="myth"
--
cgit v0.12
From e0745cb76cc8eda2decea99ea693354cfd9980bf Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson
Date: Thu, 30 Jul 2009 22:44:48 -0700
Subject: Myth2iPod:Adds m2iweb.php to allow for deletion of unwanted videos.
---
abs/extra-testing/myth2ipod/PKGBUILD | 5 +-
abs/extra-testing/myth2ipod/m2iweb.php | 157 ++++++++++++++++++++++++++
abs/extra-testing/myth2ipod/myth2ipod.install | 8 +-
3 files changed, 162 insertions(+), 8 deletions(-)
create mode 100755 abs/extra-testing/myth2ipod/m2iweb.php
diff --git a/abs/extra-testing/myth2ipod/PKGBUILD b/abs/extra-testing/myth2ipod/PKGBUILD
index 80a8613..bfb7c91 100755
--- a/abs/extra-testing/myth2ipod/PKGBUILD
+++ b/abs/extra-testing/myth2ipod/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=myth2ipod
pkgver=0.2
-pkgrel=17
+pkgrel=18
arch=("i686")
pkgdesc="A multimedia framework based on the MPEG-4 Systems standard"
url="myth2ipod.com"
depends=('gpac' 'nuvexport' )
install="myth2ipod.install"
-source=( myth2ipod iPod.pm myth2ipod-userjob.sh)
+source=( myth2ipod iPod.pm myth2ipod-userjob.sh m2iweb.php)
build() {
@@ -14,6 +14,7 @@ build() {
install -D -m 755 myth2ipod $startdir/pkg/usr/bin/myth2ipod
install -D -m 755 myth2ipod-userjob.sh /$startdir/pkg/usr/bin/myth2ipod-userjob.sh
install -D -m755 iPod.pm $startdir/pkg/usr/share/nuvexport/export/ffmpeg/iPod.pm
+ install -D -m755 m2iweb.php $startdir/pkg/myth/ipodfeed
}
diff --git a/abs/extra-testing/myth2ipod/m2iweb.php b/abs/extra-testing/myth2ipod/m2iweb.php
new file mode 100755
index 0000000..a8a9e4d
--- /dev/null
+++ b/abs/extra-testing/myth2ipod/m2iweb.php
@@ -0,0 +1,157 @@
+
+//archive.php
+// based on m2iweb.php by http://anthony.lusby.us/m2iweb/
+//release 0.1
+//10/05/07
+?>
+
+
+
+ MythWeb - Archive Recordings
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+View information and delete myth2ipod recordings.
+';
+ echo $delete;
+ unlink($delete) or print(" failed to be ");
+ echo 'deleted ';
+ $deletetoo = substr($delete, 0, -3)."mp4";
+ echo $deletetoo;
+ unlink($deletetoo) or print(" failed to be ");
+ echo 'deletedHome ';
+}
+}
+else {
+ $i=1;
+ foreach (glob("*.ipod.xml") as $file) {
+ $lines = file($file);
+ echo ' ';
+ echo ''.$i.' ';
+ echo " ".strip_tags($lines[1])." ".strip_tags($lines[7])." ".strip_tags($lines[6])." ".filesizeparse(filesize(substr($file, 0, -3)."mp4"))." ".'Delete '." ".' '." ";
+ $i++;
+ }
+}
+function filesizeparse($size){
+ $i=0;
+ $iec = array(" B", " KB", " MB", " GB", " TB");
+ while (($size/1024)>1) {
+ $size=$size/1024;
+ $i++;
+ }
+ return substr($size,0,strpos($size,'.')+3).$iec[$i];
+}
+?>
+
+
+
+
diff --git a/abs/extra-testing/myth2ipod/myth2ipod.install b/abs/extra-testing/myth2ipod/myth2ipod.install
index 43e3e78..4a7e046 100755
--- a/abs/extra-testing/myth2ipod/myth2ipod.install
+++ b/abs/extra-testing/myth2ipod/myth2ipod.install
@@ -18,21 +18,17 @@ post_install() {
ln -s /myth/ipodfeed /data/srv/httpd/htdocs/ipodfeed
cp /usr/bin/myth2ipod /tmp
sed -e "s/REPLACEME/$hostname/g" /tmp/myth2ipod > /usr/bin/myth2ipod
+ chown -R mythtv:http /myth/ipodfeed
}
post_upgrade() {
-
-
- mkdir /myth/ipodfeed
- chown mythtv:users /myth/ipodfeed
- ln -s /myth/ipodfeed /data/srv/httpd/htdocs/ipodfeed
/usr/bin/myth2ipod -rebuild
}
post_remove() {
- post_install
+ rm -fr /data/srv/httpd/htdocs/ipodfeed
}
op=$1
--
cgit v0.12
From d93b37285e6ac8c52254e0dc550e0b798f490fbd Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson
Date: Thu, 30 Jul 2009 22:49:20 -0700
Subject: Myt2XviD3:Added archive.php to allow for the deletion of unwanted
videos.
---
abs/extra-testing/myt2xvid3/PKGBUILD | 5 +-
abs/extra-testing/myt2xvid3/archive.php | 159 ++++++++++++++++++++++++++
abs/extra-testing/myt2xvid3/myt2xvid3.install | 10 +-
3 files changed, 164 insertions(+), 10 deletions(-)
create mode 100644 abs/extra-testing/myt2xvid3/archive.php
diff --git a/abs/extra-testing/myt2xvid3/PKGBUILD b/abs/extra-testing/myt2xvid3/PKGBUILD
index ee20990..231d0b3 100755
--- a/abs/extra-testing/myt2xvid3/PKGBUILD
+++ b/abs/extra-testing/myt2xvid3/PKGBUILD
@@ -1,18 +1,19 @@
pkgname=myt2xvid3
pkgver=0.1
-pkgrel=1
+pkgrel=2
arch=("i686")
pkgdesc="A multimedia framework based on the MPEG-4 Systems standard"
url="http://www.knoppmythwiki.org/index.php?page=XvidEncoding"
depends=('nuvexport')
install="myt2xvid3.install"
-source=( myt2xvid3 myt2xvid3-userjob.sh)
+source=( myt2xvid3 myt2xvid3-userjob.sh archive.php)
build() {
cd $startdir/src
install -D -m 755 myt2xvid3 $startdir/pkg/usr/bin/myt2xvid3
install -D -m 755 myt2xvid3-userjob.sh /$startdir/pkg/usr/bin/myt2xvid3-userjob.sh
+ install -D -m 755 archive.php /myth/video/archive/archive.php
}
diff --git a/abs/extra-testing/myt2xvid3/archive.php b/abs/extra-testing/myt2xvid3/archive.php
new file mode 100644
index 0000000..f970868
--- /dev/null
+++ b/abs/extra-testing/myt2xvid3/archive.php
@@ -0,0 +1,159 @@
+
+//archive.php
+// based on m2iweb.php by http://anthony.lusby.us/m2iweb/
+//release 0.1
+//10/05/07
+?>
+
+
+
+ MythWeb - Archive Recordings
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+View and delete recordings transcoded to XviD via Myt2XviD3.
+
+ ';
+ echo $delete;
+ unlink($delete) or print(" failed to be ");
+ echo ' has been deleted, ';
+ $deletetoo = substr($delete, 0, -3)."avi";
+ echo $deletetoo;
+ unlink($deletetoo) or print(" failed to be ");
+ echo ' has been deleted.';
+ echo' ';
+ }
+}
+ $i=1;
+ foreach (glob("*.XviD.xml") as $file) {
+ $lines = file($file);
+ echo ' ';
+ echo ''.$i.' ';
+ echo " ".strip_tags($lines[1])." ".strip_tags($lines[7])." ".strip_tags($lines[6])." ".filesizeparse(filesize(substr($file, 0, -3)."avi"))." ".'Delete '." ".' '." ";
+ $i++;
+ }
+//}
+
+function filesizeparse($size){
+ $i=0;
+ $iec = array(" B", " KB", " MB", " GB", " TB");
+ while (($size/1024)>1) {
+ $size=$size/1024;
+ $i++;
+ }
+ return substr($size,0,strpos($size,'.')+3).$iec[$i];
+}
+?>
+
+
+
diff --git a/abs/extra-testing/myt2xvid3/myt2xvid3.install b/abs/extra-testing/myt2xvid3/myt2xvid3.install
index abc4256..f363fa2 100755
--- a/abs/extra-testing/myt2xvid3/myt2xvid3.install
+++ b/abs/extra-testing/myt2xvid3/myt2xvid3.install
@@ -18,21 +18,15 @@ post_install() {
ln -s /myth/video/archive /data/srv/httpd/htdocs/archive
mv /usr/bin/myt2xvid3 /tmp
sed -e "s/REPLACEME/$HOSTNAME/g" /tmp/myt2xvid3 > /usr/bin/myt2xvid3
-
-
+ chown -R mythtv:http /myth/video/archive
}
post_upgrade() {
-
-
- mkdir /myth/video/archive
- chown mythtv:users /myth/video/archive
- ln -s /myth/video/archive /data/srv/httpd/htdocs/archive
/usr/bin/myth2xvid -rebuild
}
post_remove() {
- post_install
+ rm -fr /data/srv/http/htdocs/archive
}
op=$1
--
cgit v0.12
From 034b43681d72c72120deff06e5577e0d078597af Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson
Date: Thu, 30 Jul 2009 23:35:13 -0700
Subject: MythWeb:Adds myth2ipod and myt2xvid3 in headers.
---
abs/core-testing/mythtv/stable/mythweb/PKGBUILD | 5 +++--
.../mythtv/stable/mythweb/transcoders.patch | 23 ++++++++++++++++++++++
2 files changed, 26 insertions(+), 2 deletions(-)
create mode 100644 abs/core-testing/mythtv/stable/mythweb/transcoders.patch
diff --git a/abs/core-testing/mythtv/stable/mythweb/PKGBUILD b/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
index 3e3d172..20e9e3d 100644
--- a/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
@@ -1,13 +1,13 @@
pkgname=mythweb
pkgver=0.21
-pkgrel=19
+pkgrel=20
pkgdesc="Web interface for MythTV's backend"
arch=('i686' 'x86_64')
url="http://www.mythtv.org"
license=('GPL')
depends=("mythtv>=${pkgver}" 'lighttpd' 'php' 'local-website')
install=mythweb.install
-source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2" wiiweb.tar.bz2)
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2" wiiweb.tar.bz2 transcoders.patch)
md5sums=('1b3e2a97b7ecf7373e162fe20b6faabe')
groups=('mythtv-extras')
DOCROOT=/data/srv/httpd/htdocs/mythweb
@@ -26,6 +26,7 @@ build() {
# Workaround for LIGHTTPD bug in mythweb.pl (affects DB queries)
cd $startdir/src/mythplugins/$pkgname/
patch -p0 < $startdir/patch/mythweb.pl.diff
+ patch -p1 < $startdir/transcoders.patch
cp -r $startdir/src/mythplugins/$pkgname/* $startdir/pkg/$DOCROOT
# cp $startdir/src/mythplugins-$pkgver/$pkgname/data/.htaccess $startdir/pkg/$DOCROOT
diff --git a/abs/core-testing/mythtv/stable/mythweb/transcoders.patch b/abs/core-testing/mythtv/stable/mythweb/transcoders.patch
new file mode 100644
index 0000000..c1aeb6c
--- /dev/null
+++ b/abs/core-testing/mythtv/stable/mythweb/transcoders.patch
@@ -0,0 +1,23 @@
+diff -ruaN mythweb.orig/modules/_shared/lang/English.lang mythweb/modules/_shared/lang/English.lang
+--- mythweb.orig/modules/_shared/lang/English.lang 2009-01-09 02:44:23.000000000 +0000
++++ mythweb/modules/_shared/lang/English.lang 2009-07-31 06:29:11.000000000 +0000
+@@ -816,3 +816,5 @@
+ "Year"
+ "Yes"
+ "Yesterday"
++"Myth2iPod"
++"Myt2XviD3"
+diff -ruaN mythweb.orig/modules/_shared/tmpl/default/header.php mythweb/modules/_shared/tmpl/default/header.php
+--- mythweb.orig/modules/_shared/tmpl/default/header.php 2009-01-09 02:44:23.000000000 +0000
++++ mythweb/modules/_shared/tmpl/default/header.php 2009-07-31 06:28:54.000000000 +0000
+@@ -171,6 +171,10 @@
+
+ |
+
++ |
++
++ |
++
+
+ |
+
--
cgit v0.12
From cabf71982267a825d98e8d39f6bb3be7c693e2ad Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson
Date: Thu, 30 Jul 2009 23:53:55 -0700
Subject: xscreensaver:bumped version to recompile for new libjpeg.
---
abs/extra-testing/xscreensaver/PKGBUILD | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/abs/extra-testing/xscreensaver/PKGBUILD b/abs/extra-testing/xscreensaver/PKGBUILD
index d39aea7..2eb7b7c 100644
--- a/abs/extra-testing/xscreensaver/PKGBUILD
+++ b/abs/extra-testing/xscreensaver/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=xscreensaver
pkgver=5.08
-pkgrel=5
+pkgrel=6
pkgdesc="Screen saver and locker for the X Window System"
arch=('i686' 'x86_64')
url="http://www.jwz.org/xscreensaver/"
--
cgit v0.12
From 7accc0f042acdfdca9f067b1d4011d6ac01b1a74 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson
Date: Fri, 31 Jul 2009 00:23:41 -0700
Subject: nvidia:bumped to recompile.
---
abs/core-testing/nvidia/PKGBUILD | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/abs/core-testing/nvidia/PKGBUILD b/abs/core-testing/nvidia/PKGBUILD
index e8469c8..252a746 100644
--- a/abs/core-testing/nvidia/PKGBUILD
+++ b/abs/core-testing/nvidia/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=nvidia
pkgver=185.18.14
_kernver='2.6.28-LinHES'
-pkgrel=3
+pkgrel=4
pkgdesc="NVIDIA drivers for kernel26."
arch=('i686' 'x86_64')
[ "$CARCH" = "i686" ] && ARCH=x86
--
cgit v0.12
From 1404490c28c12f8be0fef4b3e964ca62e9bf9dd0 Mon Sep 17 00:00:00 2001
From: James Meyer
Date: Fri, 31 Jul 2009 22:12:01 -0500
Subject: wireshark: add to extra
---
abs/extra-testing/wireshark/PKGBUILD | 26 ++++++++++++++++++++++++++
abs/extra-testing/wireshark/wireshark.desktop | 10 ++++++++++
abs/extra-testing/wireshark/wireshark.png | Bin 0 -> 18535 bytes
3 files changed, 36 insertions(+)
create mode 100644 abs/extra-testing/wireshark/PKGBUILD
create mode 100644 abs/extra-testing/wireshark/wireshark.desktop
create mode 100644 abs/extra-testing/wireshark/wireshark.png
diff --git a/abs/extra-testing/wireshark/PKGBUILD b/abs/extra-testing/wireshark/PKGBUILD
new file mode 100644
index 0000000..4b7a88c
--- /dev/null
+++ b/abs/extra-testing/wireshark/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 34765 2009-04-11 14:17:32Z hugo $
+# Maintainer: Hugo Doria
+
+pkgname=wireshark
+pkgver=1.2.0
+pkgrel=3
+pkgdesc="A free network protocol analyzer for Unix/Linux and Windows"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('gtk2>=2.14.5' 'heimdal>=1.2.1' 'libpcap>=1.0.0' 'bash' 'gnutls>=2.4.1' 'libcap>=2.16')
+makedepends=('bison' 'flex')
+url="http://www.wireshark.org/"
+replaces=('ethereal')
+options=(!libtool)
+source=(http://www.wireshark.org/download/src/${pkgname}-${pkgver}.tar.gz wireshark.desktop wireshark.png)
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ export CFLAGS="-fno-unit-at-a-time ${CFLAGS}"
+ ./configure --prefix=/usr --with-ssl || return 1
+ make all || return 1
+ make DESTDIR=${pkgdir} install || return 1
+
+ install -Dm644 ${srcdir}/wireshark.png ${pkgdir}/usr/share/icons/wireshark.png
+ install -Dm644 ${srcdir}/wireshark.desktop ${pkgdir}/usr/share/applications/wireshark.desktop
+}
diff --git a/abs/extra-testing/wireshark/wireshark.desktop b/abs/extra-testing/wireshark/wireshark.desktop
new file mode 100644
index 0000000..f4317f6
--- /dev/null
+++ b/abs/extra-testing/wireshark/wireshark.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+GenericName=Wireshark
+Comment=Network protocol analyzer
+Name=wireshark
+Exec=wireshark
+Icon=/usr/share/icons/wireshark.png
+Type=Application
+Terminal=false
+Categories=Application;Network;
diff --git a/abs/extra-testing/wireshark/wireshark.png b/abs/extra-testing/wireshark/wireshark.png
new file mode 100644
index 0000000..4e40263
Binary files /dev/null and b/abs/extra-testing/wireshark/wireshark.png differ
--
cgit v0.12
From ad8df64823af09c36fa9f7369bb6e70ed8f3beda Mon Sep 17 00:00:00 2001
From: James Meyer
Date: Fri, 31 Jul 2009 22:12:29 -0500
Subject: dhcpcd: updated to 5.0.7. This includes the fix to force hostname for
dhcp
---
abs/core-testing/dhcpcd/PKGBUILD | 61 +++++++++++++++++++++++++++-------------
1 file changed, 41 insertions(+), 20 deletions(-)
diff --git a/abs/core-testing/dhcpcd/PKGBUILD b/abs/core-testing/dhcpcd/PKGBUILD
index dfc1914..1cfb7f9 100644
--- a/abs/core-testing/dhcpcd/PKGBUILD
+++ b/abs/core-testing/dhcpcd/PKGBUILD
@@ -1,27 +1,48 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: judd
+
pkgname=dhcpcd
-pkgver=3.2.1
-pkgrel=10
-pkgdesc="A DHCP client daemon"
-arch=(i686 x86_64)
+pkgver=5.0.7
+pkgrel=1
+pkgdesc="RFC2131 compliant DHCP client daemon"
+url="http://roy.marples.name/dhcpcd/"
+arch=('i686' 'x86_64')
license=('BSD')
-url="http://roy.marples.name/dhcpcd"
groups=('base')
-depends=('glibc')
-backup=('etc/conf.d/dhcpcd')
-source=(http://roy.marples.name/dhcpcd/$pkgname-$pkgver.tar.bz2
- dhcpcd.conf.d)
-md5sums=('5a437882b6b9eb29bde323dc411be4a4'
- '12d866a78d9f5fa5f31ca18b3940d847')
+depends=('glibc' 'bash')
+backup=('etc/conf.d/dhcpcd' 'etc/dhcpcd.conf')
+options=('emptydirs') # We Need the Empty /var/lib/dhcpcd Directory
+source=("http://roy.marples.name/downloads/$pkgname/$pkgname-$pkgver.tar.bz2" \
+ 'dhcpcd.conf.d')
build() {
- cd $startdir/src/$pkgname-$pkgver
- #disable DUID usage
- echo "#undef ENABLE_DUID" >> config.h
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # Fix Installation Locations
+ export PREFIX=/usr
+ sed -i 's/${PREFIX}\/etc/\/etc/' Makefile || return 1
+ sed -i 's/\/db/\/lib\/dhcpcd/' Makefile || return 1
+ sed -i 's/\/libexec/\/lib\/dhcpcd/' Makefile || return 1
+ sed -i 's/\/libexec/\/lib\/dhcpcd/' dhcpcd-hooks/Makefile || return 1
+ sed -i 's/${PREFIX}\/sbin/\/sbin/' Makefile || return 1
+
+ # Build
make || return 1
- make DESTDIR=$startdir/pkg install
- mkdir -p $startdir/pkg/usr/sbin
- ln -sf /sbin/dhcpcd $startdir/pkg/usr/sbin/dhcpcd
- install -D -m644 ../dhcpcd.conf.d $startdir/pkg/etc/conf.d/dhcpcd
+ make DESTDIR=${pkgdir} install || return 1
+
+ # Create Binary Symlink
+ install -d ${pkgdir}/usr/sbin || return 1
+ ln -sf /sbin/dhcpcd ${pkgdir}/usr/sbin/dhcpcd || return 1
+
+ # Install Configuration File used in /etc/rc.d/network
+ install -D -m644 ../dhcpcd.conf.d $pkgdir/etc/conf.d/$pkgname || return 1
+
+ # Install License
+ install -d $pkgdir/usr/share/licenses/$pkgname || return 1
+ awk '{if(FNR<27)print $0}' ${srcdir}/${pkgname}-${pkgver}/config.h \
+ >> ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE || return 1
+
+ # Make Man Pages FHS Compliant
+ mv -f ${pkgdir}/usr/man ${pkgdir}/usr/share/man || return 1
+
+ # Set Options in /etc/dhcpcd.conf
+ echo noipv4ll >> ${pkgdir}/etc/dhcpcd.conf || return 1 # Disable ip4vall
}
--
cgit v0.12
From db2c1433cfbd4fde1af9ffe3ad1e3d74dea8557e Mon Sep 17 00:00:00 2001
From: James Meyer
Date: Fri, 31 Jul 2009 22:12:52 -0500
Subject: dhcp: version 4.1
---
abs/core-testing/dhcp/ChangeLog | 8 ++++
abs/core-testing/dhcp/PKGBUILD | 33 ++++++--------
abs/core-testing/dhcp/dhcp-3.0.3-tr.c.patch | 10 -----
.../dhcp/dhcp-4.1.0-missing-ipv6-not-fatal.patch | 50 ++++++++++++++++++++++
abs/core-testing/dhcp/dhcp.conf.d | 6 +++
abs/core-testing/dhcp/dhcpd | 3 +-
6 files changed, 79 insertions(+), 31 deletions(-)
create mode 100644 abs/core-testing/dhcp/ChangeLog
delete mode 100644 abs/core-testing/dhcp/dhcp-3.0.3-tr.c.patch
create mode 100644 abs/core-testing/dhcp/dhcp-4.1.0-missing-ipv6-not-fatal.patch
create mode 100644 abs/core-testing/dhcp/dhcp.conf.d
diff --git a/abs/core-testing/dhcp/ChangeLog b/abs/core-testing/dhcp/ChangeLog
new file mode 100644
index 0000000..7b9cb47
--- /dev/null
+++ b/abs/core-testing/dhcp/ChangeLog
@@ -0,0 +1,8 @@
+
+2009-07-19 K. Piche
+ * dhcp 4.1.0.p1-1
+ * Adopted RedHat patch to fix bug where dhcpd won't start if ipv6 module
+ is not loaded. Fixes FS#12792.
+ * Added /etc/conf.d/dhcp feature contributed by Fabiano Furtado Pessoa
+ Coelho
+
diff --git a/abs/core-testing/dhcp/PKGBUILD b/abs/core-testing/dhcp/PKGBUILD
index f426778..db15ac3 100644
--- a/abs/core-testing/dhcp/PKGBUILD
+++ b/abs/core-testing/dhcp/PKGBUILD
@@ -1,46 +1,39 @@
-# $Id: PKGBUILD 23123 2009-01-03 02:43:02Z kevin $
+# $Id: PKGBUILD 46754 2009-07-20 03:16:44Z kevin $
# Maintainer: judd
pkgname=dhcp
-pkgver=4.1.0
+# separate patch levels with a period to maintain proper versioning.
+pkgver=4.1.0.p1
+_pkgver=4.1.0p1
pkgrel=1
pkgdesc="A DHCP server, client, and relay agent"
arch=(i686 x86_64)
license=('custom:isc-dhcp')
-url="http://www.isc.org/sw/dhcp/"
+url="https://www.isc.org/software/dhcp"
depends=('openssl>=0.9.8a')
-backup=('etc/dhcpd.conf' 'etc/dhclient.conf')
+backup=('etc/dhcpd.conf' 'etc/conf.d/dhcp')
install=dhcp.install
-source=(http://ftp.isc.org/isc/dhcp/dhcp-${pkgver}.tar.gz dhcp-3.0.3-tr.c.patch
-dhcpd)
-md5sums=('1fffed2e8c3d67b111316d6a9b33db7a' '39866416303b674df08b66b2d094e523'
- '025b8fe98b6c0814428b671b1819a810')
+source=(http://ftp.isc.org/isc/${pkgname}/${pkgname}-${_pkgver}.tar.gz
+dhcpd dhcp.conf.d dhcp-4.1.0-missing-ipv6-not-fatal.patch)
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- patch -p1 -i ../dhcp-3.0.3-tr.c.patch || return 1
+ cd ${srcdir}/${pkgname}-${_pkgver}
# Define _GNU_SOURCE to fix IPV6.
sed '/^CFLAGS="$CFLAGS/ s/INGS"/INGS -D_GNU_SOURCE"/' -i configure
+ # Make not having ipv6 non-fatal.
+ patch -Np1 -i ${srcdir}/dhcp-4.1.0-missing-ipv6-not-fatal.patch
./configure --prefix=/usr --sysconfdir=/etc \
--with-srv-lease-file=/var/state/dhcp/dhcpd.leases \
--with-srv6-lease-file=/var/state/dhcp/dhcpd6.leases
make || return 1
make DESTDIR=${pkgdir} install
- #install -D -m644 server/dhcpd.conf ${pkgdir}/etc/dhcpd.conf
- #install -D -m644 client/dhclient.conf ${pkgdir}/etc/dhclient.conf
install -D -m755 ${srcdir}/dhcpd ${pkgdir}/etc/rc.d/dhcpd
+ install -D -m644 ${srcdir}/dhcp.conf.d ${pkgdir}/etc/conf.d/${pkgname}
mkdir -p ${pkgdir}/var/state/dhcp
- #touch ${pkgdir}/var/state/dhcp/dhcpd.leases
- #chmod -R 644 ${pkgdir}/usr/share/man/*
- #chmod 755 ${pkgdir}/usr/share/man/man{1,3,5,8}
- #sed -i 's|etc/dhclient-script|sbin/dhclient-script|g' \
- #${pkgdir}/etc/dhclient.conf
- #rm -f ${pkgdir}/var/state/dhcp/dhcpd.leases
- #rm -f ${pkgdir}/sbin/{dhclient,dhclient-script}
rm -f ${pkgdir}/etc/dhclient.conf
rm -f ${pkgdir}/usr/sbin/dhclient
rm -f ${pkgdir}/usr/share/man/man{5,8}/dhclient*
# install licenses
- install -m644 -D ${srcdir}/${pkgname}-${pkgver}/LICENSE \
+ install -m644 -D ${srcdir}/${pkgname}-${_pkgver}/LICENSE \
${pkgdir}/usr/share/licenses/dhcp/LICENSE
}
diff --git a/abs/core-testing/dhcp/dhcp-3.0.3-tr.c.patch b/abs/core-testing/dhcp/dhcp-3.0.3-tr.c.patch
deleted file mode 100644
index e262c5e..0000000
--- a/abs/core-testing/dhcp/dhcp-3.0.3-tr.c.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- work.linux-2.2/common/tr.c 2005/08/14 11:34:24 1.1
-+++ work.linux-2.2/common/tr.c 2005/08/14 11:35:16
-@@ -40,6 +40,7 @@ static char copyright[] =
- #include "includes/netinet/if_ether.h"
- #include "netinet/if_tr.h"
- #include
-+#include
-
- /*
- * token ring device handling subroutines. These are required as token-ring
diff --git a/abs/core-testing/dhcp/dhcp-4.1.0-missing-ipv6-not-fatal.patch b/abs/core-testing/dhcp/dhcp-4.1.0-missing-ipv6-not-fatal.patch
new file mode 100644
index 0000000..ebf3865
--- /dev/null
+++ b/abs/core-testing/dhcp/dhcp-4.1.0-missing-ipv6-not-fatal.patch
@@ -0,0 +1,50 @@
+diff -Naur dhcp-4.1.0a2/common/discover.c dhcp-4.1.0a2-mcn/common/discover.c
+--- dhcp-4.1.0a2/common/discover.c 2008-08-29 18:48:57.000000000 +0100
++++ dhcp-4.1.0a2-mcn/common/discover.c 2008-10-02 13:02:06.000000000 +0100
+@@ -443,15 +443,17 @@
+ }
+
+ #ifdef DHCPv6
+- ifaces->fp6 = fopen("/proc/net/if_inet6", "r");
+- if (ifaces->fp6 == NULL) {
+- log_error("Error opening '/proc/net/if_inet6' to "
+- "list IPv6 interfaces; %m");
+- close(ifaces->sock);
+- ifaces->sock = -1;
+- fclose(ifaces->fp);
+- ifaces->fp = NULL;
+- return 0;
++ if (local_family == AF_INET6) {
++ ifaces->fp6 = fopen("/proc/net/if_inet6", "r");
++ if (ifaces->fp6 == NULL) {
++ log_error("Error opening '/proc/net/if_inet6' to "
++ "list IPv6 interfaces; %m");
++ close(ifaces->sock);
++ ifaces->sock = -1;
++ fclose(ifaces->fp);
++ ifaces->fp = NULL;
++ return 0;
++ }
+ }
+ #endif
+
+@@ -720,7 +722,8 @@
+ }
+ #ifdef DHCPv6
+ if (!(*err)) {
+- return next_iface6(info, err, ifaces);
++ if (local_family == AF_INET6)
++ return next_iface6(info, err, ifaces);
+ }
+ #endif
+ return 0;
+@@ -736,7 +739,8 @@
+ close(ifaces->sock);
+ ifaces->sock = -1;
+ #ifdef DHCPv6
+- fclose(ifaces->fp6);
++ if (local_family == AF_INET6)
++ fclose(ifaces->fp6);
+ ifaces->fp6 = NULL;
+ #endif
+ }
diff --git a/abs/core-testing/dhcp/dhcp.conf.d b/abs/core-testing/dhcp/dhcp.conf.d
new file mode 100644
index 0000000..99ba6d1
--- /dev/null
+++ b/abs/core-testing/dhcp/dhcp.conf.d
@@ -0,0 +1,6 @@
+#
+# Arguments to be passed to the DHCP server daemon
+#
+
+DHCP_ARGS="-q"
+
diff --git a/abs/core-testing/dhcp/dhcpd b/abs/core-testing/dhcp/dhcpd
index 0aebcc8..1fbb31e 100755
--- a/abs/core-testing/dhcp/dhcpd
+++ b/abs/core-testing/dhcp/dhcpd
@@ -2,6 +2,7 @@
. /etc/rc.conf
. /etc/rc.d/functions
+. /etc/conf.d/dhcp
PIDFILE="/var/run/dhcpd.pid"
PID=`cat $PIDFILE 2>/dev/null`
@@ -9,7 +10,7 @@ case "$1" in
start)
stat_busy "Starting DHCP Server"
if [ "$PID" = "" ]; then
- /usr/sbin/dhcpd -q
+ /usr/sbin/dhcpd $DHCP_ARGS
fi
if [ "$PID" != "" -o $? -gt 0 ]; then
stat_fail
--
cgit v0.12
From 7e10f51870aa10be3b35d7912a7b54e30f608bb8 Mon Sep 17 00:00:00 2001
From: James Meyer
Date: Fri, 31 Jul 2009 22:13:23 -0500
Subject: linhes-config: probe network on install boot for parms
---
abs/core-testing/LinHES-config/PKGBUILD | 2 +-
.../LinHES-config/install_functions.sh | 35 ++++++++++++++++++----
2 files changed, 31 insertions(+), 6 deletions(-)
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 9486462..ba324ee 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.0
-pkgrel=57
+pkgrel=62
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo python-pexpect python-netifaces LinHES-timezone python-iplib)
diff --git a/abs/core-testing/LinHES-config/install_functions.sh b/abs/core-testing/LinHES-config/install_functions.sh
index ea9e61c..a5f4122 100755
--- a/abs/core-testing/LinHES-config/install_functions.sh
+++ b/abs/core-testing/LinHES-config/install_functions.sh
@@ -197,6 +197,15 @@ function rest_of_network () {
else
printhl " DNS not found"
fi
+ echo $CMDLINE | grep -q chostname
+ if [ $? -eq 0 ]
+ then
+ TEMPVAR=${CMDLINE#*chostname=}
+ MYHOST=${TEMPVAR%% *}
+ update_db_settings HostMyhostname "$MYHOST"
+ else
+ printhl " hostname not found"
+ fi
}
function init_network {
@@ -256,6 +265,14 @@ function dev_up_check(){
}
function request_dhcp(){
+ echo $CMDLINE |grep -q cnetdev
+ if [ $? -eq 0 ]
+ then
+ TEMPVAR=${CMDLINE#*cnetdev=}
+ MYTHDEFAULT_NET=${TEMPVAR%% *}
+ else
+ MYTHDEFAULT_NET="eth0"
+ fi
for ndev in eth0 eth1 wlan0 wlan1 ath0
do
dev_up_check $ndev
@@ -263,22 +280,30 @@ function request_dhcp(){
if [ $status -eq 1 ]
then
#interface is down, lets see if dhcp responds
- dhcpcd -Td -t2 $ndev > /tmp/dhcpinfo.$ndev
- TEMPVAR=`grep IPADDR /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ dhcpcd -Td -t2 $ndev -h "" > /tmp/dhcpinfo.$ndev
+ #check for hostname here
+
+ TEMPVAR=`grep new_ip_address /tmp/dhcpinfo.$ndev |cut -d\= -f2`
if [ ! x$TEMPVAR = x ]
then
update_db_settings HostIP$ndev "$TEMPVAR"
- TEMPVAR=`grep NETMASK /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ TEMPVAR=`grep new_subnet_mask /tmp/dhcpinfo.$ndev |cut -d\= -f2`
nm=`/usr/bin/nmconv.py -obits $TEMPVAR`
TEMPVAR="/$nm $TEMPVAR"
update_db_settings HostNETMASK$ndev "$TEMPVAR"
- TEMPVAR=`grep GATEWAYS /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ TEMPVAR=`grep new_routers /tmp/dhcpinfo.$ndev |cut -d\= -f2`
update_db_settings HostGW$ndev "$TEMPVAR"
- TEMPVAR=`grep DNSSERVERS /tmp/dhcpinfo.$ndev |cut -d\' -f2`
+ TEMPVAR=`grep new_domain_name_servers /tmp/dhcpinfo.$ndev |cut -d\= -f2`
update_db_settings HostDNS$ndev "$TEMPVAR"
fi
fi
done
+ TEMPVAR=`grep new_host_name /tmp/dhcpinfo.$MYTHDEFAULT_NET |cut -d\= -f2`
+ if [ ! x$TEMPVAR = x ]
+ then
+ update_db_settings HostMyhostname "$TEMPVAR"
+ fi
+
}
function init_remote {
--
cgit v0.12
From ac63926cf72b4018ffc24fc69e4d56cfdffb75c5 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson
Date: Sat, 1 Aug 2009 15:15:50 -0700
Subject: Local-website:updates for myth2ipod and myt2xvid3.
---
abs/core-testing/local-website/PKGBUILD | 2 +-
abs/core-testing/local-website/htdocs/index.html | 46 ++++++++++++------------
2 files changed, 23 insertions(+), 25 deletions(-)
diff --git a/abs/core-testing/local-website/PKGBUILD b/abs/core-testing/local-website/PKGBUILD
index a47c062..c596881 100644
--- a/abs/core-testing/local-website/PKGBUILD
+++ b/abs/core-testing/local-website/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=local-website
pkgver=2
-pkgrel=8
+pkgrel=9
pkgdesc="Contents of http://localhost"
arch=(i686 x86_64)
license=('GPL')
diff --git a/abs/core-testing/local-website/htdocs/index.html b/abs/core-testing/local-website/htdocs/index.html
index 14d5c22..c77629d 100644
--- a/abs/core-testing/local-website/htdocs/index.html
+++ b/abs/core-testing/local-website/htdocs/index.html
@@ -1,6 +1,7 @@
-
-
-
+
+
+
+
@@ -11,13 +12,10 @@
- LinHES R6
-
-
-
-
+
+ LinHES R6
-
+
@@ -34,7 +32,7 @@
- MythWeb :
+
MythWeb :
The MythWeb allows you to use a web page to control
aspects of your MythTV system. MythWeb is a separate application,
@@ -42,7 +40,7 @@
- MythTV Web Virtual Remote :
+
MythTV Web Virtual Remote :
A web based virtual remote control for MythTV.
In order for this to work, you must enable
@@ -51,26 +49,26 @@
- MythTV Documentation :
+
MythTV Documentation :
The MythTV Installation / User's Guide.
- MythTV Keybindings :
+
MythTV Keybindings :
The keybindings for the normal MythTV interface.
- LinHES :
+
LinHES :
Describes how "The Project Leader" setup multiple systems
to form a Lin ux H ome E ntertainment S ystem.
- My Folding Status :
+
My Folding Status :
Status of the folding@home work for the local user.
@@ -82,24 +80,25 @@
- iPod Feeds
+
iPod Feeds
- Transcodes ready for the ipod (if any).
-XviD Feed dir
- Any programs you transcodes to XviD.
- FUPPES
+ Transcodes ready for the ipod (if any). Additionally, you can delete unwanted files using this link . Note: If you have no recordings, you will see a warning issued from PHP.
+XviD Feed dir
+ Any programs you have transcoded to XviD.
+ Additionally, you can delete unwanted files using this link . Note: If you have no recordings, you will see a warning issued from PHP.
+ FUPPES
FUPPES - Free UPnP Entertainment Service. A
UPnP to be used inplace of the UPnP server that comes with MythTV.
If the UPnP that comes with MythTV doesn't work for you, you can
try FUPPES.
-
RRDTool :
+
RRDTool :
Hardware status graphs.
- KnoppMyth Radio :
+
KnoppMyth Radio :
Your music must be encoded as MP3 in MythMusic for this to work.
@@ -114,5 +113,4 @@ try FUPPES.
-
-
+