summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-system
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-04-02 19:12:12 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-04-02 19:12:12 (GMT)
commit73f7ddc1f26796682680a0a1cf62dd32240db0a0 (patch)
tree1e21df52fe1d4ebac2c036ae4d342027110f8103 /abs/core-testing/LinHES-system
parent92f537738732734d5b727f10421eef59d0a152ee (diff)
downloadlinhes_pkgbuild-73f7ddc1f26796682680a0a1cf62dd32240db0a0.zip
linhes_pkgbuild-73f7ddc1f26796682680a0a1cf62dd32240db0a0.tar.gz
linhes_pkgbuild-73f7ddc1f26796682680a0a1cf62dd32240db0a0.tar.bz2
LinHES-system: general cleanup of boot and of course Hauppauge!!
Diffstat (limited to 'abs/core-testing/LinHES-system')
-rw-r--r--abs/core-testing/LinHES-system/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-system/load-modules-mythvantage.sh26
2 files changed, 21 insertions, 7 deletions
diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index 49f325f..f984a86 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=1.0
-pkgrel=46
+pkgrel=48
arch=('i686')
MVDIR=$startdir/pkg/usr/LH
BINDIR=$startdir/pkg/usr/bin
diff --git a/abs/core-testing/LinHES-system/load-modules-mythvantage.sh b/abs/core-testing/LinHES-system/load-modules-mythvantage.sh
index 8382a29..142f7c2 100755
--- a/abs/core-testing/LinHES-system/load-modules-mythvantage.sh
+++ b/abs/core-testing/LinHES-system/load-modules-mythvantage.sh
@@ -16,17 +16,31 @@ UNLOAD|unload )
#try to load the cx88 modules
if [ ! x$SystemType = xFrontend_only ]
then
- /sbin/modprobe cx88-dvb 2>/dev/null
+ /sbin/modprobe cx88-dvb 2>/dev/null
fi
if [ -f /etc/modules.mythvantage ]
then
- while read line
- do
+ while read line
+ do
module=`echo $line |cut -d# -f1`
- /sbin/modprobe $module
-
- done < /etc/modules.mythvantage
+ #this doesn't do anything on boot cause ttySX does not yet exisit
+ if [ x$module = xlirc_serial ]
+ then
+ if [ x$ReceiverType = xSerial ]
+ then
+ case $ReceiverSerialport in
+ ttyS0) FLAGS="io=0x3f8 irq=4";;
+ ttyS1) FLAGS="io=0x2f8 irq=3" ;;
+ ttyS2) FLAGS="io=0x3e8 irq=4" ;;
+ ttyS3) FLAGS="io=0x2f8 irq=3" ;;
+ esac
+ /usr/bin/setserial /dev/$ReceiverSerialport uart none 2>/dev/null
+ /sbin/modprobe lirc_serial $FLAGS 2>/dev/null
+ fi
+ fi
+ /sbin/modprobe $module 2> /dev/null
+ done < /etc/modules.mythvantage
fi
esac