summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/LinHES-system
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/LinHES-system')
-rw-r--r--abs/core-testing/LinHES-system/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-system/load-modules-mythvantage.sh26
2 files changed, 21 insertions, 7 deletions
diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index 49f325f..f984a86 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=1.0
-pkgrel=46
+pkgrel=48
arch=('i686')
MVDIR=$startdir/pkg/usr/LH
BINDIR=$startdir/pkg/usr/bin
diff --git a/abs/core-testing/LinHES-system/load-modules-mythvantage.sh b/abs/core-testing/LinHES-system/load-modules-mythvantage.sh
index 8382a29..142f7c2 100755
--- a/abs/core-testing/LinHES-system/load-modules-mythvantage.sh
+++ b/abs/core-testing/LinHES-system/load-modules-mythvantage.sh
@@ -16,17 +16,31 @@ UNLOAD|unload )
#try to load the cx88 modules
if [ ! x$SystemType = xFrontend_only ]
then
- /sbin/modprobe cx88-dvb 2>/dev/null
+ /sbin/modprobe cx88-dvb 2>/dev/null
fi
if [ -f /etc/modules.mythvantage ]
then
- while read line
- do
+ while read line
+ do
module=`echo $line |cut -d# -f1`
- /sbin/modprobe $module
-
- done < /etc/modules.mythvantage
+ #this doesn't do anything on boot cause ttySX does not yet exisit
+ if [ x$module = xlirc_serial ]
+ then
+ if [ x$ReceiverType = xSerial ]
+ then
+ case $ReceiverSerialport in
+ ttyS0) FLAGS="io=0x3f8 irq=4";;
+ ttyS1) FLAGS="io=0x2f8 irq=3" ;;
+ ttyS2) FLAGS="io=0x3e8 irq=4" ;;
+ ttyS3) FLAGS="io=0x2f8 irq=3" ;;
+ esac
+ /usr/bin/setserial /dev/$ReceiverSerialport uart none 2>/dev/null
+ /sbin/modprobe lirc_serial $FLAGS 2>/dev/null
+ fi
+ fi
+ /sbin/modprobe $module 2> /dev/null
+ done < /etc/modules.mythvantage
fi
esac