summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/live-installer
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-07 04:19:29 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-07 04:19:29 (GMT)
commit96544bc44e472422bdc878e6d943391155bbbc35 (patch)
treed4d2f5e3db547adf0a6eac5ecf083715f14bb3e8 /abs/core-testing/live-installer
parent1b44c636c6e5e251c263d5ccac938b378e17d3a4 (diff)
downloadlinhes_pkgbuild-96544bc44e472422bdc878e6d943391155bbbc35.zip
linhes_pkgbuild-96544bc44e472422bdc878e6d943391155bbbc35.tar.gz
linhes_pkgbuild-96544bc44e472422bdc878e6d943391155bbbc35.tar.bz2
km->linhes upgrade now supporting timezone.
Diffstat (limited to 'abs/core-testing/live-installer')
-rwxr-xr-xabs/core-testing/live-installer/PKGBUILD2
-rwxr-xr-xabs/core-testing/live-installer/install_functions.sh4
-rwxr-xr-xabs/core-testing/live-installer/install_proxy.sh17
3 files changed, 22 insertions, 1 deletions
diff --git a/abs/core-testing/live-installer/PKGBUILD b/abs/core-testing/live-installer/PKGBUILD
index 991e572..b8fc206 100755
--- a/abs/core-testing/live-installer/PKGBUILD
+++ b/abs/core-testing/live-installer/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=live-installer
pkgver=1.0
-pkgrel=90
+pkgrel=93
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan)
arch=('i686')
diff --git a/abs/core-testing/live-installer/install_functions.sh b/abs/core-testing/live-installer/install_functions.sh
index 511dc16..e5912da 100755
--- a/abs/core-testing/live-installer/install_functions.sh
+++ b/abs/core-testing/live-installer/install_functions.sh
@@ -438,6 +438,10 @@ case $1 in
umount \/$mountpoint/myth
umount \/$mountpoint
;;
+ update_db_it )
+ update_db_settings "$2" "$3"
+ ;;
+
esac
diff --git a/abs/core-testing/live-installer/install_proxy.sh b/abs/core-testing/live-installer/install_proxy.sh
index ae31d5b..bc89a1d 100755
--- a/abs/core-testing/live-installer/install_proxy.sh
+++ b/abs/core-testing/live-installer/install_proxy.sh
@@ -358,8 +358,25 @@ echo "-----------------------------------------------------------------------3--
$MV_ROOT/bin/restore_default_settings.sh -c restore -t syssettings -h $MVHOSTNAME -d 127.0.0.1
else
cp -rf /new_boot/etc /tmp/etc
+ #now we search for the timezone and try to update
+ TZREGION=`cat /tmp/etc/timezone | cut -d"/" -f1`
+ TZSUB=`cat /tmp/etc/timezone | cut -d"/" -f2 -`
+
+
+ if [ $TZREGION = $TZSUB ]
+ then
+ $run update_db_it HostTimeZoneRegion "$TZREGION"
+ else
+ $run update_db_it HostTimeZoneRegion "$TZREGION"
+ $run update_db_it HostTimeZoneRegion_$TZREGION "$TZSUB"
+ fi
+
+
+
fi
+
+
$run umount_it $disk
;;