summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/live-installer
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/live-installer')
-rwxr-xr-xabs/core-testing/live-installer/PKGBUILD2
-rwxr-xr-xabs/core-testing/live-installer/install_functions.sh4
-rwxr-xr-xabs/core-testing/live-installer/install_proxy.sh17
3 files changed, 22 insertions, 1 deletions
diff --git a/abs/core-testing/live-installer/PKGBUILD b/abs/core-testing/live-installer/PKGBUILD
index 991e572..b8fc206 100755
--- a/abs/core-testing/live-installer/PKGBUILD
+++ b/abs/core-testing/live-installer/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=live-installer
pkgver=1.0
-pkgrel=90
+pkgrel=93
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan)
arch=('i686')
diff --git a/abs/core-testing/live-installer/install_functions.sh b/abs/core-testing/live-installer/install_functions.sh
index 511dc16..e5912da 100755
--- a/abs/core-testing/live-installer/install_functions.sh
+++ b/abs/core-testing/live-installer/install_functions.sh
@@ -438,6 +438,10 @@ case $1 in
umount \/$mountpoint/myth
umount \/$mountpoint
;;
+ update_db_it )
+ update_db_settings "$2" "$3"
+ ;;
+
esac
diff --git a/abs/core-testing/live-installer/install_proxy.sh b/abs/core-testing/live-installer/install_proxy.sh
index ae31d5b..bc89a1d 100755
--- a/abs/core-testing/live-installer/install_proxy.sh
+++ b/abs/core-testing/live-installer/install_proxy.sh
@@ -358,8 +358,25 @@ echo "-----------------------------------------------------------------------3--
$MV_ROOT/bin/restore_default_settings.sh -c restore -t syssettings -h $MVHOSTNAME -d 127.0.0.1
else
cp -rf /new_boot/etc /tmp/etc
+ #now we search for the timezone and try to update
+ TZREGION=`cat /tmp/etc/timezone | cut -d"/" -f1`
+ TZSUB=`cat /tmp/etc/timezone | cut -d"/" -f2 -`
+
+
+ if [ $TZREGION = $TZSUB ]
+ then
+ $run update_db_it HostTimeZoneRegion "$TZREGION"
+ else
+ $run update_db_it HostTimeZoneRegion "$TZREGION"
+ $run update_db_it HostTimeZoneRegion_$TZREGION "$TZSUB"
+ fi
+
+
+
fi
+
+
$run umount_it $disk
;;