summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythinstall
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-16 02:10:33 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-16 02:10:33 (GMT)
commit9fcda2eebb7c5d83a03fd7d4bfad9fe16988d004 (patch)
tree92574c0e9309281265ff12104ed74646eb7aafe9 /abs/core-testing/mythinstall
parent620cb6800d15e6b2b0738b6cdd29080d2685f70b (diff)
downloadlinhes_pkgbuild-9fcda2eebb7c5d83a03fd7d4bfad9fe16988d004.zip
linhes_pkgbuild-9fcda2eebb7c5d83a03fd7d4bfad9fe16988d004.tar.gz
linhes_pkgbuild-9fcda2eebb7c5d83a03fd7d4bfad9fe16988d004.tar.bz2
mythinstall: add help message for initial res setting
Diffstat (limited to 'abs/core-testing/mythinstall')
-rw-r--r--abs/core-testing/mythinstall/PKGBUILD2
-rwxr-xr-xabs/core-testing/mythinstall/xorgsettings.h8
2 files changed, 8 insertions, 2 deletions
diff --git a/abs/core-testing/mythinstall/PKGBUILD b/abs/core-testing/mythinstall/PKGBUILD
index 6fea8ed..75654f1 100644
--- a/abs/core-testing/mythinstall/PKGBUILD
+++ b/abs/core-testing/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jams
pkgname=mythinstall
pkgver=1
-pkgrel=8
+pkgrel=9
pkgdesc="LinHES installer/systemconfig GUI."
arch=i686
depends=()
diff --git a/abs/core-testing/mythinstall/xorgsettings.h b/abs/core-testing/mythinstall/xorgsettings.h
index b9513fd..4a4ed34 100755
--- a/abs/core-testing/mythinstall/xorgsettings.h
+++ b/abs/core-testing/mythinstall/xorgsettings.h
@@ -105,6 +105,7 @@ static HostComboBox *HostXres()
const int num_defaults = 2;
char *defaults[num_defaults]={"800x600","1280x720"};
int defaults_added[num_defaults]={0,0};
+ int found_modes_in_xorg_log = FALSE;
gc->addSelection("Auto");
@@ -153,6 +154,7 @@ static HostComboBox *HostXres()
strncpy (previous_mode, separator, 200);
gc->addSelection(separator, line_in);
+ found_modes_in_xorg_log = TRUE;
for (int def = 0; def < num_defaults; def++)
if (strncmp (&line_in[1], defaults[def], strlen (defaults[def]))==0)
@@ -166,6 +168,10 @@ static HostComboBox *HostXres()
if (!defaults_added[def])
gc->addSelection(defaults[def], defaults[def]);
- gc->setHelpText(QObject::tr(""));
+ if (found_modes_in_xorg_log)
+ gc->setHelpText(QObject::tr("Choose a resolution to match your display and a refresh rate to match the content you will be recording - 60 Hz for NTSC (e.g. US) 50 Hz for PAL (e.g. UK, Aust, NZ)."));
+ else
+ gc->setHelpText(QObject::tr("Choose the resolution to use when the system reboots."));
+
return gc;
}