summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-09-26 18:52:37 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-09-26 18:52:37 (GMT)
commitfe2a6a4009b2d53946c1e6c8ed9187e82a3b2fb0 (patch)
tree6bf028253a975ca04c0a2c191214a55be84c1de2 /abs/core/LinHES-system
parent38859c2f1949b928c648f5f4e1ad709e96a7a503 (diff)
downloadlinhes_pkgbuild-fe2a6a4009b2d53946c1e6c8ed9187e82a3b2fb0.zip
linhes_pkgbuild-fe2a6a4009b2d53946c1e6c8ed9187e82a3b2fb0.tar.gz
linhes_pkgbuild-fe2a6a4009b2d53946c1e6c8ed9187e82a3b2fb0.tar.bz2
LinHES-system & func: Change OSD font to Overlock
msg_client.py: if cmd is --print_list wait 1s for data to be returned from msg_daemon
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD6
-rwxr-xr-xabs/core/LinHES-system/msg_client.py39
-rwxr-xr-xabs/core/LinHES-system/msg_daemon.py2
-rw-r--r--abs/core/LinHES-system/system.install1
4 files changed, 28 insertions, 20 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 33a47d8..e05bcb3 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=8.0
-pkgrel=23
+pkgrel=24
arch=('i686' 'x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -100,8 +100,8 @@ md5sums=('5ee78704cab0e88ec58d1aab821fc1aa'
'8f474e019d5fcb775497aca355d61b0b'
'4a3cd8f9b33b2b86fdba47a8f1fa2859'
'16f079dab35dde6efd55bf6cf4e2fb2f'
- '4abc4780fa78ed40c07401b3cd25209b'
- '78375aead3402bccbfbf26aa11f94ad4'
+ '3e60b17892e5b8214d47dcfddf5215a4'
+ '23c9ae11d9d058e2399283c197dfe9aa'
'ea315f41dcd6c978e546c95fc05546cf'
'ac61cc460d9e97ba1f5ef69e92cdfbe5'
'f3502bb7c665750da0ecdf6918f7c838'
diff --git a/abs/core/LinHES-system/msg_client.py b/abs/core/LinHES-system/msg_client.py
index 8c5e3c4..8978e86 100755
--- a/abs/core/LinHES-system/msg_client.py
+++ b/abs/core/LinHES-system/msg_client.py
@@ -23,6 +23,8 @@ def send_message(message):
#amount_received = 0
#amount_expected = len(message)
print "Waiting for response..."
+ if cmd == 'list':
+ time.sleep(1)
data = sock.recv(1024)
print data
@@ -32,7 +34,7 @@ def send_message(message):
sock.close()
def usage():
line = '''
- Help screen:
+ Usage:
msg_client.py is used to add, remove, or list items in the queue of messages that
will be displayed on screen. Optionally messages can be given an identifier or "tag".
This identifier does not have to be unique.
@@ -43,24 +45,27 @@ def usage():
ADD:
- To add items to the queue:
+ To add items to the queue (--tag is optional):
msg_client.py --msg "My first message" --tag "tag1"
To add a message with a line break use \\n:
- msg_client.py --msg "My first\\nmessage" --tag "tag1"
+ msg_client.py --msg "My first\\nmessage"
REMOVE:
- Removing items are based off the tag.
To remove all items from the queue that match the tag "tag1":
msg_client.py --clear --tag "tag1"
To remove all items from the queue:
msg_client.py --clear
+ To immediately stop displaying the current message:
+ msg_client.py --kill
+
- Listing items in the queue or to get the total item count:
- msg_client.py --print_list
+ LIST:
+ To list items in the queue or to get the total item count:
+ msg_client.py --print_list
> -------------
> msg : slot 1
> slot : 1
@@ -69,8 +74,12 @@ def usage():
> timeout : None
- To immediately stop displaying the current message, use the kill command.
- msg_client.py --kill
+ APPEARANCE:
+ Display profiles define the font color, display timeout, screen position,
+ and font. Display profiles are defined in /usr/MythVantage/etc/msg.cfg
+
+ To display the message using a profile:
+ msg_client.py --msg "Display middle profile.|middle"
'''
print line
@@ -78,14 +87,14 @@ def usage():
if __name__ == "__main__":
parser = argparse.ArgumentParser()
- parser.add_argument('--tag', action='store', dest='tag',help='message tag')
- parser.add_argument('--timeout', action='store', dest='timeout',help='time to display message in seconds')
+ parser.add_argument('--tag', action='store', dest='tag',help='Add a tag to the message')
+ parser.add_argument('--timeout', action='store', dest='timeout',help='Time to display the message in seconds')
action = parser.add_mutually_exclusive_group(required=True)
- action.add_argument('--msg', action='store', dest='msg', help='Add message to the queue')
- action.add_argument('--clear', action='store_true', help='Remove message from queue that match tag')
- action.add_argument('--kill', action='store_true', help='Kill current msg thats displayed')
- action.add_argument('--print_list', action='store_true', help='Print current queue')
- action.add_argument('--usage', action='store_true', help='Print help screen')
+ action.add_argument('--msg', action='store', dest='msg', help='Add a message to the queue')
+ action.add_argument('--clear', action='store_true', help='Remove messages from queue that match tag. No tag will remove all messages in the queue')
+ action.add_argument('--kill', action='store_true', help='Kill the current message that is displayed')
+ action.add_argument('--print_list', action='store_true', help='Print the current queue')
+ action.add_argument('--usage', action='store_true', help='Print usage screen')
results = parser.parse_args()
resultsdict = vars(results)
diff --git a/abs/core/LinHES-system/msg_daemon.py b/abs/core/LinHES-system/msg_daemon.py
index ba611a3..bbcebb3 100755
--- a/abs/core/LinHES-system/msg_daemon.py
+++ b/abs/core/LinHES-system/msg_daemon.py
@@ -371,7 +371,7 @@ if __name__ == "__main__":
for k,v in i.iteritems():
line=" %s : %s\n" %(k,v)
connection.send(line)
- line = "Number of messages in queue: %s \n" %(len(q))
+ line = "\nNumber of messages in queue: %s \n" %(len(q))
connection.send(line)
#connection.send(pickle.dumps(q))
diff --git a/abs/core/LinHES-system/system.install b/abs/core/LinHES-system/system.install
index c354e9e..c8dc71d 100644
--- a/abs/core/LinHES-system/system.install
+++ b/abs/core/LinHES-system/system.install
@@ -20,7 +20,6 @@ post_install() {
#/usr/LH/bin/misc_status_config.py
# install canter font for msg_client.py
- /usr/LH/bin/install_canter_font.sh
}
# arg 1: the new package version