summaryrefslogtreecommitdiffstats
path: root/abs/core/bc
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/bc
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/bc')
-rw-r--r--abs/core/bc/PKGBUILD24
-rw-r--r--abs/core/bc/build-fix.patch13
2 files changed, 37 insertions, 0 deletions
diff --git a/abs/core/bc/PKGBUILD b/abs/core/bc/PKGBUILD
new file mode 100644
index 0000000..88a85df
--- /dev/null
+++ b/abs/core/bc/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: dorphell <dorphell@archlinux.org>
+
+pkgname=bc
+pkgver=1.06
+pkgrel=4
+pkgdesc="An arbitrary precision calculator language"
+arch=(i686 x86_64)
+license=('GPL')
+depends=('readline')
+replaces=(bc-readline)
+conflicts=(bc-readline)
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ build-fix.patch)
+md5sums=('d44b5dddebd8a7a7309aea6c36fda117' 'fc7ecbd9e55ef04c6d3a495692626116')
+
+build() {
+ CFLAGS="$CFLAGS -O3"
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ patch -Np1 -i ${startdir}/src/build-fix.patch || return 1
+ ./configure --prefix=/usr --with-readline
+ make LEX="flex -I" || return 1
+ make DESTDIR=${startdir}/pkg install
+}
diff --git a/abs/core/bc/build-fix.patch b/abs/core/bc/build-fix.patch
new file mode 100644
index 0000000..98a4082
--- /dev/null
+++ b/abs/core/bc/build-fix.patch
@@ -0,0 +1,13 @@
+diff -wbBur bc-1.06/bc/scan.l bc-1.06.my/bc/scan.l
+--- bc-1.06/bc/scan.l 2000-09-13 22:25:47 +0400
++++ bc-1.06.my/bc/scan.l 2006-12-25 12:39:34 +0300
+@@ -143,7 +143,9 @@
+
+ /* Definitions for readline access. */
+ extern FILE *rl_instream;
++#if 0
+ _PROTOTYPE(char *readline, (char *));
++#endif
+
+ /* rl_input puts upto MAX characters into BUF with the number put in
+ BUF placed in *RESULT. If the yy input file is the same as