summaryrefslogtreecommitdiffstats
path: root/abs/core/grep
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:29:20 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:29:20 (GMT)
commit7a9e8d425d8f8c8eaa139629601860782e74816c (patch)
tree77431387e45932e6fe13b8c55681e8907555ee93 /abs/core/grep
parentb75dfcd759c84edb19648ad5c087dc70de59865e (diff)
downloadlinhes_pkgbuild-7a9e8d425d8f8c8eaa139629601860782e74816c.zip
linhes_pkgbuild-7a9e8d425d8f8c8eaa139629601860782e74816c.tar.gz
linhes_pkgbuild-7a9e8d425d8f8c8eaa139629601860782e74816c.tar.bz2
grep 2.13
Diffstat (limited to 'abs/core/grep')
-rw-r--r--abs/core/grep/PKGBUILD13
-rw-r--r--abs/core/grep/grep-2.11-exclude-dir-crash.patch44
2 files changed, 51 insertions, 6 deletions
diff --git a/abs/core/grep/PKGBUILD b/abs/core/grep/PKGBUILD
index 918ef58..b878e71 100644
--- a/abs/core/grep/PKGBUILD
+++ b/abs/core/grep/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id$
+# $Id: PKGBUILD 163715 2012-07-18 02:16:59Z dreisner $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=grep
-pkgver=2.9
-pkgrel=1
+pkgver=2.13
+pkgrel=2
pkgdesc="A string search utility"
arch=('i686' 'x86_64')
license=('GPL3')
@@ -13,12 +13,13 @@ groups=('base')
depends=('glibc' 'pcre' 'sh')
makedepends=('texinfo')
install=${pkgname}.install
-source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz)
-md5sums=('25e41b2aa201104354740961ef36005a')
+source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz{,.sig})
+md5sums=('5894d484e6c02249f9702d0d8a472115'
+ '99acaa4d45ab931be2ecba49a1766df7')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --bindir=/bin --without-included-regex
+ ./configure --prefix=/usr --without-included-regex
make
}
diff --git a/abs/core/grep/grep-2.11-exclude-dir-crash.patch b/abs/core/grep/grep-2.11-exclude-dir-crash.patch
new file mode 100644
index 0000000..6b17317
--- /dev/null
+++ b/abs/core/grep/grep-2.11-exclude-dir-crash.patch
@@ -0,0 +1,44 @@
+From 12c957f786b12a4dd116f9c40a715d671d17fa16 Mon Sep 17 00:00:00 2001
+From: Allan McRae <allan@archlinux.org>
+Date: Mon, 12 Mar 2012 09:28:01 +0100
+Subject: [PATCH] grep: fix segfault with -r --exclude-dir and no file operand
+
+* src/main.c (grepdir): Don't invoke excluded_file_name on NULL.
+* NEWS (Bug fixes): Mention it.
+---
+ NEWS | 5 +++++
+ src/main.c | 2 +-
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/NEWS b/NEWS
+index d0a63d5..d4d70f5 100644
+--- a/NEWS
++++ b/NEWS
+@@ -2,6 +2,11 @@ GNU grep NEWS -*- outline -*-
+
+ * Noteworthy changes in release ?.? (????-??-??) [?]
+
++** Bug fixes
++
++ grep no longer segfaults with -r --exclude-dir and no file operand.
++ I.e., ":|grep -r --exclude-dir=D PAT" would segfault.
++
+
+ * Noteworthy changes in release 2.11 (2012-03-02) [stable]
+
+diff --git a/src/main.c b/src/main.c
+index 2f6c761..f4f1235 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -1361,7 +1361,7 @@ grepdir (char const *dir, struct stats const *stats)
+ struct stats const *ancestor;
+ char *name_space;
+ int status = 1;
+- if (excluded_directory_patterns
++ if (dir && excluded_directory_patterns
+ && excluded_file_name (excluded_directory_patterns, dir))
+ return 1;
+
+--
+1.7.9.3
+