summaryrefslogtreecommitdiffstats
path: root/abs/core/iproute2/iproute2-fhs.patch
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-24 02:43:49 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-24 02:43:49 (GMT)
commit4409812d4344e9d926924da54e73230b6d5336ba (patch)
treeba5a5901aeec99e5cceabfbef93c355a383daff1 /abs/core/iproute2/iproute2-fhs.patch
parent58e40c80ba0b97076fcd16d54602017420b1ad08 (diff)
downloadlinhes_pkgbuild-4409812d4344e9d926924da54e73230b6d5336ba.zip
linhes_pkgbuild-4409812d4344e9d926924da54e73230b6d5336ba.tar.gz
linhes_pkgbuild-4409812d4344e9d926924da54e73230b6d5336ba.tar.bz2
iproute2: upgrade
Diffstat (limited to 'abs/core/iproute2/iproute2-fhs.patch')
-rw-r--r--abs/core/iproute2/iproute2-fhs.patch57
1 files changed, 42 insertions, 15 deletions
diff --git a/abs/core/iproute2/iproute2-fhs.patch b/abs/core/iproute2/iproute2-fhs.patch
index 563a915..2608414 100644
--- a/abs/core/iproute2/iproute2-fhs.patch
+++ b/abs/core/iproute2/iproute2-fhs.patch
@@ -17,21 +17,6 @@ diff -Naur iproute2.old/Makefile iproute2-2.6.29/Makefile
# Path to db_185.h include
DBM_INCLUDE:=$(ROOTDIR)/usr/include
-diff -Naur iproute2.old/netem/Makefile iproute2-2.6.29/netem/Makefile
---- iproute2.old/netem/Makefile 2009-11-11 22:05:21.284750207 +0100
-+++ iproute2-2.6.29/netem/Makefile 2009-11-11 22:07:54.674736924 +0100
-@@ -20,9 +20,9 @@
- $(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
-
- install: all
-- mkdir -p $(DESTDIR)/lib/tc
-+ mkdir -p $(DESTDIR)/${SHAREDIR}/tc
- for i in $(DISTDATA); \
-- do install -m 755 $$i $(DESTDIR)/lib/tc; \
-+ do install -m 755 $$i $(DESTDIR)/${SHAREDIR}/tc; \
- done
-
- clean:
diff -Naur iproute2.old/tc/tc_util.c iproute2-2.6.29/tc/tc_util.c
--- iproute2.old/tc/tc_util.c 2009-11-11 22:05:21.298076943 +0100
+++ iproute2-2.6.29/tc/tc_util.c 2009-11-11 22:09:32.865152646 +0100
@@ -55,3 +40,45 @@ diff -Naur iproute2.old/tc/tc_util.c iproute2-2.6.29/tc/tc_util.c
return lib_dir;
}
+diff -Naur iproute2.old/netem/Makefile iproute2-2.6.35/netem/Makefile
+--- iproute2.old/netem/Makefile 2010-08-06 11:30:48.640940183 +0200
++++ iproute2-2.6.35/netem/Makefile 2010-08-06 11:32:34.210908892 +0200
+@@ -20,9 +20,9 @@
+ $(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
+
+ install: all
+- mkdir -p $(DESTDIR)$(LIBDIR)/tc
++ mkdir -p $(DESTDIR)$(SHAREDIR)/tc
+ for i in $(DISTDATA); \
+- do install -m 644 $$i $(DESTDIR)$(LIBDIR)/tc; \
++ do install -m 644 $$i $(DESTDIR)$(SHAREDIR)/tc; \
+ done
+
+ clean:
+diff -Naur iproute2.old/tc/Makefile iproute2-2.6.35/tc/Makefile
+--- iproute2.old/tc/Makefile 2010-08-06 11:48:35.607472252 +0200
++++ iproute2-2.6.35/tc/Makefile 2010-08-06 11:49:36.977473380 +0200
+@@ -99,18 +99,11 @@
+ $(AR) rcs $@ $(TCLIB)
+
+ install: all
+- mkdir -p $(MODDESTDIR)
+- install -m 0755 tc $(DESTDIR)$(SBINDIR)
+- for i in $(TCSO); \
+- do install -m 755 $$i $(MODDESTDIR); \
+- done
+- if [ ! -f $(MODDESTDIR)/m_ipt.so ]; then \
+- if [ -f $(MODDESTDIR)/m_xt.so ]; \
+- then ln -s m_xt.so $(MODDESTDIR)/m_ipt.so ; \
+- elif [ -f $(MODDESTDIR)/m_xt_old.so ]; \
+- then ln -s m_xt_old.so $(MODDESTDIR)/m_ipt.so ; \
+- fi; \
+- fi
++ mkdir -p $(DESTDIR)$(LIBDIR)/tc
++ install -m 0755 tc $(DESTDIR)$(SBINDIR)
++ for i in $(TCSO); \
++ do install -m 755 $$i $(DESTDIR)$(LIBDIR)/tc; \
++ done
+
+ clean:
+ rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \