summaryrefslogtreecommitdiffstats
path: root/abs/core/libdvdread/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-17 22:24:37 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-17 22:24:37 (GMT)
commit2b28f4edd87526b7775580f8d5996b86a750823d (patch)
tree9fc304c2a629d3249747f356870cff19e7402371 /abs/core/libdvdread/PKGBUILD
parent139157db8d34b5662687bf303eca59728d81dda8 (diff)
downloadlinhes_pkgbuild-2b28f4edd87526b7775580f8d5996b86a750823d.zip
linhes_pkgbuild-2b28f4edd87526b7775580f8d5996b86a750823d.tar.gz
linhes_pkgbuild-2b28f4edd87526b7775580f8d5996b86a750823d.tar.bz2
libdvdread: update to latest, fix patch
Diffstat (limited to 'abs/core/libdvdread/PKGBUILD')
-rw-r--r--abs/core/libdvdread/PKGBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/abs/core/libdvdread/PKGBUILD b/abs/core/libdvdread/PKGBUILD
index e39e586..3e5ece3 100644
--- a/abs/core/libdvdread/PKGBUILD
+++ b/abs/core/libdvdread/PKGBUILD
@@ -1,23 +1,35 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Thomas Baechler <thomas@archlinux.org>
+# $Id: PKGBUILD 80196 2010-05-13 15:59:09Z andrea $
+# Maintainer:
+# Contributor: Thomas Baechler <thomas@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=libdvdread
-pkgver=0.9.7
-pkgrel=1
+pkgver=4.1.3
+pkgrel=3
+pkgdesc="Provides a simple foundation for reading DVD video disks"
arch=(i686 x86_64)
-pkgdesc="libdvdread provides a simple foundation for reading DVD video disks"
+url="http://www.mplayerhq.hu/MPlayer/releases/dvdnav/"
+license=('GPL')
depends=('glibc')
makedepends=('libdvdcss')
-install=$pkgname.install
+optdepends=('libdvdcss: for decoding encrypted DVDs')
options=('!libtool')
-source=(http://www.dtek.chalmers.se/groups/dvd/dist/$pkgname-$pkgver.tar.gz)
-url="http://www.dtek.chalmers.se/groups/dvd/downloads.shtml"
-md5sums=('078788c9241ae16763529e1235502337')
+source=("http://www.mplayerhq.hu/MPlayer/releases/dvdnav/${pkgname}-${pkgver}.tar.bz2"
+ 'DVDFileStat.patch')
+md5sums=('6dc068d442c85a3cdd5ad3da75f6c6e8'
+ '0e8e8c19f811a06dc761322e208cbda0')
build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # http://lists.mplayerhq.hu/pipermail/dvdnav-discuss/2009-February/000986.html (FS#19324)
+ patch -Np1 -i ${srcdir}/DVDFileStat.patch || return 1
+
+ ./autogen.sh --prefix=/usr || return 1
make || return 1
- make DESTDIR=$startdir/pkg install
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
}