summaryrefslogtreecommitdiffstats
path: root/abs/core/libraw1394
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/libraw1394
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/libraw1394')
-rw-r--r--abs/core/libraw1394/PKGBUILD24
-rw-r--r--abs/core/libraw1394/libraw1394.install18
2 files changed, 42 insertions, 0 deletions
diff --git a/abs/core/libraw1394/PKGBUILD b/abs/core/libraw1394/PKGBUILD
new file mode 100644
index 0000000..b1065fd
--- /dev/null
+++ b/abs/core/libraw1394/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 13741 2008-09-28 13:27:16Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=libraw1394
+pkgver=2.0.2
+pkgrel=3
+arch=('i686' 'x86_64')
+license=('LGPL')
+pkgdesc="Provides an API to the Linux IEEE1394 (FireWire) driver"
+depends=('glibc')
+makedepends=('pkgconfig')
+url="http://www.linux1394.org/"
+options=(!libtool force)
+install=libraw1394.install
+source=(http://www.linux1394.org/dl/${pkgname}-${pkgver}.tar.gz)
+md5sums=('9fbbef5ea31101c4c28085db134fd448')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+}
diff --git a/abs/core/libraw1394/libraw1394.install b/abs/core/libraw1394/libraw1394.install
new file mode 100644
index 0000000..33fb64c
--- /dev/null
+++ b/abs/core/libraw1394/libraw1394.install
@@ -0,0 +1,18 @@
+# arg 1: the new package version
+post_install() {
+ ln -s /usr/lib/libraw1394.so.11.0.1 /usr/lib/libraw1394.so.8
+}
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ rm -fr /usr/lib/libraw1394.so.8
+}
+
+op=$1
+shift
+$op $*