summaryrefslogtreecommitdiffstats
path: root/abs/core/linhes-scripts/myth2mp3
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-01 01:51:25 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-01 01:51:25 (GMT)
commitf5e4d5cd76772c52fe652d4a6472266109298bdd (patch)
tree6506ee810bdec8199445e053529af0a15d38b9ab /abs/core/linhes-scripts/myth2mp3
parent5211b30fbeab9533f21e3d320ca1d8494d50a86b (diff)
downloadlinhes_pkgbuild-f5e4d5cd76772c52fe652d4a6472266109298bdd.zip
linhes_pkgbuild-f5e4d5cd76772c52fe652d4a6472266109298bdd.tar.gz
linhes_pkgbuild-f5e4d5cd76772c52fe652d4a6472266109298bdd.tar.bz2
linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist
In mythtv .25 mythcommflag --getcutlist is depreciated Conflicts: abs/core/linhes-scripts/PKGBUILD
Diffstat (limited to 'abs/core/linhes-scripts/myth2mp3')
-rwxr-xr-xabs/core/linhes-scripts/myth2mp34
1 files changed, 2 insertions, 2 deletions
diff --git a/abs/core/linhes-scripts/myth2mp3 b/abs/core/linhes-scripts/myth2mp3
index 5ce72c1..69d5d3f 100755
--- a/abs/core/linhes-scripts/myth2mp3
+++ b/abs/core/linhes-scripts/myth2mp3
@@ -1,6 +1,6 @@
#!/bin/sh
# convert recordings to as mp3 audio only
-# version 1.1.2
+# version 1.1.3
# usage:
# first parameter must be %DIR%/%FILE% of the recording
@@ -37,7 +37,7 @@ beforetime="$(date +%s)"
# check if using cutlist
if [ $USECUTLIST = Y ];then
- MYTHCOMMFRAMES=`mythcommflag --getcutlist -f "$FFINPUTFILE" | grep 'Cutlist:' | cut -d \ -f 2`
+ MYTHCOMMFRAMES=`mythutil --getcutlist --chanid "$3" --starttime "$4" | grep 'Cutlist:' | cut -d \ -f 2`
if [ -n "$MYTHCOMMFRAMES" ]; then
echo "Extracting Cutlist..." >> $LOGFILE
/usr/bin/nice -n19 /usr/bin/mythtranscode --chanid "$3" --starttime "$4" --outfile "$TMPCUTFILE" --mpeg2 --honorcutlist