summaryrefslogtreecommitdiffstats
path: root/abs/core/linhes-scripts
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-09-14 22:10:40 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-09-14 22:10:40 (GMT)
commit096c20a03e34e5142356c2df5ba7602990561d4e (patch)
treecfef1e62e53f152bcbe31ebf8afc7884fe48d19c /abs/core/linhes-scripts
parent3c36d806034f2c63d48bf0d7c577969be4155fb7 (diff)
downloadlinhes_pkgbuild-096c20a03e34e5142356c2df5ba7602990561d4e.zip
linhes_pkgbuild-096c20a03e34e5142356c2df5ba7602990561d4e.tar.gz
linhes_pkgbuild-096c20a03e34e5142356c2df5ba7602990561d4e.tar.bz2
LinHES-system, linhes-scripts: move linhes_update*.sh and mythwelcome-* to LinHES-system
Diffstat (limited to 'abs/core/linhes-scripts')
-rw-r--r--abs/core/linhes-scripts/PKGBUILD14
-rw-r--r--abs/core/linhes-scripts/linhes_update.sh74
-rw-r--r--abs/core/linhes-scripts/linhes_update2.sh52
-rw-r--r--abs/core/linhes-scripts/linhes_update3.sh28
-rwxr-xr-xabs/core/linhes-scripts/mythwelcome-config.py27
-rwxr-xr-xabs/core/linhes-scripts/mythwelcome-set-alarm.sh23
-rwxr-xr-xabs/core/linhes-scripts/mythwelcome-test-wakeup.sh16
7 files changed, 1 insertions, 233 deletions
diff --git a/abs/core/linhes-scripts/PKGBUILD b/abs/core/linhes-scripts/PKGBUILD
index 5ccc91a..e78d857 100644
--- a/abs/core/linhes-scripts/PKGBUILD
+++ b/abs/core/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=linhes-scripts
pkgver=7
-pkgrel=53
+pkgrel=54
pkgdesc="Various scripts that help to make LinHES, LinHES."
arch=('i686' 'x86_64')
license=('GPL2')
@@ -20,20 +20,14 @@ shootscreens-mythtv.sh
importfiles.sh
myth2mp3
mplayer-resumer.pl
-mythwelcome-test-wakeup.sh
pause-mythcommflag.sh
myth2x264
770-wrapper.sh
-mythwelcome-set-alarm.sh
-mythwelcome-config.py
pause_mythcommflag
limit-mythcommflag.sh
vdpau-detector
screenshooter.sh
run-limit-mythcommflag
-linhes_update.sh
-linhes_update2.sh
-linhes_update3.sh
update_schema_021_to_022.sh
upgrade_linhes.sh
remove_php_mythvideo.sh
@@ -76,20 +70,14 @@ md5sums=('47a66238d95259d75c9c5cbcbb6da19f'
'6b6e7d34a4bda6d608d150039adefd07'
'4a1fda884dcd7d65fb2690fbdbd92a83'
'18263972b6326e140bbef0bb7dfa2da9'
- '410795ef9039e4c6c0484e706ecfd567'
'ad98d51e79f83df7c03f828dbeaea7f4'
'3b1c44a0818b35b6939c3cb2b723ce9e'
'd2b475821f902c5e081e7da43a35e6ac'
- '95c092f67036a361ef7a57436f44332e'
- '92950f0ffb1faf1ed64c6be2b8fbc3f6'
'3b776bbff68906ddc2f62b7e0dde3fe4'
'a57641fb63d7bb6d92a438f1ea779a57'
'3d0adf26280cde55a0c47188fff34826'
'b2c3dd48a4abb976eda2d5fbf22a173a'
'b527b01d119d3bc33b8fa69bdf1082bb'
- '9d077c24d102fa02e4f417d639d8b00a'
- '98979920c30bb48c02d00f6943e9e50e'
- '460861e6d0cf999629b734912eea0acf'
'65629302a4d2c3adf88cdf0ebc10d493'
'ab469714d77f3a29c7dda715e5ab98e0'
'87b0dc855181f98516acb18a7d551601'
diff --git a/abs/core/linhes-scripts/linhes_update.sh b/abs/core/linhes-scripts/linhes_update.sh
deleted file mode 100644
index e5dd2ad..0000000
--- a/abs/core/linhes-scripts/linhes_update.sh
+++ /dev/null
@@ -1,74 +0,0 @@
-#!/bin/bash
-
-#----------------------------------------------------------------------------
-. /etc/osd_cat.cfg || {
- color=yellow
- outline=2
- outlinecolour=black
- shadow=0
- shadowcolour=black
- font="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
-}
-#----------------------------------------------------------------------------
-dsply () {
- if grep -q Updates\ Available /usr/share/mythtv/themes/defaultmenu/linhes.xml
- then
- killall -9 osd_cat
- echo -e "\nUpdates available!\nExit and re-enter Service Menu\n to install the updates." | osd_cat --pos=middle --align=center --delay=5 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- echo -e "\nUpdates available!\nExit and re-enter Service Menu\n to install the updates." | osd_cat --pos=middle --align=center --delay=5 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- exit
- else
- killall -9 osd_cat
- echo -e "Checking for updates..." | osd_cat --pos=middle --align=center --delay=300 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- echo -e "Checking for updates..." | osd_cat --pos=middle --align=center --delay=300 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- fi
-}
-chck () {
- sudo pacman -Sy
- sudo pacman -Qu > /tmp/to_be_upgraded
- if [[ ! -s /tmp/to_be_upgraded ]]
- then
- killall -9 osd_cat
- echo -e "\nNo updates available." | osd_cat --pos=middle --align=center --delay=5 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- echo -e "\nNo updates available." | osd_cat --pos=middle --align=center --delay=5 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- else
- mv /usr/share/mythtv/themes/defaultmenu/linhes.xml /tmp/linhes.xml.tmp
- sed -e '/\#Check/,/\#Check/d' < /tmp/linhes.xml.tmp > /usr/share/mythtv/themes/defaultmenu/linhes.xml
- mv /usr/share/mythtv/themes/defaultmenu/linhes.xml /tmp
- grep -v -e /mythmenu /tmp/linhes.xml > /tmp/linhes.xml.tmp
- echo "<!--#UpdatesAvailable-->" >> /tmp/linhes.xml.tmp
- echo " <button>" >> /tmp/linhes.xml.tmp
- echo " <type>UPGRADE</type>" >> /tmp/linhes.xml.tmp
- echo " <text>Updates Available</text>" >> /tmp/linhes.xml.tmp
- echo " <action>MENU update2.xml</action>" >> /tmp/linhes.xml.tmp
- echo " </button>" >> /tmp/linhes.xml.tmp
- echo "<!--#UpdatesAvailable-->" >> /tmp/linhes.xml.tmp
- echo "</mythmenu>" >> /tmp/linhes.xml.tmp
- mv /tmp/linhes.xml.tmp /usr/share/mythtv/themes/defaultmenu/linhes.xml
-
- echo "<mythmenu name=\"LinHES\">" > /tmp/update3.xml.tmp
- if grep kernel26 /tmp/to_be_upgraded || grep nvidia /tmp/to_be_upgraded
- then
- echo "" >> /tmp/update3.xml.tmp
- echo " <button>" >> /tmp/update3.xml.tmp
- echo " <type>UPGRADE</type>" >> /tmp/update3.xml.tmp
- echo " <text>REBOOT REQUIRED</text>" >> /tmp/update3.xml.tmp
- echo " <action>NONE</action>" >> /tmp/update3.xml.tmp
- echo " </button>" >> /tmp/update3.xml.tmp
- fi
-
- while read line; do
- echo "" >> /tmp/update3.xml.tmp
- echo " <button>" >> /tmp/update3.xml.tmp
- echo " <type>UPGRADE</type>" >> /tmp/update3.xml.tmp
- echo " <text>$line</text>" >> /tmp/update3.xml.tmp
- echo " <action>NONE</action>" >> /tmp/update3.xml.tmp
- echo " </button>" >> /tmp/update3.xml.tmp
- done < "/tmp/to_be_upgraded"
- echo "</mythmenu>" >> /tmp/update3.xml.tmp
- mv /tmp/update3.xml.tmp /usr/share/mythtv/themes/defaultmenu/update3.xml
- dsply
- fi
- }
-dsply
-chck
diff --git a/abs/core/linhes-scripts/linhes_update2.sh b/abs/core/linhes-scripts/linhes_update2.sh
deleted file mode 100644
index d6984ed..0000000
--- a/abs/core/linhes-scripts/linhes_update2.sh
+++ /dev/null
@@ -1,52 +0,0 @@
-#!/bin/bash
-
-#----------------------------------------------------------------------------
-. /etc/osd_cat.cfg || {
- color=yellow
- outline=2
- outlinecolour=black
- shadow=0
- shadowcolour=black
- font="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
-}
-#----------------------------------------------------------------------------
-
-if [[ "$1" = "install" ]]
-then
- killall -9 osd_cat
- echo -e "Updating..." | osd_cat --pos=middle --align=center --delay=300000 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- echo -e "Updating..." | osd_cat --pos=middle --align=center --delay=300000 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- sudo pacman -Suf --noconfirm && sudo killall -9 osd_cat
- killall -9 osd_cat
- echo -e "\nUpdates complete." | osd_cat --pos=middle --align=center --delay=3 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- echo -e "\nUpdates complete." | osd_cat --pos=middle --align=center --delay=3 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- if grep kernel26 /tmp/to_be_upgraded || grep nvidia /tmp/to_be_upgraded
- then
- echo -e "\n\nUpdates require a reboot." | osd_cat --pos=middle --align=center --delay=3 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- echo -e "\n\nUpdates require a reboot." | osd_cat --pos=middle --align=center --delay=3 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- fi
-else
- killall -9 osd_cat
- echo -e "\nUpdates canceled." | osd_cat --pos=middle --align=center --delay=3 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- echo -e "\nUpdates canceled." | osd_cat --pos=middle --align=center --delay=3 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
-fi
-
-rm -fr /tmp/to_be_upgraded
-
-if grep -q Updates\ Available /usr/share/mythtv/themes/defaultmenu/linhes.xml
-then
- mv /usr/share/mythtv/themes/defaultmenu/linhes.xml /tmp/linhes.xml.tmp
- sed -e '/\#UpdatesAv/,/\#UpdatesAv/d' < /tmp/linhes.xml.tmp > /usr/share/mythtv/themes/defaultmenu/linhes.xml
- mv /usr/share/mythtv/themes/defaultmenu/linhes.xml /tmp
- grep -v -e /mythmenu /tmp/linhes.xml > /tmp/linhes.xml.tmp
- echo "<!--#Check for updates-->" >> /tmp/linhes.xml.tmp
- echo " <button>" >> /tmp/linhes.xml.tmp
- echo " <type>UPGRADE</type>" >> /tmp/linhes.xml.tmp
- echo " <text>Update LinHES</text>" >> /tmp/linhes.xml.tmp
- echo " <action>MENU update.xml</action>" >> /tmp/linhes.xml.tmp
- echo " </button>" >> /tmp/linhes.xml.tmp
- echo "<!--#Check for updates-->" >> /tmp/linhes.xml.tmp
- echo "" >> /tmp/linhes.xml.tmp
- echo "</mythmenu>" >> /tmp/linhes.xml.tmp
- mv /tmp/linhes.xml.tmp /usr/share/mythtv/themes/defaultmenu/linhes.xml
-fi
diff --git a/abs/core/linhes-scripts/linhes_update3.sh b/abs/core/linhes-scripts/linhes_update3.sh
deleted file mode 100644
index 72641db..0000000
--- a/abs/core/linhes-scripts/linhes_update3.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/bash
-#----------------------------------------------------------------------------
-. /etc/osd_cat.cfg || {
- color=yellow
- outline=2
- outlinecolour=black
- shadow=0
- shadowcolour=black
- font="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
-}
-#----------------------------------------------------------------------------
-
-sudo killall osd_cat
-cat /tmp/to_be_upgraded | sed 's/ /\n/g' | sed '/^$/d' | grep - > /tmp/to_be_upgraded2
-COUNT=$(wc -l /tmp/to_be_upgraded2 | awk '{print $1}')
-if [ $COUNT -lt 20 ]
- then
- cat /tmp/to_be_upgraded2 | osd_cat --lines=20 --pos=top --align=center --delay=12 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
- else
- cat /tmp/to_be_upgraded2 | osd_cat --lines=20 --pos=top --align=center --delay=1 --wait --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font &
-fi
-if grep kernel26 /tmp/to_be_upgraded2
-then
- killall -9 osd_cat
- echo -e "Please note:\The kernel will be upgraded.\nThis will require a reboot.\nPlease do so when no jobs are running." | osd_cat --pos=middle --align=center --delay=10 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font
-else
- exit
-fi
diff --git a/abs/core/linhes-scripts/mythwelcome-config.py b/abs/core/linhes-scripts/mythwelcome-config.py
deleted file mode 100755
index 5ab24b0..0000000
--- a/abs/core/linhes-scripts/mythwelcome-config.py
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/usr/bin/env python2
-
-# This script will configure the myth db to allow MythWelcome to wake and shutdown the system.
-
-from socket import gethostname
-from MythTV import MythDB
-mythdb = MythDB()
-localhostname = gethostname()
-
-# mythwelcome --setup
-mythdb.settings[localhostname].MythShutdownNvramCmd = u'sudo sh -c \"/usr/LH/bin/mythwelcome-set-alarm.sh $time\"'
-mythdb.settings[localhostname].MythShutdownWakeupTimeFmt = u'time_t'
-mythdb.settings[localhostname].MythShutdownNvramRestartCmd = u''
-mythdb.settings[localhostname].MythShutdownReboot = u'sudo /sbin/reboot'
-mythdb.settings[localhostname].MythShutdownPowerOff = u'sudo /sbin/poweroff'
-mythdb.settings[localhostname].MythShutdownXTermCmd = u'xterm'
-mythdb.settings[localhostname].MythWelcomeStartFECmd = u'/usr/LH/bin/mythfrontend-start'
-
-
-# mythtv-setup Shutdown/Wakeup options
-if mythdb.settings[localhostname].idleTimeoutSecs == u'0':
- mythdb.settings[localhostname].idleTimeoutSecs = u'40'
-
-mythdb.settings.NULL.WakeupTimeFormat = u'yyyy-MM-ddThh:mm:ss'
-mythdb.settings.NULL.SetWakeuptimeCommand = u'/usr/bin/mythshutdown --setwakeup $time'
-mythdb.settings.NULL.ServerHaltCommand = u'/usr/bin/mythshutdown --shutdown'
-mythdb.settings.NULL.preSDWUCheckCommand = u'/usr/LH/bin/idle.sh -s -m -r'
diff --git a/abs/core/linhes-scripts/mythwelcome-set-alarm.sh b/abs/core/linhes-scripts/mythwelcome-set-alarm.sh
deleted file mode 100755
index 990adf7..0000000
--- a/abs/core/linhes-scripts/mythwelcome-set-alarm.sh
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-#$1 is the first argument to the script. It is the time in seconds since 1970
-#This is defined in mythwelcome with the time_t argument
-
-# Configure mythwelcome --setup page:
-# Command to Set Wakeup Time: sudo sh -c "/usr/LH/bin/mythwelcome-set-alarm.sh $time"
-# Wakeup Time Format: time_t
-# nvram-wakeup Restart Command: Leave this blank
-# Command to reboot: sudo /sbin/reboot
-# Command to shutdown: sudo /sbin/poweroff
-# Command to run Xterm: xterm
-# Command to start the Frontend: /usr/bin/mythfrontend -l /var/log/mythtv/mythfrontend.log
-
-# Configure mythtv-setup Shutdown/Wakeup Options page:
-# Idletimeout (secs): any value greater that 0
-# Wakeup time format: yyyy-MM-ddThh:mm:ss
-# Set wakeup time command: /usr/bin/mythshutdown --setwakeup $time
-# Server Halt command: /usr/bin/mythshutdown --shutdown
-# Pre shutdown check command: /usr/bin/mythshutdown --check
-
-echo 0 > /sys/class/rtc/rtc0/wakealarm #this clears your alarm
-echo $1 > /sys/class/rtc/rtc0/wakealarm #this writes your alarm
-cat /proc/driver/rtc > /var/log/wake_alarm
diff --git a/abs/core/linhes-scripts/mythwelcome-test-wakeup.sh b/abs/core/linhes-scripts/mythwelcome-test-wakeup.sh
deleted file mode 100755
index 4aadf6d..0000000
--- a/abs/core/linhes-scripts/mythwelcome-test-wakeup.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-sudo sh -c "echo 0 > /sys/class/rtc/rtc0/wakealarm" #this clears your alarm
-sudo sh -c "echo `date '+%s' -d '+ 4 minutes'` > /sys/class/rtc/rtc0/wakealarm" #this writes your alarm
-cat /proc/driver/rtc
-cat /proc/driver/rtc > /var/log/wake_alarm
-echo "Your computer is set to start up in 4 minutes using ACPI."
-echo -n "Do you want to shutdown the computer now? (y/n): "
-read -n 1 shutdown
-if [ "$shutdown" == "y" ]; then
- echo -e "\nShutting down now..."
- sudo shutdown -t 5 -h now
-else
- echo -e "\nTo shutdown execute the following:"
- echo " sudo shutdown -t 5 -h now"
-fi