summaryrefslogtreecommitdiffstats
path: root/abs/core/miscsplashutils
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/miscsplashutils
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/miscsplashutils')
-rw-r--r--abs/core/miscsplashutils/ChangeLog3
-rw-r--r--abs/core/miscsplashutils/PKGBUILD26
-rw-r--r--abs/core/miscsplashutils/miscsplashutils.install39
3 files changed, 68 insertions, 0 deletions
diff --git a/abs/core/miscsplashutils/ChangeLog b/abs/core/miscsplashutils/ChangeLog
new file mode 100644
index 0000000..811f87d
--- /dev/null
+++ b/abs/core/miscsplashutils/ChangeLog
@@ -0,0 +1,3 @@
+2007-06-28 tardo <tardo@nagi-fanboi.net>
+* Built for x86_64
+
diff --git a/abs/core/miscsplashutils/PKGBUILD b/abs/core/miscsplashutils/PKGBUILD
new file mode 100644
index 0000000..e0b85c8
--- /dev/null
+++ b/abs/core/miscsplashutils/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+
+pkgname=miscsplashutils
+pkgver=0.1.8
+pkgrel=1
+pkgdesc="Miscellaneous framebuffer utilities including fbres and fbtruetype"
+arch=(i686 x86_64)
+url="http://dev.gentoo.org/~spock/projects/gensplash/"
+license=('GPL')
+depends=('freetype2')
+conflicts=('bootsplash')
+install=miscsplashutils.install
+source=(http://dev.gentoo.org/~spock/projects/gensplash/current/$pkgname-$pkgver.tar.bz2)
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ make || return 1
+ make DESTDIR=$startdir/pkg/ install
+
+ install -d $startdir/pkg/lib/splash/bin
+ touch $startdir/pkg/lib/splash/bin/wc
+
+ # install luxisri.ttf to avoid an x-server dependency
+ install -D -m644 fbtruetype/luxisri.ttf $startdir/pkg/etc/splash/luxisri.ttf
+}
+md5sums=('0a9505c5c5ed169e6158d2c1b06ff40b')
diff --git a/abs/core/miscsplashutils/miscsplashutils.install b/abs/core/miscsplashutils/miscsplashutils.install
new file mode 100644
index 0000000..4345f5d
--- /dev/null
+++ b/abs/core/miscsplashutils/miscsplashutils.install
@@ -0,0 +1,39 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+/bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+echo " : Copying /usr/bin/wc to /lib/splash/bin"
+install -D -m755 /usr/bin/wc /lib/splash/bin/wc
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+/bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+post_install
+}
+
+# arg 1: the old package version
+pre_remove() {
+/bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+/bin/true
+}
+
+op=$1
+shift
+$op $*