summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable-29/mythplugins
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/core/mythtv/stable-29/mythplugins
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/mythtv/stable-29/mythplugins')
-rw-r--r--abs/core/mythtv/stable-29/mythplugins/PKGBUILD25
-rw-r--r--abs/core/mythtv/stable-29/mythplugins/mythburn.cpp-python2.patch13
2 files changed, 30 insertions, 8 deletions
diff --git a/abs/core/mythtv/stable-29/mythplugins/PKGBUILD b/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
index ed4036c..7dcae9e 100644
--- a/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-29/mythplugins/PKGBUILD
@@ -9,22 +9,23 @@ pkgname=('mytharchive'
'mythweather'
'mythzoneminder')
pkgver=29.1
-pkgrel=1
-arch=('i686' 'x86_64')
+pkgrel=9
+arch=('x86_64')
url="http://www.mythtv.org"
license=('GPL')
makedepends=('cdrkit' 'dcraw' 'dvdauthor' 'dvd+rw-tools' 'ffmpeg' 'flac' 'libexif'
'libvorbis' 'mesa' 'libgl' 'mplayer' "mythtv>=${pkgver}"
'perl-datetime-format-iso8601' 'perl-date-manip' 'perl-image-size'
'perl-json' 'perl-libwww' 'perl-soap-lite' 'perl-xml-sax'
- 'perl-xml-simple' 'perl-xml-xpath' 'python-oauth' 'python2-pillow'
- 'python-pycurl' 'zlib')
+ 'perl-xml-simple' 'perl-xml-xpath' 'python2-oauth' 'python2-pillow'
+ 'python2-pycurl' 'zlib')
source=('mythburn.py-aspectratio.patch'
+ 'mythburn.cpp-python2.patch'
'cdparanoia.patch'
'0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch'
)
-build() {
+prepare() {
if [ -e ${srcdir}/mythplugins ]
then
msg "Removing old mythplugins src"
@@ -38,14 +39,21 @@ build() {
cd ${srcdir}
patch -Np1 -i "$srcdir/0317-0336-MythMusic-Fix-Playlist-copyTracks-and-removeAllTrack.patch"
- msg "Patching configure"
+ msg "Change python to python2"
+ find . -name '*.py' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
+ patch -Np1 -i "$srcdir/mythburn.cpp-python2.patch"
+
+ msg "Patching Configure"
cd ${srcdir}/${pkgbase}
patch -Np1 -i "$srcdir/cdparanoia.patch"
+}
+build() {
+ cd ${srcdir}/${pkgbase}
msg "Configuring mythplugins"
./configure --prefix=/usr \
--enable-all \
- --python=/usr/bin/python2
+ --python=python2
msg "Compiling mythplugins"
qmake-qt5 mythplugins.pro || return 1
@@ -93,7 +101,7 @@ package_mythmusic() {
package_mythnetvision() {
pkgdesc="MythNetvision plugin for MythTV"
- depends=("mythtv>=${pkgver}" 'python-pycurl' 'python-oauth'
+ depends=("mythtv>=${pkgver}" 'python2-pycurl' 'python2-oauth'
'python2-lxml' 'python2')
cd "${srcdir}/${_gitname}/${pkgbase}/mythnetvision"
make INSTALL_ROOT="${pkgdir}" install || return 1
@@ -124,5 +132,6 @@ package_mythzoneminder() {
}
md5sums=('e98c2a09bcb051fdde959fb4bb2e5ab2'
+ 'b9edd8f7da64ffa74baa91092bd48cc9'
'5de8dd79d0b8a2b006f3c3258938b6b7'
'0299d0214c0d3a452c0284352435d698')
diff --git a/abs/core/mythtv/stable-29/mythplugins/mythburn.cpp-python2.patch b/abs/core/mythtv/stable-29/mythplugins/mythburn.cpp-python2.patch
new file mode 100644
index 0000000..2c43f9e
--- /dev/null
+++ b/abs/core/mythtv/stable-29/mythplugins/mythburn.cpp-python2.patch
@@ -0,0 +1,13 @@
+diff --git a/mythplugins/mytharchive/mytharchive/mythburn.cpp b/mythplugins/mytharchive/mytharchive/mythburn.cpp
+index 4188579bb0..639f17abe9 100644
+--- a/mythplugins/mytharchive/mytharchive/mythburn.cpp
++++ b/mythplugins/mytharchive/mytharchive/mythburn.cpp
+@@ -950,7 +950,7 @@ void MythBurn::runScript()
+ QFile::remove(logDir + "/mythburncancel.lck");
+
+ createConfigFile(configDir + "/mydata.xml");
+- commandline = "python " + GetShareDir() + "mytharchive/scripts/mythburn.py";
++ commandline = "python2 " + GetShareDir() + "mytharchive/scripts/mythburn.py";
+ commandline += " -j " + configDir + "/mydata.xml"; // job file
+ commandline += " -l " + logDir + "/progress.log"; // progress log
+ commandline += " > " + logDir + "/mythburn.log 2>&1 &"; // Logs