summaryrefslogtreecommitdiffstats
path: root/abs/core/net-tools
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-16 23:55:51 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:04 (GMT)
commit5e43b65f3e67974c0b421f631e6b5eeec2bb393c (patch)
tree22a2aba11b019ad6c2c6bb4124194bc95ba46db7 /abs/core/net-tools
parent4061895c257e60fa6368b38c4cfd5191f5481a16 (diff)
downloadlinhes_pkgbuild-5e43b65f3e67974c0b421f631e6b5eeec2bb393c.zip
linhes_pkgbuild-5e43b65f3e67974c0b421f631e6b5eeec2bb393c.tar.gz
linhes_pkgbuild-5e43b65f3e67974c0b421f631e6b5eeec2bb393c.tar.bz2
net-tools, nfstools
update binary path to /usr/bin refs #961
Diffstat (limited to 'abs/core/net-tools')
-rw-r--r--abs/core/net-tools/Makefile.patch17
-rw-r--r--abs/core/net-tools/PKGBUILD41
-rw-r--r--abs/core/net-tools/gcc340.patch46
-rw-r--r--abs/core/net-tools/net-tools-1.60-2.6-compilefix.patch23
-rw-r--r--abs/core/net-tools/net-tools-1.60-miiioctl.patch17
-rw-r--r--abs/core/net-tools/net-tools-1.60-nameif.patch58
-rw-r--r--abs/core/net-tools/net-tools-1.60-nameif_strncpy.patch13
-rw-r--r--abs/core/net-tools/net-tools.install12
-rw-r--r--abs/core/net-tools/net-tools.patch30
9 files changed, 36 insertions, 221 deletions
diff --git a/abs/core/net-tools/Makefile.patch b/abs/core/net-tools/Makefile.patch
new file mode 100644
index 0000000..aaacd6b
--- /dev/null
+++ b/abs/core/net-tools/Makefile.patch
@@ -0,0 +1,17 @@
+--- Makefile.old 2012-08-07 22:07:58.235437087 +0200
++++ Makefile 2012-08-07 22:10:21.192104345 +0200
+@@ -239,12 +239,12 @@
+ install -m 0755 -d ${BASEDIR}/bin
+ install -m 0755 arp ${BASEDIR}/sbin
+ install -m 0755 hostname ${BASEDIR}/bin
+- install -m 0755 ifconfig ${BASEDIR}/bin
++ install -m 0755 ifconfig ${BASEDIR}/sbin
+ install -m 0755 nameif ${BASEDIR}/sbin
+ install -m 0755 netstat ${BASEDIR}/bin
+ install -m 0755 plipconfig $(BASEDIR)/sbin
+ install -m 0755 rarp ${BASEDIR}/sbin
+- install -m 0755 route ${BASEDIR}/bin
++ install -m 0755 route ${BASEDIR}/sbin
+ install -m 0755 slattach $(BASEDIR)/sbin
+ ifeq ($(HAVE_IP_TOOLS),1)
+ install -m 0755 ipmaddr $(BASEDIR)/sbin
diff --git a/abs/core/net-tools/PKGBUILD b/abs/core/net-tools/PKGBUILD
index 605620a..dc1a161 100644
--- a/abs/core/net-tools/PKGBUILD
+++ b/abs/core/net-tools/PKGBUILD
@@ -1,43 +1,40 @@
-# $Id: PKGBUILD 142384 2011-11-08 22:05:28Z ronald $
+# $Id: PKGBUILD 187035 2013-06-03 11:15:26Z allan $
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=net-tools
-pkgver=1.60.20110819cvs
-pkgrel=3
+pkgver=1.60.20130531git
+pkgrel=1
pkgdesc="Configuration tools for Linux networking"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('GPL2')
-url="http://www.tazenda.demon.co.uk/phil/net-tools"
+url="http://net-tools.sourceforge.net/"
depends=('glibc')
-
-# http://www.tazenda.demon.co.uk/phil/$pkgname/$pkgname-$pkgver.tar.bz2
-# use cvs checkout instead
-source=(ftp://ftp.archlinux.org/other/net-tools/net-tools-1.60.20110819cvs.tar.bz2
- net-tools-1.60-miiioctl.patch
- net-tools-1.60-nameif_strncpy.patch)
+makedepends=('git')
+# use git snapshot currently prefered over release
+source=("net-tools::git://git.code.sf.net/p/net-tools/code#commit=6a14c03f")
options=(!makeflags)
-install=net-tools.install
-sha1sums=('02946449191ff279f9f0f7fd7bc65ae21059a2bf'
- '654a96bc6575efb4a2e04b49de45d448d240eb6e'
- '7888000d8fe867e58b5b00fe2bcf6c3041d716b4')
+sha1sums=('SKIP')
+
+prepare() {
+ sed -i "s#/sbin#/bin#" ${srcdir}/${pkgname}/Makefile
+ sed -i "s#/usr##" ${srcdir}/${pkgname}/man/Makefile
+}
build() {
- cd $srcdir/$pkgname-$pkgver
- patch -Np1 -i ../net-tools-1.60-miiioctl.patch
- patch -Np1 -i ${srcdir}/net-tools-1.60-nameif_strncpy.patch
+ cd ${srcdir}/${pkgname}
yes "" | make
}
package() {
- cd $srcdir/$pkgname-$pkgver
- make BASEDIR=$pkgdir update
+ cd ${srcdir}/${pkgname}
+ make DESTDIR=${pkgdir}/usr update
# the following is provided by yp-tools
- rm "${pkgdir}"/bin/{nis,yp}domainname
+ rm "${pkgdir}"/usr/bin/{nis,yp}domainname
rm "${pkgdir}"/usr/share/man/man1/{nis,yp}domainname.1
# hostname is provided by inetutils
- rm "${pkgdir}"/bin/{hostname,dnsdomainname,domainname}
+ rm "${pkgdir}"/usr/bin/{hostname,dnsdomainname,domainname}
rm -rf "${pkgdir}"/usr/share/man/man1
}
diff --git a/abs/core/net-tools/gcc340.patch b/abs/core/net-tools/gcc340.patch
deleted file mode 100644
index 8089bf2..0000000
--- a/abs/core/net-tools/gcc340.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -Naur net-tools-1.60-orig/hostname.c net-tools-1.60/hostname.c
---- net-tools-1.60-orig/hostname.c 2001-04-08 10:04:23.000000000 -0700
-+++ net-tools-1.60/hostname.c 2004-05-07 17:22:14.000000000 -0700
-@@ -78,6 +78,7 @@
- fprintf(stderr, _("%s: name too long\n"), program_name);
- break;
- default:
-+ ;
- }
- exit(1);
- }
-@@ -98,6 +99,7 @@
- fprintf(stderr, _("%s: name too long\n"), program_name);
- break;
- default:
-+ ;
- }
- exit(1);
- };
-@@ -117,6 +119,7 @@
- fprintf(stderr, _("%s: name too long\n"), program_name);
- break;
- default:
-+ ;
- }
- exit(1);
- };
-@@ -174,6 +177,7 @@
- printf("%s\n", hp->h_name);
- break;
- default:
-+ ;
- }
- }
-
-diff -Naur net-tools-1.60-orig/lib/inet_sr.c net-tools-1.60/lib/inet_sr.c
---- net-tools-1.60-orig/lib/inet_sr.c 2000-02-20 13:46:45.000000000 -0800
-+++ net-tools-1.60/lib/inet_sr.c 2004-05-07 17:20:14.000000000 -0700
-@@ -105,6 +105,7 @@
- case 2:
- isnet = 0; break;
- default:
-+ ;
- }
-
- /* Fill in the other fields. */
diff --git a/abs/core/net-tools/net-tools-1.60-2.6-compilefix.patch b/abs/core/net-tools/net-tools-1.60-2.6-compilefix.patch
deleted file mode 100644
index 92ce901..0000000
--- a/abs/core/net-tools/net-tools-1.60-2.6-compilefix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -ruN net-tools-1.60.orig/lib/x25_sr.c net-tools-1.60/lib/x25_sr.c
---- net-tools-1.60.orig/lib/x25_sr.c 2000-05-20 15:38:10.000000000 +0200
-+++ net-tools-1.60/lib/x25_sr.c 2003-10-18 20:33:31.927574928 +0200
-@@ -22,6 +22,7 @@
- #include <sys/socket.h>
- #include <sys/ioctl.h>
- #include <linux/x25.h>
-+#include <linux/version.h>
- #include <ctype.h>
- #include <errno.h>
- #include <netdb.h>
-@@ -77,7 +78,11 @@
- rt.sigdigits=sigdigits;
-
- /* x25_route_struct.address isn't type struct sockaddr_x25, Why? */
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0)
- memcpy(&rt.address, &sx25.sx25_addr, sizeof(x25_address));
-+#else
-+ memcpy(&rt.address, &sx25.sx25_addr, sizeof(struct x25_address));
-+#endif
-
- while (*args) {
- if (!strcmp(*args,"device") || !strcmp(*args,"dev")) {
diff --git a/abs/core/net-tools/net-tools-1.60-miiioctl.patch b/abs/core/net-tools/net-tools-1.60-miiioctl.patch
deleted file mode 100644
index 6c7f069..0000000
--- a/abs/core/net-tools/net-tools-1.60-miiioctl.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- net-tools-1.60.20110819cvs/include/mii.h 2011-08-19 10:14:00.743873299 +0200
-+++ net-tools-1.60.20110819cvs/include/mii.h.new 2011-08-19 10:28:26.500524160 +0200
-@@ -14,11 +14,9 @@
- /* network interface ioctl's for MII commands */
- #ifndef SIOCGMIIPHY
- #warning "SIOCGMIIPHY is not defined by your kernel source"
--#define SIOCGMIIPHY (SIOCDEVPRIVATE) /* Read from current PHY */
--#define SIOCGMIIREG (SIOCDEVPRIVATE+1) /* Read any PHY register */
--#define SIOCSMIIREG (SIOCDEVPRIVATE+2) /* Write any PHY register */
--#define SIOCGPARAMS (SIOCDEVPRIVATE+3) /* Read operational parameters */
--#define SIOCSPARAMS (SIOCDEVPRIVATE+4) /* Set operational parameters */
-+#define SIOCGMIIPHY 0x8947 /* Read from current PHY */
-+#define SIOCGMIIREG 0x8948 /* Read any PHY register */
-+#define SIOCSMIIREG 0x8949 /* Write any PHY register */
- #endif
-
- #include <linux/types.h>
diff --git a/abs/core/net-tools/net-tools-1.60-nameif.patch b/abs/core/net-tools/net-tools-1.60-nameif.patch
deleted file mode 100644
index 54def00..0000000
--- a/abs/core/net-tools/net-tools-1.60-nameif.patch
+++ /dev/null
@@ -1,58 +0,0 @@
---- net-tools-1.60/nameif.c.nameif 2000-10-18 19:26:29.000000000 +0200
-+++ net-tools-1.60/nameif.c 2003-03-19 11:02:01.000000000 +0100
-@@ -117,7 +117,8 @@
- }
-
- struct change {
-- struct change *next,**pprev;
-+ struct change *next;
-+ int found;
- char ifname[IFNAMSIZ+1];
- unsigned char mac[6];
- };
-@@ -139,10 +140,7 @@
- ch->ifname, pos);
- if (parsemac(p,ch->mac) < 0)
- complain(_("cannot parse MAC `%s' at %s"), p, pos);
-- if (clist)
-- clist->pprev = &ch->next;
- ch->next = clist;
-- ch->pprev = &clist;
- clist = ch;
- return 0;
- }
-@@ -200,7 +198,7 @@
-
- void usage(void)
- {
-- fprintf(stderr, _("usage: nameif [-c configurationfile] [-s] {ifname macaddress}"));
-+ fprintf(stderr, _("usage: nameif [-c configurationfile] [-s] {ifname macaddress}\n"));
- exit(1);
- }
-
-@@ -277,21 +275,21 @@
- ch = lookupmac(mac);
- if (!ch)
- continue;
--
-- *ch->pprev = ch->next;
-+
-+ ch->found = 1;
- if (strcmp(p, ch->ifname)) {
- if (setname(p, ch->ifname) < 0)
- complain(_("cannot change name of %s to %s: %s"),
- p, ch->ifname, strerror(errno));
- }
-- free(ch);
- }
- fclose(ifh);
-
- while (clist) {
- struct change *ch = clist;
- clist = clist->next;
-- warning(_("interface '%s' not found"), ch->ifname);
-+ if (!ch->found)
-+ warning(_("interface '%s' not found"), ch->ifname);
- free(ch);
- }
-
diff --git a/abs/core/net-tools/net-tools-1.60-nameif_strncpy.patch b/abs/core/net-tools/net-tools-1.60-nameif_strncpy.patch
deleted file mode 100644
index 7568e21..0000000
--- a/abs/core/net-tools/net-tools-1.60-nameif_strncpy.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- net-tools-1.60/nameif.c.ncpy 2006-10-03 14:24:21.000000000 +0200
-+++ net-tools-1.60/nameif.c 2006-10-03 14:22:43.000000000 +0200
-@@ -100,8 +100,8 @@
- struct ifreq ifr;
- opensock();
- memset(&ifr,0,sizeof(struct ifreq));
-- strcpy(ifr.ifr_name, oldname);
-- strcpy(ifr.ifr_newname, newname);
-+ strncpy(ifr.ifr_name, oldname, IF_NAMESIZE);
-+ strncpy(ifr.ifr_newname, newname, IF_NAMESIZE);
- return ioctl(ctl_sk, SIOCSIFNAME, &ifr);
- }
-
diff --git a/abs/core/net-tools/net-tools.install b/abs/core/net-tools/net-tools.install
deleted file mode 100644
index 9eee9e5..0000000
--- a/abs/core/net-tools/net-tools.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_upgrade() {
- if [ "$(vercmp $2 1.60-16)" -lt 0 ]; then
- echo "hostname and {,yp,nis}domainname has moved:"
- echo "----------"
- echo "hostname is now in coreutils"
- echo "domainname is now in yp-tools"
- echo "their functionality might have changed slightly"
- echo ""
- echo "dnsdomainname remains in net-tools"
- echo "----------"
- fi
-}
diff --git a/abs/core/net-tools/net-tools.patch b/abs/core/net-tools/net-tools.patch
deleted file mode 100644
index 8af2d21..0000000
--- a/abs/core/net-tools/net-tools.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -Naur net-tools-1.60-orig/mii-tool.c net-tools-1.60/mii-tool.c
---- net-tools-1.60-orig/mii-tool.c 2000-05-21 07:31:17.000000000 -0700
-+++ net-tools-1.60/mii-tool.c 2004-05-31 12:35:21.000000000 -0700
-@@ -379,16 +379,16 @@
- /*--------------------------------------------------------------------*/
-
- const char *usage =
--"usage: %s [-VvRrwl] [-A media,... | -F media] [interface ...]
-- -V, --version display version information
-- -v, --verbose more verbose output
-- -R, --reset reset MII to poweron state
-- -r, --restart restart autonegotiation
-- -w, --watch monitor for link status changes
-- -l, --log with -w, write events to syslog
-- -A, --advertise=media,... advertise only specified media
-- -F, --force=media force specified media technology
--media: 100baseT4, 100baseTx-FD, 100baseTx-HD, 10baseT-FD, 10baseT-HD,
-+"usage: %s [-VvRrwl] [-A media,... | -F media] [interface ...]\n\
-+ -V, --version display version information\n\
-+ -v, --verbose more verbose output\n\
-+ -R, --reset reset MII to poweron state\n\
-+ -r, --restart restart autonegotiation\n\
-+ -w, --watch monitor for link status changes\n\
-+ -l, --log with -w, write events to syslog\n\
-+ -A, --advertise=media,... advertise only specified media\n\
-+ -F, --force=media force specified media technology\n\
-+media: 100baseT4, 100baseTx-FD, 100baseTx-HD, 10baseT-FD, 10baseT-HD,\n\
- (to advertise both HD and FD) 100baseTx, 10baseT\n";
-
- int main(int argc, char **argv)