summaryrefslogtreecommitdiffstats
path: root/abs/core/nettle
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 17:45:33 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 17:45:33 (GMT)
commit58c09e7721915b7ee8b92345f242ab0da6176c06 (patch)
treed7d1952b9131a3c48300213185bfd2f3460f1baf /abs/core/nettle
parent80d1276c4aab094c21ca671b71e5e3cddadefd58 (diff)
downloadlinhes_pkgbuild-58c09e7721915b7ee8b92345f242ab0da6176c06.zip
linhes_pkgbuild-58c09e7721915b7ee8b92345f242ab0da6176c06.tar.gz
linhes_pkgbuild-58c09e7721915b7ee8b92345f242ab0da6176c06.tar.bz2
nettle 2.5
Diffstat (limited to 'abs/core/nettle')
-rw-r--r--abs/core/nettle/PKGBUILD36
-rw-r--r--abs/core/nettle/nettle.install20
2 files changed, 56 insertions, 0 deletions
diff --git a/abs/core/nettle/PKGBUILD b/abs/core/nettle/PKGBUILD
new file mode 100644
index 0000000..2e9f8c0
--- /dev/null
+++ b/abs/core/nettle/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 163476 2012-07-12 19:05:48Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: bender02 at gmx dot com
+
+pkgname=nettle
+pkgver=2.5
+pkgrel=1
+pkgdesc="A low-level cryptographic library"
+arch=('i686' 'x86_64')
+url="http://www.lysator.liu.se/~nisse/nettle/"
+license=('GPL2')
+install=$pkgname.install
+depends=('gmp')
+source=(ftp://ftp.lysator.liu.se/pub/security/lsh/$pkgname-$pkgver.tar.gz)
+md5sums=('d66882e6ad31a9f651b73d7a1a93bd4c')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --libdir=/usr/lib \
+ --enable-shared \
+ --disable-static # <-- seems not working now
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ # remove static libs
+ rm -f ${pkgdir}/usr/lib/{libhogweed,libnettle}.a
+}
diff --git a/abs/core/nettle/nettle.install b/abs/core/nettle/nettle.install
new file mode 100644
index 0000000..3d19b5f
--- /dev/null
+++ b/abs/core/nettle/nettle.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(nettle.info)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file.gz $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
+ done
+}