summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-file-which/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-26 14:49:49 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-26 14:49:49 (GMT)
commit1ee7cc86da31af9c0b0f16f8934626093df968a8 (patch)
tree28ef252b3b04b01ac64c9ebb3ad8497f13c0352f /abs/core/perl_modules/perl-file-which/PKGBUILD
parent9b02f79cac1b37a36a6be3bd658a693369fccc62 (diff)
downloadlinhes_pkgbuild-1ee7cc86da31af9c0b0f16f8934626093df968a8.zip
linhes_pkgbuild-1ee7cc86da31af9c0b0f16f8934626093df968a8.tar.gz
linhes_pkgbuild-1ee7cc86da31af9c0b0f16f8934626093df968a8.tar.bz2
perl_modules needed for frozen bubble:
perl-aliean-sdl perl-capture-tiny perl-compress-bzip2 perl-file-sharedir perl-file-which perl-ipc-system-simple perl-local-maketext-lexicon perl-module-build perl-sdl perl-text-patch perl-tie-simple
Diffstat (limited to 'abs/core/perl_modules/perl-file-which/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-file-which/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-file-which/PKGBUILD b/abs/core/perl_modules/perl-file-which/PKGBUILD
new file mode 100644
index 0000000..6ba407e
--- /dev/null
+++ b/abs/core/perl_modules/perl-file-which/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 149416 2012-02-07 16:24:46Z heftig $
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com
+# Contributor: Charles Mauch <cmauch@gmail.com>
+
+pkgname=perl-file-which
+_realname=File-Which
+pkgver=1.09
+pkgrel=3
+pkgdesc="Portable implementation of which"
+arch=(any)
+url="http://search.cpan.org/dist/File-Which"
+license=(GPL PerlArtistic)
+source=("http://www.cpan.org/authors/id/A/AD/ADAMK/${_realname}-${pkgver}.tar.gz")
+md5sums=('b9429edaad7f45caafa4d458afcfd8af')
+
+build() {
+ cd "$srcdir/${_realname}-${pkgver}"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/${_realname}-${pkgver}"
+ make install DESTDIR="$pkgdir"
+}