summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules/perl-file-which/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/perl_modules/perl-file-which/PKGBUILD')
-rw-r--r--abs/core/perl_modules/perl-file-which/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-file-which/PKGBUILD b/abs/core/perl_modules/perl-file-which/PKGBUILD
new file mode 100644
index 0000000..6ba407e
--- /dev/null
+++ b/abs/core/perl_modules/perl-file-which/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 149416 2012-02-07 16:24:46Z heftig $
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com
+# Contributor: Charles Mauch <cmauch@gmail.com>
+
+pkgname=perl-file-which
+_realname=File-Which
+pkgver=1.09
+pkgrel=3
+pkgdesc="Portable implementation of which"
+arch=(any)
+url="http://search.cpan.org/dist/File-Which"
+license=(GPL PerlArtistic)
+source=("http://www.cpan.org/authors/id/A/AD/ADAMK/${_realname}-${pkgver}.tar.gz")
+md5sums=('b9429edaad7f45caafa4d458afcfd8af')
+
+build() {
+ cd "$srcdir/${_realname}-${pkgver}"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/${_realname}-${pkgver}"
+ make install DESTDIR="$pkgdir"
+}