summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-31 15:57:01 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-31 15:57:01 (GMT)
commit27b4ba8e1659a5b0fead38136db5dcf54f24c4d1 (patch)
tree7673e32ff95f0e5df2f58d2502e477c87f4bfb8d /abs/core/perl_modules
parentf45fec4bab0e4922c6e31b26e1a8216451f62a14 (diff)
downloadlinhes_pkgbuild-27b4ba8e1659a5b0fead38136db5dcf54f24c4d1.zip
linhes_pkgbuild-27b4ba8e1659a5b0fead38136db5dcf54f24c4d1.tar.gz
linhes_pkgbuild-27b4ba8e1659a5b0fead38136db5dcf54f24c4d1.tar.bz2
perl-package-deprecationmanager: update to 0.17
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-package-deprecationmanager/PKGBUILD67
1 files changed, 27 insertions, 40 deletions
diff --git a/abs/core/perl_modules/perl-package-deprecationmanager/PKGBUILD b/abs/core/perl_modules/perl-package-deprecationmanager/PKGBUILD
index ae69247..9907a06 100644
--- a/abs/core/perl_modules/perl-package-deprecationmanager/PKGBUILD
+++ b/abs/core/perl_modules/perl-package-deprecationmanager/PKGBUILD
@@ -1,47 +1,34 @@
-# Maintainer: Justin Davis (juster) <jrcd83@gmail.com>
-# $Id: PKGBUILD 71653 2012-05-31 15:45:01Z juster $
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Jonathan Steel <jsteel@aur.archlinux.org>
+# Contributor: Justin Davis (juster) <jrcd83@gmail.com>
pkgname=perl-package-deprecationmanager
-pkgver=0.13
-pkgrel=1
-pkgdesc='Manage deprecation warnings for your distribution'
-arch=(any)
-license=(PerlArtistic GPL)
-options=(!emptydirs)
-depends=(perl-list-moreutils perl-params-util perl-sub-install)
-checkdepends=(perl-test-fatal perl-test-requires)
-url=https://metacpan.org/release/Package-DeprecationManager
-source=("http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Package-DeprecationManager-$pkgver.tar.gz")
-md5sums=(f81ae3c0f9bcac048eb4bff348b79f67)
-sha512sums=(393841bc8a6a96dfc3ce9e2787d532f0e5ba45ef07a8d95be4450ad399b0ae3c4929f8abf07892194fca85c7de75c118a5b611a816b565a7945e34ebca36c4a8)
-_dir="$srcdir/Package-DeprecationManager-$pkgver"
+pkgver=0.17
+pkgrel=3
+pkgdesc="Manage deprecation warnings for your distribution"
+arch=('any')
+license=('Artistic2.0')
+depends=('perl-params-util' 'perl-sub-install' 'perl-sub-name' 'perl-package-stash'
+ 'perl-module-implementation' 'perl-namespace-autoclean')
+checkdepends=('perl-test-fatal' 'perl-test-warnings')
+options=('!emptydirs')
+url="https://metacpan.org/release/Package-DeprecationManager"
+source=(http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Package-DeprecationManager-$pkgver.tar.gz)
+md5sums=('7b46e92aaae3047ede3c67c1714ab88e')
-build()
-(
- cd "$_dir"
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
- unset PERL5LIB PERL_MM_OPT
- /usr/bin/perl Makefile.PL
+build() {
+ cd "$srcdir"/Package-DeprecationManager-$pkgver
+ perl Makefile.PL INSTALLDIRS=vendor
make
-)
+}
-check()
-(
- cd "$_dir"
- export PERL_MM_USE_DEFAULT=1
- unset PERL5LIB
+check() {
+ cd "$srcdir"/Package-DeprecationManager-$pkgver
make test
-)
+}
-package()
-(
- cd "$_dir"
- make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
-)
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et:
+package() {
+ cd "$srcdir"/Package-DeprecationManager-$pkgver
+ make install DESTDIR="$pkgdir"
+}