summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-03-24 16:15:47 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-03-24 16:15:47 (GMT)
commit74ea800185b1548a3fe62511f46231712e023022 (patch)
tree42451643c34e74c84ecab991c160b3c0aa546ca6 /abs/core/perl_modules
parent4a1f42eb677daa566ce121461d0f7487e2e1deaf (diff)
downloadlinhes_pkgbuild-74ea800185b1548a3fe62511f46231712e023022.zip
linhes_pkgbuild-74ea800185b1548a3fe62511f46231712e023022.tar.gz
linhes_pkgbuild-74ea800185b1548a3fe62511f46231712e023022.tar.bz2
perl-data-dump: initial inclusion. dep of zoneminder
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-data-dump/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-data-dump/PKGBUILD b/abs/core/perl_modules/perl-data-dump/PKGBUILD
new file mode 100644
index 0000000..a40b423
--- /dev/null
+++ b/abs/core/perl_modules/perl-data-dump/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer:
+
+pkgname=perl-data-dump
+pkgver=1.23
+pkgrel=1
+pkgdesc="Pretty printing of data structures"
+arch=(any)
+url="https://metacpan.org/release/Data-Dump"
+license=(PerlArtistic GPL)
+depends=('perl')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/Data-Dump-${pkgver}.tar.gz")
+sha1sums=('7da875cde34b6fe32b680eaa0c70121e4b69f09b')
+sha1sums=('3f5c0d4a15c8dd6befbcdceb41fe15b9aef1b741')
+
+build() {
+ cd Data-Dump-${pkgver}
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd Data-Dump-${pkgver}
+ make test
+}
+
+package() {
+ cd Data-Dump-${pkgver}
+ make DESTDIR="$pkgdir" install
+}