summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/pyopengl/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/core/python_modules/pyopengl/PKGBUILD
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/pyopengl/PKGBUILD')
-rw-r--r--abs/core/python_modules/pyopengl/PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/abs/core/python_modules/pyopengl/PKGBUILD b/abs/core/python_modules/pyopengl/PKGBUILD
new file mode 100644
index 0000000..dbb05c9
--- /dev/null
+++ b/abs/core/python_modules/pyopengl/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Josh Taylor <joshtaylor.mail@gmail.com>
+# Contributor: simo <simo@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgbase=pyopengl
+pkgname=('python2-opengl' 'python-opengl')
+pkgver=3.1.0
+pkgrel=3
+pkgdesc="The cross platform Python binding to OpenGL and related APIs"
+url="http://pyopengl.sourceforge.net/"
+license=('BSD')
+arch=('any')
+makedepends=('freeglut' 'python2-setuptools' 'python-setuptools')
+source=("https://pypi.python.org/packages/source/P/PyOpenGL/PyOpenGL-${pkgver}.tar.gz"
+ 'LICENSE')
+md5sums=('0de021941018d46d91e5a8c11c071693'
+ '0b53c508a63e5dbaf44cdfb0fa103b3a')\
+
+prepare() {
+ cp -a PyOpenGL-${pkgver} python-PyOpenGL-${pkgver}
+
+ # Fix the shebang
+ sed -i 's|#!/usr/bin/env python|#!/usr/bin/python2|' \
+ PyOpenGL-${pkgver}/OpenGL/Tk/__init__.py
+ sed -i 's|#! /usr/bin/env python|#!/usr/bin/python2|' \
+ PyOpenGL-${pkgver}/OpenGL/arrays/{_,}buffers.py
+}
+
+package_python2-opengl() {
+ depends=('python2' 'freeglut')
+ conflicts=('python-pyopengl' 'python-opengl<=3.0.1-4')
+ replaces=('python-pyopengl' 'python-opengl<=3.0.1-4')
+
+ cd PyOpenGL-${pkgver}
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 "${srcdir}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python-opengl() {
+ depends=('python' 'freeglut')
+
+ cd python-PyOpenGL-${pkgver}
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 "${srcdir}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+