summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-30 19:00:01 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-30 19:00:01 (GMT)
commit8941080f15d473a4ffb2c86aac2cc72bee1ed764 (patch)
treec6c9e54bd7017b093c1bfb02e6e553061f5eeb49 /abs/core/python_modules
parent0da469ed49f6874b4ff8088587b7f9053f2a5173 (diff)
downloadlinhes_pkgbuild-8941080f15d473a4ffb2c86aac2cc72bee1ed764.zip
linhes_pkgbuild-8941080f15d473a4ffb2c86aac2cc72bee1ed764.tar.gz
linhes_pkgbuild-8941080f15d473a4ffb2c86aac2cc72bee1ed764.tar.bz2
python2-oauth: replace python-oauth
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-oauth/PKGBUILD27
-rw-r--r--abs/core/python_modules/python2-oauth/PKGBUILD32
2 files changed, 32 insertions, 27 deletions
diff --git a/abs/core/python_modules/python-oauth/PKGBUILD b/abs/core/python_modules/python-oauth/PKGBUILD
deleted file mode 100644
index 1404fec..0000000
--- a/abs/core/python_modules/python-oauth/PKGBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Maintainer: Snowknight (hopkinsth@gmail.com)
-pkgname=python-oauth
-pkgver=1.0.1
-pkgrel=6
-pkgdesc="An open protocol to allow API authentication in a simple and standard method from desktop and web applications."
-arch=('any')
-url="http://code.google.com/p/oauth/"
-license=('MIT')
-depends=('python2')
-#makedepends=('python2-distribute')
-makedepends=('setuptools')
-source=(http://pypi.python.org/packages/source/o/oauth/oauth-${pkgver}.tar.gz)
-md5sums=('30ed3cc8c11d7841a89feab437aabf81')
-sha1sums=('b2d7609e4852b33d0d33f0bc6ae5cab8fadca014')
-
-build() {
- cd ${srcdir}/oauth-${pkgver}
-
- python2 setup.py build || return 1
-}
-package() {
- cd ${srcdir}/oauth-${pkgver}
- python2 setup.py install --root=${pkgdir} || return 1
-
- install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
-}
-
diff --git a/abs/core/python_modules/python2-oauth/PKGBUILD b/abs/core/python_modules/python2-oauth/PKGBUILD
new file mode 100644
index 0000000..83f3f09
--- /dev/null
+++ b/abs/core/python_modules/python2-oauth/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Jonathan Conder <jonno.conder@gmail.com>
+# Contributor: Snowknight (hopkinsth@gmail.com)
+
+_pkgbasename=oauth
+pkgname=python2-oauth
+pkgver=1.0.1
+pkgrel=3
+pkgdesc="An open protocol to allow API authentication from desktop and web applications."
+arch=('any')
+url="https://code.google.com/archive/p/oauth/"
+license=('MIT')
+depends=('python2')
+makedepends=('python2-setuptools')
+conflicts=('python-oauth')
+replaces=('python-oauth')
+source=("https://files.pythonhosted.org/packages/source/${_pkgbasename:0:1}/$_pkgbasename/$_pkgbasename-$pkgver.tar.gz")
+sha256sums=('e769819ff0b0c043d020246ce1defcaadd65b9c21d244468a45a7f06cb88af5d')
+
+build() {
+ cd $_pkgbasename-$pkgver
+
+ python2 setup.py build
+}
+
+package() {
+ cd $_pkgbasename-$pkgver
+
+ python2 setup.py install -O1 --root="$pkgdir"
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}