summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-11 19:39:54 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-11 19:39:54 (GMT)
commit965ed2966be39696be73414c6f5468420ff244be (patch)
tree6ad9714463becec1cd8fcec5f14dc34b7c337395 /abs/core/python_modules
parente49186294c4f1ab10eb3abce91b39605c51893a4 (diff)
downloadlinhes_pkgbuild-965ed2966be39696be73414c6f5468420ff244be.zip
linhes_pkgbuild-965ed2966be39696be73414c6f5468420ff244be.tar.gz
linhes_pkgbuild-965ed2966be39696be73414c6f5468420ff244be.tar.bz2
python-pybluez: update to 0.22
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-pybluez/PKGBUILD32
-rw-r--r--abs/core/python_modules/python-pybluez/__changelog1
2 files changed, 16 insertions, 17 deletions
diff --git a/abs/core/python_modules/python-pybluez/PKGBUILD b/abs/core/python_modules/python-pybluez/PKGBUILD
index e48f941..99594e6 100644
--- a/abs/core/python_modules/python-pybluez/PKGBUILD
+++ b/abs/core/python_modules/python-pybluez/PKGBUILD
@@ -3,29 +3,29 @@
# Contributor: cs-cam - me.at.camdaniel.com
pkgbase=python-pybluez
-pkgname=(python2-pybluez)
-pkgver=0.20
+pkgname=(python-pybluez python2-pybluez)
+pkgver=0.22
pkgrel=2
pkgdesc="Python wrapper for the BlueZ Bluetooth stack"
-arch=('i686' 'x86_64')
-url="http://code.google.com/p/pybluez/"
+arch=('x86_64')
+url="http://karulis.github.io/pybluez/"
license=('GPL')
-makedepends=('python2' 'bluez-libs')
-source=(http://pybluez.googlecode.com/files/PyBluez-$pkgver.zip)
-md5sums=('1e7fad332d50f089bbce69070c877ef6')
+makedepends=('python-setuptools' 'python2-setuptools' 'bluez-libs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/karulis/pybluez/archive/$pkgver.tar.gz")
+md5sums=('06f71ca6d4216ace671d5e588ec85887')
-#package_python-pybluez() {
-# depends=('python' 'bluez-libs')
+package_python-pybluez() {
+ depends=('python' 'bluez-libs')
-# cd $srcdir/PyBluez-$pkgver
-# python setup.py install --root=$pkgdir
-# ln -s bluetooth/_bluetooth.so $pkgdir/usr/lib/python3.3/site-packages/_bluetooth.so
-#}
+ cd "$srcdir"/pybluez-$pkgver
+ python setup.py install --root="$pkgdir"
+# ln -s bluetooth/_bluetooth.so "$pkgdir"/usr/lib/python3.3/site-packages/_bluetooth.so
+}
package_python2-pybluez() {
depends=('python2' 'bluez-libs')
- cd $srcdir/PyBluez-$pkgver
- python2 setup.py install --root=$pkgdir
-# ln -s bluetooth/_bluetooth.so $pkgdir/usr/lib/python2.7/site-packages/_bluetooth.so
+ cd "$srcdir"/pybluez-$pkgver
+ python2 setup.py install --root="$pkgdir"
+# ln -s bluetooth/_bluetooth.so "$pkgdir"/usr/lib/python2.7/site-packages/_bluetooth.so
}
diff --git a/abs/core/python_modules/python-pybluez/__changelog b/abs/core/python_modules/python-pybluez/__changelog
deleted file mode 100644
index 488d3cf..0000000
--- a/abs/core/python_modules/python-pybluez/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: rm py 3 stuff