summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-11 19:37:13 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-11 19:37:13 (GMT)
commite49186294c4f1ab10eb3abce91b39605c51893a4 (patch)
tree711767bbdaf84b0f12e5ea48fcd5bff9019b4656 /abs/core/python_modules
parent0304489714def760cd612f611a420386e0128298 (diff)
downloadlinhes_pkgbuild-e49186294c4f1ab10eb3abce91b39605c51893a4.zip
linhes_pkgbuild-e49186294c4f1ab10eb3abce91b39605c51893a4.tar.gz
linhes_pkgbuild-e49186294c4f1ab10eb3abce91b39605c51893a4.tar.bz2
python-simplejson: update to 3.13.2
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-simplejson/PKGBUILD46
-rw-r--r--abs/core/python_modules/python-simplejson/__changelog1
2 files changed, 34 insertions, 13 deletions
diff --git a/abs/core/python_modules/python-simplejson/PKGBUILD b/abs/core/python_modules/python-simplejson/PKGBUILD
index d5273f5..0e1a323 100644
--- a/abs/core/python_modules/python-simplejson/PKGBUILD
+++ b/abs/core/python_modules/python-simplejson/PKGBUILD
@@ -5,33 +5,55 @@
# Contributor: David Moore <davidm@sjsoft.com>
pkgbase=python-simplejson
-pkgname=('python2-simplejson')
-pkgver=3.8.2
+pkgname=('python-simplejson' 'python2-simplejson')
+pkgver=3.13.2
pkgrel=1
pkgdesc='Simple, fast, extensible JSON encoder/decoder for Python'
license=('MIT')
-arch=('x86_64' 'i686')
+arch=('x86_64')
url='https://github.com/simplejson/simplejson'
-makedepends=('python2-setuptools' 'git')
-source=("git://github.com/simplejson/simplejson.git#tag=v$pkgver")
-md5sums=('SKIP')
+makedepends=('python-setuptools' 'python2-setuptools')
+checkdepends=('python-pytest-runner' 'python2-pytest-runner')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/simplejson/simplejson/archive/v$pkgver.tar.gz")
+sha512sums=('b1d6c68e1a6c967dfb695d0cd3d8dca19d458b650ddc0c8273328378eab7f52b801ee29431a6b3bde16608e886259267f41cbefabb7fbe7adb1e243479f91132')
+
+prepare() {
+ cp -a simplejson-$pkgver{,-py2}
+}
+
+build() {
+ cd "$srcdir"/simplejson-$pkgver
+ python setup.py build
+
+ cd "$srcdir"/simplejson-$pkgver-py2
+ python2 setup.py build
+}
+
+check() {
+ cd "$srcdir"/simplejson-$pkgver
+ python setup.py pytest
+
+ cd "$srcdir"/simplejson-$pkgver-py2
+ python2 setup.py pytest
+}
package_python-simplejson() {
depends=('python')
- cd simplejson
+ cd simplejson-$pkgver
python setup.py install --root="$pkgdir"
- install -Dm644 "$srcdir/simplejson/LICENSE.txt" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir"/simplejson-$pkgver/LICENSE.txt \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
package_python2-simplejson() {
depends=('python2')
- cd simplejson
+ cd simplejson-$pkgver-py2
python2 setup.py install --root="$pkgdir"
- install -Dm644 "$srcdir/simplejson/LICENSE.txt" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir"/simplejson-$pkgver/LICENSE.txt \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
# vim:set ts=2 sw=2 et:
+
diff --git a/abs/core/python_modules/python-simplejson/__changelog b/abs/core/python_modules/python-simplejson/__changelog
deleted file mode 100644
index 488d3cf..0000000
--- a/abs/core/python_modules/python-simplejson/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: rm py 3 stuff