summaryrefslogtreecommitdiffstats
path: root/abs/core/tdb
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/tdb
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/tdb')
-rw-r--r--abs/core/tdb/PKGBUILD28
-rw-r--r--abs/core/tdb/gcc3.patch41
2 files changed, 69 insertions, 0 deletions
diff --git a/abs/core/tdb/PKGBUILD b/abs/core/tdb/PKGBUILD
new file mode 100644
index 0000000..e908119
--- /dev/null
+++ b/abs/core/tdb/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 37511 2009-05-02 16:17:09Z tpowa $
+# Maintainer: eric <eric@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=tdb
+pkgver=3.3.4
+pkgrel=1
+# We use the 'A' to fake out pacman's version comparators. Samba chooses
+# to append 'a','b',etc to their subsequent releases, which pamcan
+# misconstrues as alpha, beta, etc. Bad samba!
+_realver=3.3.4
+pkgdesc="A Trivial Database similar to GDBM but allows simultaneous commits"
+arch=(i686 x86_64)
+license=('GPL3')
+url="www.samba.org"
+source=(http://us1.samba.org/samba/ftp/samba-${_realver}.tar.gz)
+options=(!makeflags)
+
+build() {
+ cd ${srcdir}/samba-${_realver}/source/lib/tdb
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ ln -sf /usr/lib/libtdb.so.1.1.2 ${pkgdir}/usr/lib/libtdb.so.1
+ ln -sf /usr/lib/libtdb.so.1.1.2 ${pkgdir}/usr/lib/libtdb.so
+}
+md5sums=('1443165edb7cb3f56f1e77aec1ee3266')
diff --git a/abs/core/tdb/gcc3.patch b/abs/core/tdb/gcc3.patch
new file mode 100644
index 0000000..c88c2e7
--- /dev/null
+++ b/abs/core/tdb/gcc3.patch
@@ -0,0 +1,41 @@
+--- tdb-1.0.6/tdbtool.c 2001-12-10 22:45:47.000000000 -0500
++++ ./tdbtool.c 2003-12-31 19:44:50.000000000 -0500
+@@ -169,22 +169,22 @@
+
+ static void help(void)
+ {
+- printf("
+-tdbtool:
+- create dbname : create a database
+- open dbname : open an existing database
+- erase : erase the database
+- dump dumpname : dump the database as strings
+- insert key data : insert a record
+- store key data : store a record (replace)
+- show key : show a record by key
+- delete key : delete a record by key
+- list : print the database hash table and freelist
+- free : print the database freelist
+- 1 | first : print the first record
+- n | next : print the next record
+- q | quit : terminate
+- \\n : repeat 'next' command
++ printf("\
++tdbtool: \
++ create dbname : create a database\
++ open dbname : open an existing database\
++ erase : erase the database\
++ dump dumpname : dump the database as strings\
++ insert key data : insert a record\
++ store key data : store a record (replace)\
++ show key : show a record by key\
++ delete key : delete a record by key\
++ list : print the database hash table and freelist\
++ free : print the database freelist\
++ 1 | first : print the first record\
++ n | next : print the next record\
++ q | quit : terminate\
++ \\n : repeat 'next' command\
+ ");
+ }
+