summaryrefslogtreecommitdiffstats
path: root/abs/core/which
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/which
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/which')
-rw-r--r--abs/core/which/PKGBUILD18
-rw-r--r--abs/core/which/which.install20
2 files changed, 31 insertions, 7 deletions
diff --git a/abs/core/which/PKGBUILD b/abs/core/which/PKGBUILD
index 3bd0175..41e0b60 100644
--- a/abs/core/which/PKGBUILD
+++ b/abs/core/which/PKGBUILD
@@ -1,20 +1,24 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: judd <jvinet@zeroflux.org>
+# $Id: PKGBUILD 12859 2008-09-22 17:33:50Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
pkgname=which
-pkgver=2.19
-pkgrel=11
+pkgver=2.20
+pkgrel=10
pkgdesc="A utility to show the full path of commands"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://www.xs4all.nl/~carlo17/which"
license=('GPL3')
+install=which.install
groups=('base')
-depends=('glibc')
+depends=('glibc' 'texinfo')
source=(http://www.xs4all.nl/~carlo17/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('bbd094cec2444cd78befbc0cf09deea4')
+md5sums=('95be0501a466e515422cde4af46b2744')
build() {
cd $startdir/src/$pkgname-$pkgver
./configure --prefix=/usr
make || return 1
make DESTDIR=$startdir/pkg install
+
+ rm -f ${pkgdir}/usr/share/info/dir
}
diff --git a/abs/core/which/which.install b/abs/core/which/which.install
new file mode 100644
index 0000000..899bd6f
--- /dev/null
+++ b/abs/core/which/which.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(which.info)
+
+post_install() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+# vim:set ts=2 sw=2 et: