summaryrefslogtreecommitdiffstats
path: root/abs/core/yasm
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/yasm
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/yasm')
-rw-r--r--abs/core/yasm/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core/yasm/PKGBUILD b/abs/core/yasm/PKGBUILD
new file mode 100644
index 0000000..fcbd935
--- /dev/null
+++ b/abs/core/yasm/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 18746 2008-11-08 22:44:05Z aaron $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# Contributor: Vinay S Shastry <vinayshastry@gmail.com>
+
+pkgname=yasm
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="A rewrite of NASM to allow for multiple syntax supported (NASM, TASM, GAS, etc.)"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://www.tortall.net/projects/yasm/"
+depends=('glibc')
+source=(http://www.tortall.net/projects/yasm/releases/$pkgname-$pkgver.tar.gz)
+options=('!libtool')
+md5sums=('cc9360593de5625dca286f0bfcb27dd5')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ install -Dm644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/COPYING
+}