summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-30 21:37:01 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-30 21:37:01 (GMT)
commit3c0c19a4da26028096ed8edd602c000c5b95ddfd (patch)
treea398778cabfcc3f365578cb73501ce0d9908fb28 /abs/core
parent2c1d7e9e6b841addd6e3060fec9434e10cb742c3 (diff)
downloadlinhes_pkgbuild-3c0c19a4da26028096ed8edd602c000c5b95ddfd.zip
linhes_pkgbuild-3c0c19a4da26028096ed8edd602c000c5b95ddfd.tar.gz
linhes_pkgbuild-3c0c19a4da26028096ed8edd602c000c5b95ddfd.tar.bz2
python-ply: initial inclusion. dep of python-pycparser
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/python_modules/python-ply/PKGBUILD45
-rw-r--r--abs/core/python_modules/python-ply/__changelog1
2 files changed, 46 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-ply/PKGBUILD b/abs/core/python_modules/python-ply/PKGBUILD
new file mode 100644
index 0000000..3c8cace
--- /dev/null
+++ b/abs/core/python_modules/python-ply/PKGBUILD
@@ -0,0 +1,45 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Marcin "avalan" Falkiewicz <avalatron@gmail.com>
+# Contributor: C Anthony Risinger <anthony@xtfx.me>
+
+pkgbase=python-ply
+pkgname=(python2-ply)
+pkgver=3.4
+pkgrel=4
+pkgdesc='Implementation of lex and yacc parsing tools'
+arch=('any')
+url='http://www.dabeaz.com/ply/'
+license=('BSD')
+makedepends=('python2-setuptools')
+source=("${url}ply-$pkgver.tar.gz")
+sha256sums=('af435f11b7bdd69da5ffbc3fecb8d70a7073ec952e101764c88720cdefb2546b')
+
+prepare() {
+ cp -r ${pkgbase#python-}-$pkgver{,-py2}
+}
+
+#package_python-ply() {
+# depends=('python')
+
+# cd "${pkgbase#python-}-$pkgver"
+
+# python setup.py install --root="$pkgdir"
+
+# install -d "$pkgdir/usr/share/licenses/$pkgname"
+# head -n30 README > "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+#}
+
+package_python2-ply() {
+ depends=('python2')
+
+ cd "${pkgbase#python-}-$pkgver-py2"
+
+ python2 setup.py install --root="$pkgdir"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ head -n30 README > "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/python_modules/python-ply/__changelog b/abs/core/python_modules/python-ply/__changelog
new file mode 100644
index 0000000..488d3cf
--- /dev/null
+++ b/abs/core/python_modules/python-ply/__changelog
@@ -0,0 +1 @@
+PKGBUILD: rm py 3 stuff