summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-07 15:10:34 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-07 15:10:34 (GMT)
commitd5ad4049ff57099d8e9c97eb5f0232d44fb97383 (patch)
treeaeee1c898a9b7684ea465cfb2041578685e51d03 /abs/core
parent631a68e34804625b64806f6dcec8091168d90302 (diff)
downloadlinhes_pkgbuild-d5ad4049ff57099d8e9c97eb5f0232d44fb97383.zip
linhes_pkgbuild-d5ad4049ff57099d8e9c97eb5f0232d44fb97383.tar.gz
linhes_pkgbuild-d5ad4049ff57099d8e9c97eb5f0232d44fb97383.tar.bz2
mkinitcpio {busybox}: 1.20.2
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/mkinitcpio-busybox/PKGBUILD17
-rw-r--r--abs/core/mkinitcpio-busybox/__changelog1
-rw-r--r--abs/core/mkinitcpio-busybox/glibc-2.16.patch10
-rw-r--r--abs/core/mkinitcpio-busybox/sys_resource.patch99
-rw-r--r--abs/core/mkinitcpio/PKGBUILD30
5 files changed, 28 insertions, 129 deletions
diff --git a/abs/core/mkinitcpio-busybox/PKGBUILD b/abs/core/mkinitcpio-busybox/PKGBUILD
index 55071e0..f85beb6 100644
--- a/abs/core/mkinitcpio-busybox/PKGBUILD
+++ b/abs/core/mkinitcpio-busybox/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 160678 2012-06-03 16:32:18Z dreisner $
+# $Id: PKGBUILD 167188 2012-09-27 01:16:40Z dreisner $
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=mkinitcpio-busybox
-pkgver=1.20.1
+pkgver=1.20.2
pkgrel=1
pkgdesc="base initramfs tools"
arch=('i686' 'x86_64')
@@ -12,16 +12,22 @@ license=('GPL')
depends=('glibc')
options=('!buildflags')
source=("http://busybox.net/downloads/busybox-$pkgver.tar.bz2"
- 'config' 'sys_resource.patch')
+ 'glibc-2.16.patch'
+ 'config')
+sha256sums=('eb13ff01dae5618ead2ef6f92ba879e9e0390f9583bd545d8789d27cf39b6882'
+ 'fb5b6e2a0de4db5401322e5c2474ad8ce6a58615dad45b7109cfe045baf2c88d'
+ 'd8064ed6ec21868e4afe057445e2d852b353abd595132cb1ca3ba345988772f0')
build() {
cd "$srcdir/busybox-$pkgver"
- patch -Np1 < $srcdir/sys_resource.patch
+
local safeflags="${CARCH/_/-} -mtune=generic -Os -pipe -fno-strict-aliasing"
sed 's|^\(CONFIG_EXTRA_CFLAGS\)=.*|\1="-march='"$safeflags"'"|' \
"$srcdir/config" > .config
+ patch -Np1 < "$srcdir/glibc-2.16.patch"
+
make
}
@@ -30,6 +36,3 @@ package() {
}
# vim:set ts=2 sw=2 et:
-md5sums=('af2fededb6dca804544c05684636e574'
- 'dd4c0fefe9bb9e65945a5b5525543fd7'
- '47e725861776dbaad351e021c9a4df5a')
diff --git a/abs/core/mkinitcpio-busybox/__changelog b/abs/core/mkinitcpio-busybox/__changelog
deleted file mode 100644
index 25dffa3..0000000
--- a/abs/core/mkinitcpio-busybox/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-sys_resource.patch, needed for glibc 1.15
diff --git a/abs/core/mkinitcpio-busybox/glibc-2.16.patch b/abs/core/mkinitcpio-busybox/glibc-2.16.patch
new file mode 100644
index 0000000..5e2fb4f
--- /dev/null
+++ b/abs/core/mkinitcpio-busybox/glibc-2.16.patch
@@ -0,0 +1,10 @@
+--- a/include/libbb.h.orig 2012-09-17 08:28:35.215518120 -0400
++++ b/include/libbb.h 2012-09-17 08:28:49.807212925 -0400
+@@ -44,6 +44,7 @@
+ #include <sys/stat.h>
+ #include <sys/time.h>
+ #include <sys/types.h>
++#include <sys/resource.h>
+ #ifndef major
+ # include <sys/sysmacros.h>
+ #endif
diff --git a/abs/core/mkinitcpio-busybox/sys_resource.patch b/abs/core/mkinitcpio-busybox/sys_resource.patch
deleted file mode 100644
index bd55961..0000000
--- a/abs/core/mkinitcpio-busybox/sys_resource.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Pending
-
-From c5fe9f7b723f949457263ef8e22ab807d5b549ce Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Fri, 06 Jul 2012 03:19:09 +0000
-Subject: include sys/resource.h where needed
-
-We use functions from sys/resource.h in misc applets, but don't include
-the header. This breaks building with newer glibc versions, so add the
-include where needed.
-
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
----
-Index: busybox-1.19.4/loginutils/passwd.c
-===================================================================
---- busybox-1.19.4.orig/loginutils/passwd.c 2012-02-04 11:34:24.000000000 -0800
-+++ busybox-1.19.4/loginutils/passwd.c 2012-07-06 17:48:27.388096092 -0700
-@@ -15,6 +15,7 @@
-
- #include "libbb.h"
- #include <syslog.h>
-+#include <sys/resource.h> /* setrlimit */
-
- static void nuke_str(char *str)
- {
-Index: busybox-1.19.4/miscutils/time.c
-===================================================================
---- busybox-1.19.4.orig/miscutils/time.c 2012-02-04 11:24:55.000000000 -0800
-+++ busybox-1.19.4/miscutils/time.c 2012-07-06 17:48:27.388096092 -0700
-@@ -16,6 +16,7 @@
- //usage: "\n -v Verbose"
-
- #include "libbb.h"
-+#include <sys/resource.h> /* getrusage */
-
- /* Information on the resources used by a child process. */
- typedef struct {
-Index: busybox-1.19.4/networking/inetd.c
-===================================================================
---- busybox-1.19.4.orig/networking/inetd.c 2012-02-04 11:34:24.000000000 -0800
-+++ busybox-1.19.4/networking/inetd.c 2012-07-06 17:48:54.852097259 -0700
-@@ -165,6 +165,7 @@
- //usage: "\n (default: 0 - disabled)"
-
- #include <syslog.h>
-+#include <sys/resource.h> /* setrlimit */
- #include <sys/un.h>
-
- #include "libbb.h"
-Index: busybox-1.19.4/networking/ntpd.c
-===================================================================
---- busybox-1.19.4.orig/networking/ntpd.c 2012-02-04 11:24:55.000000000 -0800
-+++ busybox-1.19.4/networking/ntpd.c 2012-07-06 17:48:27.392096048 -0700
-@@ -46,6 +46,7 @@
- #include "libbb.h"
- #include <math.h>
- #include <netinet/ip.h> /* For IPTOS_LOWDELAY definition */
-+#include <sys/resource.h> /* setpriority */
- #include <sys/timex.h>
- #ifndef IPTOS_LOWDELAY
- # define IPTOS_LOWDELAY 0x10
-Index: busybox-1.19.4/networking/ntpd_simple.c
-===================================================================
---- busybox-1.19.4.orig/networking/ntpd_simple.c 2012-02-04 11:24:55.000000000 -0800
-+++ busybox-1.19.4/networking/ntpd_simple.c 2012-07-06 17:48:27.400095949 -0700
-@@ -7,6 +7,7 @@
- */
- #include "libbb.h"
- #include <netinet/ip.h> /* For IPTOS_LOWDELAY definition */
-+#include <sys/resource.h> /* setpriority */
- #ifndef IPTOS_LOWDELAY
- # define IPTOS_LOWDELAY 0x10
- #endif
-Index: busybox-1.19.4/runit/chpst.c
-===================================================================
---- busybox-1.19.4.orig/runit/chpst.c 2012-02-04 11:34:24.000000000 -0800
-+++ busybox-1.19.4/runit/chpst.c 2012-07-06 17:48:27.400095949 -0700
-@@ -91,6 +91,7 @@
- //usage: "\n a SIGXCPU after N seconds"
-
- #include "libbb.h"
-+#include <sys/resource.h> /* getrlimit */
-
- /*
- Five applets here: chpst, envdir, envuidgid, setuidgid, softlimit.
-Index: busybox-1.19.4/shell/shell_common.c
-===================================================================
---- busybox-1.19.4.orig/shell/shell_common.c 2012-02-04 11:34:24.000000000 -0800
-+++ busybox-1.19.4/shell/shell_common.c 2012-07-06 17:48:27.400095949 -0700
-@@ -18,6 +18,7 @@
- */
- #include "libbb.h"
- #include "shell_common.h"
-+#include <sys/resource.h> /* getrlimit */
-
- const char defifsvar[] ALIGN1 = "IFS= \t\n";
-
diff --git a/abs/core/mkinitcpio/PKGBUILD b/abs/core/mkinitcpio/PKGBUILD
index d4675f1..e4415be 100644
--- a/abs/core/mkinitcpio/PKGBUILD
+++ b/abs/core/mkinitcpio/PKGBUILD
@@ -1,44 +1,30 @@
-# $Id: PKGBUILD 161860 2012-06-15 22:35:26Z dreisner $
+# $Id: PKGBUILD 171244 2012-11-16 22:09:31Z dreisner $
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=mkinitcpio
-pkgver=0.9.2
-pkgrel=4
+pkgver=0.11.2
+pkgrel=1
pkgdesc="Modular initramfs image creation utility"
arch=('any')
url="http://www.archlinux.org/"
license=('GPL')
-depends=('awk' 'mkinitcpio-busybox>=1.19.4-2' 'kmod>=3' 'util-linux>=2.21' 'libarchive' 'coreutils'
+depends=('awk' 'mkinitcpio-busybox>=1.19.4-2' 'kmod' 'util-linux>=2.21' 'libarchive' 'coreutils'
'bash' 'findutils' 'grep' 'filesystem>=2011.10-1' 'file' 'gzip' 'systemd-tools')
optdepends=('xz: Use lzma or xz compression for the initramfs image'
'bzip2: Use bzip2 compression for the initramfs image'
'lzop: Use lzo compression for the initramfs image'
'mkinitcpio-nfs-utils: Support for root filesystem on NFS')
backup=('etc/mkinitcpio.conf')
-source=("ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"
- 0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
- 0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
- mkinitcpio.patch)
+source=("ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig} "mkinitcpio.patch")
install=mkinitcpio.install
package() {
- cd "$pkgname-$pkgver"
-
- patch -Np1 <"$srcdir"/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
- patch -Np1 <"$srcdir"/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
-
- make DESTDIR="$pkgdir" install
-
- # compat symlink
- install -dm755 "$pkgdir/sbin"
- ln -s /usr/bin/mkinitcpio "$pkgdir/sbin/mkinitcpio"
-
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
cd $pkgdir/etc
patch -Np0 < $srcdir/mkinitcpio.patch || exit 1
}
-md5sums=('6894147b09012054e025bfbe03445cda'
- 'e6e2aafa24f6c9d58b483e8df4dafdec'
- 'ffd144b1c8b3950671dacdc1c4a5e80d'
+md5sums=('cc437770a2f1a6ae63e14ac3c86defcf'
+ '5521e600fafa99522deb4f112f2e57cb'
'fa758c290731ab535c8d6995f0ff5ef0')