summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/mjpegtools/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-08 17:08:28 (GMT)
commitc38715641e214272ad7dc6d495edd29940366e7f (patch)
tree9dcd507543e67458d98fa7462f62026041524047 /abs/extra-testing/mjpegtools/PKGBUILD
parent3d91b06198a56b6579cb0bd77de65f5908571b87 (diff)
downloadlinhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.zip
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.gz
linhes_pkgbuild-c38715641e214272ad7dc6d495edd29940366e7f.tar.bz2
packages that will be needed in the future.
This is the initial merge of packages from MythVantage that are not MythVantage specific.
Diffstat (limited to 'abs/extra-testing/mjpegtools/PKGBUILD')
-rw-r--r--abs/extra-testing/mjpegtools/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/extra-testing/mjpegtools/PKGBUILD b/abs/extra-testing/mjpegtools/PKGBUILD
new file mode 100644
index 0000000..663e839
--- /dev/null
+++ b/abs/extra-testing/mjpegtools/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=mjpegtools
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="The mjpeg programs are a set of tools that can do recording of videos and playback, simple cut-and-paste editing and the MPEG compression of audio and video under Linux. "
+arch=(i686 x86_64)
+license=('GPL')
+url="http://mjpeg.sourceforge.net/"
+depends=('libjpeg' 'libpng' 'sdl' 'gcc' 'libdv')
+makedepends=('gtk2')
+options=('!makeflags' '!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/mjpeg/${pkgname}-${pkgver}.tar.gz
+ mjpegtools-1.8.0-gcc41.patch mjpegtools-1.8.0-libc.patch)
+#md5sums=('6fd98362310480bdaf7171e9659f165f' '803eccd889c60a442ee23ba65951fadc')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+# patch -Np1 -i ${startdir}/src/mjpegtools-1.8.0-gcc41.patch || return 1
+ patch -Np1 -i ${startdir}/src/mjpegtools-1.8.0-libc.patch || return 1
+ ./configure --prefix=/usr
+ find -name Makefile -exec sed -i -e 's:-march=k8 -mtune=k8::' -e 's:-march=pentium3 -mtune=pentium3::' {} \;
+
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+
+ install -m644 mpeg2enc/mpeg2syntaxcodes.h \
+ ${startdir}/pkg/usr/include/mjpegtools/mpeg2enc/
+}