summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/xine-lib/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-28 21:31:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-28 21:31:00 (GMT)
commit088d235213f43978790a0f6864a84b97a4817cf5 (patch)
tree39523a00ccb73600bc30213cd85a57e161705ca9 /abs/extra-testing/xine-lib/PKGBUILD
parentc8eb0fa27c78daf50c995b94f9f72f69b3404387 (diff)
downloadlinhes_pkgbuild-088d235213f43978790a0f6864a84b97a4817cf5.zip
linhes_pkgbuild-088d235213f43978790a0f6864a84b97a4817cf5.tar.gz
linhes_pkgbuild-088d235213f43978790a0f6864a84b97a4817cf5.tar.bz2
update mplayer
add xine various other libs needed by the above
Diffstat (limited to 'abs/extra-testing/xine-lib/PKGBUILD')
-rw-r--r--abs/extra-testing/xine-lib/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/extra-testing/xine-lib/PKGBUILD b/abs/extra-testing/xine-lib/PKGBUILD
new file mode 100644
index 0000000..de79173
--- /dev/null
+++ b/abs/extra-testing/xine-lib/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id: PKGBUILD 10479 2008-08-29 07:46:38Z pierre $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=xine-lib
+pkgver=1.1.15
+pkgrel=2
+pkgdesc="A free video player for Unix"
+arch=('i686' 'x86_64')
+url="http://xinehq.de/"
+license=('LGPL' 'GPL')
+depends=('libgl' 'libxvmc' 'flac>=1.1.4' 'libvorbis' 'sdl' 'libmng' 'libtheora'
+ 'libxcb' 'wavpack' 'ffmpeg>=20080715')
+makedepends=('pkgconfig' 'libtool' 'automake' 'autoconf' 'imagemagick'
+ 'smbclient' 'mesa' 'alsa-lib' )
+options=('!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/xine/${pkgname}-${pkgver}.tar.bz2
+ xine-lib-1.1.1-configure-no-mcpu-march.patch xine-header.patch)
+md5sums=('42a2b4893b7f892eb334de2fc36d49c8' '9776df4eb54d2f1f68d8268adbc3b5c2'
+ 'b139ee72700f8d118f9051e9140473f5')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Np0 -i ../xine-lib-1.1.1-configure-no-mcpu-march.patch || return 1
+ patch -p0 -i ../xine-header.patch || return 1
+ libtoolize --force --copy || return 1
+ aclocal -I m4 || return 1
+ autoconf || return 1
+ automake --add-missing || return 1
+
+ ./configure --prefix=/usr --with-w32-path=/usr/lib/codecs \
+ --with-xv-path=/usr/lib --with-libflac --with-wavpack \
+ --without-arts --without-jack --without-speex \
+ --disable-gnomevfs --without-pulseaudio --disable-aalib \
+ --disable-modplug --with-external-ffmpeg || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+}