summaryrefslogtreecommitdiffstats
path: root/abs/extra/bash-completion
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-24 01:56:29 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-24 01:56:29 (GMT)
commit2700f114424822082eae5868a0fddc8d9213c0ef (patch)
treea8b9a79053bdab256df4e8844e2d19658424ad63 /abs/extra/bash-completion
parent3ffa4baa017bc3d64a844560344abdb837340f95 (diff)
downloadlinhes_pkgbuild-2700f114424822082eae5868a0fddc8d9213c0ef.zip
linhes_pkgbuild-2700f114424822082eae5868a0fddc8d9213c0ef.tar.gz
linhes_pkgbuild-2700f114424822082eae5868a0fddc8d9213c0ef.tar.bz2
bash-completion: update to 2.7
Diffstat (limited to 'abs/extra/bash-completion')
-rw-r--r--abs/extra/bash-completion/PKGBUILD36
1 files changed, 18 insertions, 18 deletions
diff --git a/abs/extra/bash-completion/PKGBUILD b/abs/extra/bash-completion/PKGBUILD
index 575e523..a2b3d9c 100644
--- a/abs/extra/bash-completion/PKGBUILD
+++ b/abs/extra/bash-completion/PKGBUILD
@@ -2,33 +2,33 @@
# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgname=bash-completion
-pkgver=2.4
-pkgrel=1
-pkgdesc="Programmable completion for the bash shell"
+pkgver=2.7
+pkgrel=2
+pkgdesc='Programmable completion for the bash shell'
arch=('any')
-url="https://github.com/scop/bash-completion"
-license=('GPL2')
-depends=('bash')
-options=('!emptydirs' '!makeflags')
-source=("https://github.com/scop/bash-completion/releases/download/$pkgver/$pkgname-$pkgver.tar.xz")
-sha1sums=('c02fb9c0f669d178f678c291ea17ddadfd011250')
+url='https://github.com/scop/bash-completion'
+license=(GPL2)
+depends=(bash)
+options=(!emptydirs !makeflags)
+source=($url/releases/download/$pkgver/$pkgname-$pkgver.tar.xz)
+sha1sums=('2260342127086cfedd4801f796fdaaa051411a14')
build() {
- cd ${pkgname}-${pkgver}
+ cd $pkgname-$pkgver
./configure --prefix=/usr --sysconfdir=/etc
make
}
package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
-# bash-completion is sourced in /etc/bash.bashrc so that non-bash shell don't source it
- rm "${pkgdir}/etc/profile.d/bash_completion.sh"
+ # bash-completion is sourced in /etc/bash.bashrc so that non-bash shell don't source it
+ rm "$pkgdir/etc/profile.d/bash_completion.sh"
-# remove Slackware's makepkg completion
- rm "${pkgdir}/usr/share/bash-completion/completions/makepkg"
+ # remove Slackware's makepkg completion
+ rm "$pkgdir/usr/share/bash-completion/completions/makepkg"
-# remove completions which overlap with util-linux
- rm "${pkgdir}/usr/share/bash-completion/completions"/{u,}mount
+ # remove completions which overlap with util-linux
+ rm "$pkgdir/usr/share/bash-completion/completions"/{{u,}mount,rfkill}
}