summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/unrar
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/community/unrar
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/community/unrar')
-rw-r--r--abs/extra/community/unrar/PKGBUILD23
-rw-r--r--abs/extra/community/unrar/unrar-3.5.2-optimalization-fix.patch12
2 files changed, 35 insertions, 0 deletions
diff --git a/abs/extra/community/unrar/PKGBUILD b/abs/extra/community/unrar/PKGBUILD
new file mode 100644
index 0000000..6b68616
--- /dev/null
+++ b/abs/extra/community/unrar/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 18913 2008-11-10 11:16:31Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: dorphell <dorphell@gmx.net>
+
+pkgname=unrar
+pkgver=3.8.5
+pkgrel=1
+pkgdesc="The RAR uncompression program"
+arch=('i686' 'x86_64')
+depends=('gcc-libs')
+url="http://rarlab.com"
+license=('custom')
+replaces=('rar')
+source=(http://www.rarlab.com/rar/unrarsrc-${pkgver}.tar.gz)
+md5sums=('875688e6a144a3f75d2a6a0da3e43f8b')
+
+build() {
+ cd ${srcdir}/${pkgname}
+ make -f makefile.unix
+ install -Dm755 unrar ${pkgdir}/usr/bin/unrar
+ # install license
+ install -Dm644 license.txt ${pkgdir}/usr/share/licenses/$pkgname/license.txt
+}
diff --git a/abs/extra/community/unrar/unrar-3.5.2-optimalization-fix.patch b/abs/extra/community/unrar/unrar-3.5.2-optimalization-fix.patch
new file mode 100644
index 0000000..2ed2e6e
--- /dev/null
+++ b/abs/extra/community/unrar/unrar-3.5.2-optimalization-fix.patch
@@ -0,0 +1,12 @@
+diff -Naur unrar.orig/makefile.unix unrar/makefile.unix
+--- unrar.orig/makefile.unix 2005-05-27 21:53:56.000000000 +0000
++++ unrar/makefile.unix 2005-05-27 21:54:16.000000000 +0000
+@@ -7,7 +7,7 @@
+
+ # Linux using GCC
+ CXX=g++
+-CXXFLAGS=-O2
++CXXFLAGS=${CFLAGS}
+ DEFINES=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ STRIP=strip
+