summaryrefslogtreecommitdiffstats
path: root/abs/extra/community
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2012-04-27 04:14:34 (GMT)
committerCecil <knoppmyth@gmail.com>2012-04-27 04:14:34 (GMT)
commit78fb16866e4942bffa2d7db2c28a4d422236de0a (patch)
tree16f7172373a8986327c22a818574eb97968187d4 /abs/extra/community
parentddd3cca11c55e087b67c54bb53ea8d4d0180c7ea (diff)
downloadlinhes_pkgbuild-78fb16866e4942bffa2d7db2c28a4d422236de0a.zip
linhes_pkgbuild-78fb16866e4942bffa2d7db2c28a4d422236de0a.tar.gz
linhes_pkgbuild-78fb16866e4942bffa2d7db2c28a4d422236de0a.tar.bz2
portaudio:initial inclusion, dep of dolphin-emu.
Diffstat (limited to 'abs/extra/community')
-rw-r--r--abs/extra/community/portaudio/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra/community/portaudio/PKGBUILD b/abs/extra/community/portaudio/PKGBUILD
new file mode 100644
index 0000000..1872b94
--- /dev/null
+++ b/abs/extra/community/portaudio/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 55258 2011-09-07 18:41:32Z ebelanger $
+# Based on 'portaudio' package - Eric Belanger <eric@archlinux.org>
+# Last/Most-Recent Contributor: Darwin Bautista <djclue917@gmail.com>
+# Maintainer: Bob Finch <w9ya@qrparci.net>
+
+pkgname=portaudio
+pkgver=19_20110326
+pkgrel=1
+pkgdesc="A free, cross-platform, open source, audio I/O library"
+arch=('i686' 'x86_64')
+url="http://www.portaudio.com/"
+license=('custom')
+depends=('jack')
+options=('!libtool')
+source=(http://www.portaudio.com/archives/pa_stable_v$pkgver.tgz)
+md5sums=('8f266ce03638419ef46e4efcb0fabde6')
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}