summaryrefslogtreecommitdiffstats
path: root/abs/extra/community
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-31 01:35:17 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-31 01:35:17 (GMT)
commit8b08e5b127670b6d5fa7170477754fc3144cb309 (patch)
treebdfee8440555368ed920069443a2ba4fe595c9c1 /abs/extra/community
parent6325c32f07e7b2c360283b8f368c8b514993c9c8 (diff)
downloadlinhes_pkgbuild-8b08e5b127670b6d5fa7170477754fc3144cb309.zip
linhes_pkgbuild-8b08e5b127670b6d5fa7170477754fc3144cb309.tar.gz
linhes_pkgbuild-8b08e5b127670b6d5fa7170477754fc3144cb309.tar.bz2
Merge remote-tracking branch 'origin/testing' into testing
# By Britney Fransen (4) and others # Via Britney Fransen * origin/testing: dvb-firmware: add xc5000c firmware. change xc5000 modprobe options. closes #844 v4l-dvb: update to snapshot from 20120828. refs #844 LinHES-system: update myth_status.py to work with tuners in error. closes #843 curlftpfs: Initial Inclusion. linhes-scripts: minor changes to myth2mkv mythtv:Bumped to latest fixes. Added ./configure items to close #842. LinHES-config:7.4 rdt 9th anniversary release. Conflicts: abs/core/LinHES-config/LinHES-release abs/core/LinHES-config/PKGBUILD abs/core/LinHES-system/PKGBUILD abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
Diffstat (limited to 'abs/extra/community')
-rw-r--r--abs/extra/community/curlftpfs/PKGBUILD30
-rw-r--r--abs/extra/community/curlftpfs/ioerror.patch11
2 files changed, 41 insertions, 0 deletions
diff --git a/abs/extra/community/curlftpfs/PKGBUILD b/abs/extra/community/curlftpfs/PKGBUILD
new file mode 100644
index 0000000..242e28f
--- /dev/null
+++ b/abs/extra/community/curlftpfs/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: Allan McRae <mcrae_allan@hotmail.com>
+# Contributor: Philip Nilsson <leffeman@gmail.com>
+
+pkgname=curlftpfs
+pkgver=0.9.2
+pkgrel=4
+pkgdesc="A filesystem for acessing FTP hosts based on FUSE and libcurl."
+url="http://curlftpfs.sourceforge.net/"
+license=('GPL')
+depends=('curl>=7.15.4' 'fuse' 'glib2')
+makedepends=('pkgconfig>=0.9.0')
+arch=('i686' 'x86_64')
+source=(http://downloads.sourceforge.net/sourceforge/curlftpfs/$pkgname-$pkgver.tar.gz
+ ioerror.patch)
+md5sums=('b452123f755114cd4461d56c648d9f12'
+ '7a8db686293463ba3148c7032871c883')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < "$srcdir/ioerror.patch"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/abs/extra/community/curlftpfs/ioerror.patch b/abs/extra/community/curlftpfs/ioerror.patch
new file mode 100644
index 0000000..6ca1afb
--- /dev/null
+++ b/abs/extra/community/curlftpfs/ioerror.patch
@@ -0,0 +1,11 @@
+--- curlftpfs-0.9.2.orig/ftpfs.c 2008-04-30 03:05:47.000000000 +0400
++++ curlftpfs-0.9.2.orig/ftpfs.c 2011-01-20 20:33:38.000000000 +0300
+@@ -503,7 +503,7 @@ static void *ftpfs_write_thread(void *da
+
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_URL, fh->full_path);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_UPLOAD, 1);
+- curl_easy_setopt_or_die(fh->write_conn, CURLOPT_INFILESIZE, -1);
++ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_INFILESIZE, (curl_off_t)-1);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READFUNCTION, write_data_bg);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READDATA, fh);
+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_LOW_SPEED_LIMIT, 1);