summaryrefslogtreecommitdiffstats
path: root/abs/extra/cups
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-07-04 21:22:20 (GMT)
committerCecil <knoppmyth@gmail.com>2011-07-04 21:22:20 (GMT)
commit473c18ce7f181ef05ba9855276c072f86ac5cd7c (patch)
tree16269e89dd35c18aa9944768859664ce19feb1f4 /abs/extra/cups
parent061a8311857dd0d80e70269b159379c3adbf770e (diff)
downloadlinhes_pkgbuild-473c18ce7f181ef05ba9855276c072f86ac5cd7c.zip
linhes_pkgbuild-473c18ce7f181ef05ba9855276c072f86ac5cd7c.tar.gz
linhes_pkgbuild-473c18ce7f181ef05ba9855276c072f86ac5cd7c.tar.bz2
cups:bumped to latest
Diffstat (limited to 'abs/extra/cups')
-rw-r--r--abs/extra/cups/PKGBUILD19
-rw-r--r--abs/extra/cups/cups-avahi.patch46
-rw-r--r--abs/extra/cups/cups.install10
-rw-r--r--abs/extra/cups/cups.logrotate8
4 files changed, 41 insertions, 42 deletions
diff --git a/abs/extra/cups/PKGBUILD b/abs/extra/cups/PKGBUILD
index e1f13b7..730bed3 100644
--- a/abs/extra/cups/PKGBUILD
+++ b/abs/extra/cups/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 82848 2010-06-18 06:18:19Z andyrtr $
+# $Id: PKGBUILD 98719 2010-11-12 22:23:13Z andyrtr $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgbase="cups"
pkgname=('libcups' 'cups')
-pkgver=1.4.4
+pkgver=1.4.5
pkgrel=1
arch=('i686' 'x86_64')
license=('GPL')
@@ -14,8 +14,8 @@ source=(ftp://ftp.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.bz2
cups-avahi.patch
cups cups.logrotate cups.pam)
#options=('!emptydirs')
-md5sums=('8776403ad60fea9e85eab9c04d88560d'
- '3388dbe3fc20f16f37912e60a8ec46bc'
+md5sums=('50729f6fc46ba54223e0eaf5009f3419'
+ '8ebd390197501ffd709f0ee546937fd5'
'5c85b7d8d2ddd02c2c64955cebbf55ea'
'f861b18f4446c43918c8643dcbbd7f6d'
'96f82c38f3f540b53f3e5144900acf17')
@@ -24,23 +24,23 @@ build() {
cd ${srcdir}/${pkgbase}-${pkgver}
# Avahi support in the dnssd backend. patch from Fedora
patch -Np1 -i ${srcdir}/cups-avahi.patch || return 1
+
# Rebuild configure script for --enable-avahi.
aclocal -I config-scripts
autoconf -I config-scripts
+
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--with-logdir=/var/log/cups -with-docdir=/usr/share/cups/doc \
--with-cups-user=daemon --with-cups-group=lp --enable-pam=yes \
--disable-ldap --libdir=/usr/lib --enable-raw-printing \
- --enable-dbus --with-dbusdir=/etc/dbus-1 --enable-ssl=yes --enable-gnutls --disable-threads --enable-dnssd\
+ --enable-dbus --with-dbusdir=/etc/dbus-1 --enable-ssl=yes --enable-gnutls --disable-threads --enable-avahi\
--with-php=/usr/bin/php-cgi --with-pdftops=pdftops --with-optim="$CFLAGS"
make || return 1
}
package_libcups() {
pkgdesc="The CUPS Printing System - client libraries and headers"
-depends=('gnutls>=2.8.3' 'libtiff>=3.9.2-2' 'libpng>=1.4.0' 'heimdal>=1.3.1')
-optdepends=('avahi: for the "dnssd" CUPS backend')
-
+depends=('gnutls>=2.8.3' 'libtiff>=3.9.2-2' 'libpng>=1.4.0' 'heimdal>=1.3.1' 'avahi')
cd ${srcdir}/${pkgbase}-${pkgver}
make BUILDROOT=${pkgdir} install-headers install-libs || return 1
@@ -83,6 +83,9 @@ optdepends=('php: for included phpcups.so module')
# fix perms on /var/spool and /etc
chmod 755 ${pkgdir}/var/spool
chmod 755 ${pkgdir}/etc
+
+ # serial backend needs to run as root (http://bugs.archlinux.org/task/20396)
+ chmod 700 ${pkgdir}/usr/lib/cups/backend/serial
# install ssl directory where to store the certs, solves some samba issues
install -dm700 -g lp ${pkgdir}/etc/cups/ssl
diff --git a/abs/extra/cups/cups-avahi.patch b/abs/extra/cups/cups-avahi.patch
index 01fcb1a..cf1056a 100644
--- a/abs/extra/cups/cups-avahi.patch
+++ b/abs/extra/cups/cups-avahi.patch
@@ -1,6 +1,6 @@
-diff -up cups-1.4.0/backend/dnssd.c.avahi cups-1.4.0/backend/dnssd.c
---- cups-1.4.0/backend/dnssd.c.avahi 2009-08-07 23:27:12.000000000 +0100
-+++ cups-1.4.0/backend/dnssd.c 2009-09-04 14:57:04.730388833 +0100
+diff -up cups-1.4.5/backend/dnssd.c.avahi cups-1.4.5/backend/dnssd.c
+--- cups-1.4.5/backend/dnssd.c.avahi 2009-08-08 00:27:12.000000000 +0200
++++ cups-1.4.5/backend/dnssd.c 2010-11-12 13:13:31.000000000 +0100
@@ -22,6 +22,7 @@
* exec_backend() - Execute the backend that corresponds to the
* resolved service name.
@@ -794,10 +794,10 @@ diff -up cups-1.4.0/backend/dnssd.c.avahi cups-1.4.0/backend/dnssd.c
/*
* 'sigterm_handler()' - Handle termination signals...
*/
-diff -up cups-1.4.0/config.h.in.avahi cups-1.4.0/config.h.in
---- cups-1.4.0/config.h.in.avahi 2009-06-10 16:51:21.000000000 +0100
-+++ cups-1.4.0/config.h.in 2009-09-04 14:57:04.733388405 +0100
-@@ -336,6 +336,13 @@
+diff -up cups-1.4.5/config.h.in.avahi cups-1.4.5/config.h.in
+--- cups-1.4.5/config.h.in.avahi 2010-08-13 06:11:46.000000000 +0200
++++ cups-1.4.5/config.h.in 2010-11-12 13:13:31.000000000 +0100
+@@ -344,6 +344,13 @@
/*
@@ -811,9 +811,9 @@ diff -up cups-1.4.0/config.h.in.avahi cups-1.4.0/config.h.in
* Do we have <sys/ioctl.h>?
*/
-diff -up cups-1.4.0/config-scripts/cups-dnssd.m4.avahi cups-1.4.0/config-scripts/cups-dnssd.m4
---- cups-1.4.0/config-scripts/cups-dnssd.m4.avahi 2009-02-10 17:05:35.000000000 +0000
-+++ cups-1.4.0/config-scripts/cups-dnssd.m4 2009-09-04 14:57:04.731388902 +0100
+diff -up cups-1.4.5/config-scripts/cups-dnssd.m4.avahi cups-1.4.5/config-scripts/cups-dnssd.m4
+--- cups-1.4.5/config-scripts/cups-dnssd.m4.avahi 2009-08-29 00:54:34.000000000 +0200
++++ cups-1.4.5/config-scripts/cups-dnssd.m4 2010-11-12 13:13:31.000000000 +0100
@@ -27,6 +27,21 @@ AC_ARG_WITH(dnssd-includes, [ --with-dn
DNSSDLIBS=""
DNSSD_BACKEND=""
@@ -836,9 +836,9 @@ diff -up cups-1.4.0/config-scripts/cups-dnssd.m4.avahi cups-1.4.0/config-scripts
if test x$enable_dnssd != xno; then
AC_CHECK_HEADER(dns_sd.h, [
case "$uname" in
-diff -up cups-1.4.0/cups/http-support.c.avahi cups-1.4.0/cups/http-support.c
---- cups-1.4.0/cups/http-support.c.avahi 2009-06-12 01:21:58.000000000 +0100
-+++ cups-1.4.0/cups/http-support.c 2009-09-04 14:57:04.736398674 +0100
+diff -up cups-1.4.5/cups/http-support.c.avahi cups-1.4.5/cups/http-support.c
+--- cups-1.4.5/cups/http-support.c.avahi 2010-10-02 00:40:38.000000000 +0200
++++ cups-1.4.5/cups/http-support.c 2010-11-12 13:28:45.000000000 +0100
@@ -55,6 +55,11 @@
# include <dns_sd.h>
# include <poll.h>
@@ -876,7 +876,7 @@ diff -up cups-1.4.0/cups/http-support.c.avahi cups-1.4.0/cups/http-support.c
/*
* 'httpAssembleURI()' - Assemble a uniform resource identifier from its
-@@ -1349,15 +1372,26 @@ _httpResolveURI(
+@@ -1351,16 +1374,27 @@ _httpResolveURI(
if (strstr(hostname, "._tcp"))
{
@@ -887,7 +887,8 @@ diff -up cups-1.4.0/cups/http-support.c.avahi cups-1.4.0/cups/http-support.c
DNSServiceRef ref, /* DNS-SD master service reference */
domainref, /* DNS-SD service reference for domain */
localref; /* DNS-SD service reference for .local */
- int domainsent = 0; /* Send the domain resolve? */
+ int domainsent = 0, /* Send the domain resolve? */
+ offline = 0; /* offline-report state set? */
- char *regtype, /* Pointer to type in hostname */
- *domain; /* Pointer to domain in hostname */
_http_uribuf_t uribuf; /* URI buffer */
@@ -905,7 +906,7 @@ diff -up cups-1.4.0/cups/http-support.c.avahi cups-1.4.0/cups/http-support.c
if (logit)
-@@ -1395,8 +1429,13 @@ _httpResolveURI(
+@@ -1398,8 +1432,13 @@ _httpResolveURI(
if (domain)
*domain++ = '\0';
@@ -919,7 +920,7 @@ diff -up cups-1.4.0/cups/http-support.c.avahi cups-1.4.0/cups/http-support.c
resolved_uri[0] = '\0';
-@@ -1411,6 +1450,7 @@ _httpResolveURI(
+@@ -1414,6 +1453,7 @@ _httpResolveURI(
uri = NULL;
@@ -927,7 +928,7 @@ diff -up cups-1.4.0/cups/http-support.c.avahi cups-1.4.0/cups/http-support.c
if (DNSServiceCreateConnection(&ref) == kDNSServiceErr_NoError)
{
localref = ref;
-@@ -1486,6 +1526,36 @@ _httpResolveURI(
+@@ -1500,6 +1540,36 @@ _httpResolveURI(
DNSServiceRefDeallocate(ref);
}
@@ -964,8 +965,8 @@ diff -up cups-1.4.0/cups/http-support.c.avahi cups-1.4.0/cups/http-support.c
if (logit)
{
-@@ -1497,13 +1567,13 @@ _httpResolveURI(
- fputs("STATE: -connecting-to-device\n", stderr);
+@@ -1511,13 +1581,13 @@ _httpResolveURI(
+ fputs("STATE: -connecting-to-device,offline-report\n", stderr);
}
-#else
@@ -980,7 +981,7 @@ diff -up cups-1.4.0/cups/http-support.c.avahi cups-1.4.0/cups/http-support.c
if (logit && !uri)
_cupsLangPuts(stderr, _("Unable to find printer!\n"));
-@@ -1708,6 +1778,105 @@ resolve_callback(
+@@ -1722,6 +1792,105 @@ resolve_callback(
}
#endif /* HAVE_DNSSD */
@@ -1085,5 +1086,4 @@ diff -up cups-1.4.0/cups/http-support.c.avahi cups-1.4.0/cups/http-support.c
+
/*
- * End of "$Id: http-support.c 8705 2009-06-12 00:21:58Z mike $".
-
+ * End of "$Id: http-support.c 9322 2010-10-01 22:40:38Z mike $".
diff --git a/abs/extra/cups/cups.install b/abs/extra/cups/cups.install
index 97fda5a..e92e17e 100644
--- a/abs/extra/cups/cups.install
+++ b/abs/extra/cups/cups.install
@@ -1,11 +1,15 @@
post_install() {
- xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+ echo ">> If you use an HTTPS connection to CUPS, the first time you access"
+ echo ">> the interface it may take a very long time before the site comes up."
+ echo ">> This is because the first request triggers the generation of the CUPS"
+ echo ">> SSL certificates which can be a very time-consuming job."
}
post_upgrade() {
- post_install
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
}
post_remove() {
- post_install
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
}
diff --git a/abs/extra/cups/cups.logrotate b/abs/extra/cups/cups.logrotate
deleted file mode 100644
index 9c49bbd..0000000
--- a/abs/extra/cups/cups.logrotate
+++ /dev/null
@@ -1,8 +0,0 @@
-/var/log/cups/*log {
- missingok
- notifempty
- delaycompress
- postrotate
- /bin/kill -HUP `cat /var/run/cups.pid 2>/dev/null` 2>/dev/null || true
- endscript
-}