summaryrefslogtreecommitdiffstats
path: root/abs/extra/dotconf
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-08-22 15:51:00 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-08-22 15:51:00 (GMT)
commit4cba5850fbd8199f2b2bf2af8c31bc47d953df90 (patch)
tree56d26abf572bddf77abd51170c718561e97503d8 /abs/extra/dotconf
parent820ad5cb2cd594b29b561e2f70f1f6bad5b287dd (diff)
downloadlinhes_pkgbuild-4cba5850fbd8199f2b2bf2af8c31bc47d953df90.zip
linhes_pkgbuild-4cba5850fbd8199f2b2bf2af8c31bc47d953df90.tar.gz
linhes_pkgbuild-4cba5850fbd8199f2b2bf2af8c31bc47d953df90.tar.bz2
dotconf: initial inclusion. dep of speech-dispatcher.
Diffstat (limited to 'abs/extra/dotconf')
-rw-r--r--abs/extra/dotconf/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/extra/dotconf/PKGBUILD b/abs/extra/dotconf/PKGBUILD
new file mode 100644
index 0000000..07e7e91
--- /dev/null
+++ b/abs/extra/dotconf/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer:
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Chris Brannon <cmbrannon@cox.net>
+
+pkgname=dotconf
+pkgver=1.3
+pkgrel=3
+pkgdesc='A C library for parsing configuration files'
+url="https://github.com/williamh/dotconf"
+arch=('i686' 'x86_64')
+depends=('glibc')
+makedepends=('pkgconfig' 'findutils')
+license=('LGPL2.1')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/williamh/${pkgname}/tarball/v${pkgver}")
+md5sums=('36bfdde245072fc2f4f5766b7db97c45')
+options=('!libtool')
+
+build() {
+ cd "${srcdir}"/williamh-${pkgname}-4cd7b3a
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}"/williamh-${pkgname}-4cd7b3a
+ make DESTDIR="${pkgdir}" install
+}