summaryrefslogtreecommitdiffstats
path: root/abs/extra/gd
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-02-07 21:26:54 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-02-07 21:26:54 (GMT)
commitd4883c4c193386f582479372364dc799ea941cd9 (patch)
tree47debafe27fee3093efd7f063dabbb0611e4f077 /abs/extra/gd
parentdfb572772726c46ee88deb6e2538af8a9848f880 (diff)
downloadlinhes_pkgbuild-d4883c4c193386f582479372364dc799ea941cd9.zip
linhes_pkgbuild-d4883c4c193386f582479372364dc799ea941cd9.tar.gz
linhes_pkgbuild-d4883c4c193386f582479372364dc799ea941cd9.tar.bz2
gd: update to 2.2.3
Diffstat (limited to 'abs/extra/gd')
-rw-r--r--abs/extra/gd/PKGBUILD30
-rw-r--r--abs/extra/gd/gd-2.1.1-libvpx-1.4.0.patch37
2 files changed, 10 insertions, 57 deletions
diff --git a/abs/extra/gd/PKGBUILD b/abs/extra/gd/PKGBUILD
index 4988f09..75242e6 100644
--- a/abs/extra/gd/PKGBUILD
+++ b/abs/extra/gd/PKGBUILD
@@ -1,43 +1,33 @@
# $Id$
+# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgname=gd
-pkgver=2.1.1
+pkgver=2.2.3
pkgrel=3
pkgdesc="Library for the dynamic creation of images by programmers"
arch=('i686' 'x86_64')
url="http://www.libgd.org/"
license=('custom')
-depends=('fontconfig' 'libvpx' 'libxpm' 'libtiff')
-makedepends=('git')
+depends=('fontconfig' 'libxpm' 'libwebp')
optdepends=('perl: bdftogd script')
-source=("${pkgname}::git+https://github.com/libgd/libgd.git#tag=${pkgname}-${pkgver}"
- gd-2.1.1-libvpx-1.4.0.patch)
-md5sums=('SKIP'
- '9114dd8259aaa88b0a09188fe7b19afc')
-
-prepare() {
- cd ${pkgname}
- ./bootstrap.sh
- patch -p1 -i "${srcdir}/gd-2.1.1-libvpx-1.4.0.patch"
-}
+source=("https://github.com/libgd/libgd/releases/download/gd-${pkgver}/libgd-${pkgver}.tar.xz")
+md5sums=('14e4134c129b4c166c3a0549a32ef340')
build() {
- cd ${pkgname}
+ cd libgd-${pkgver}
./configure \
--prefix=/usr \
- --disable-rpath \
- --with-vpx=/usr \
- --with-tiff=/usr
+ --disable-rpath
make
}
check() {
- cd ${pkgname}
- make check
+ cd libgd-${pkgver}
+ [[ ${CARCH} == 'i686' ]] || make check
}
package() {
- cd ${pkgname}
+ cd libgd-${pkgver}
make DESTDIR="${pkgdir}" install
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/abs/extra/gd/gd-2.1.1-libvpx-1.4.0.patch b/abs/extra/gd/gd-2.1.1-libvpx-1.4.0.patch
deleted file mode 100644
index c698972..0000000
--- a/abs/extra/gd/gd-2.1.1-libvpx-1.4.0.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From d41eb72cd4545c394578332e5c102dee69e02ee8 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Tue, 7 Apr 2015 13:11:03 +0200
-Subject: [PATCH] Fix build with latest libvpx 1.4.0
-
-These new constants exist at least since 1.0.0
-Compatibility ones have been droped in 1.4.0
----
- src/webpimg.c | 14 +++++++-------
- 1 file changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/src/webpimg.c b/src/webpimg.c
-index cf73d64..e49fcc6 100644
---- a/src/webpimg.c
-+++ b/src/webpimg.c
-@@ -711,14 +711,14 @@ static WebPResult VPXEncode(const uint8* Y,
- codec_ctl(&enc, VP8E_SET_STATIC_THRESHOLD, 0);
- codec_ctl(&enc, VP8E_SET_TOKEN_PARTITIONS, 2);
-
-- vpx_img_wrap(&img, IMG_FMT_I420,
-+ vpx_img_wrap(&img, VPX_IMG_FMT_I420,
- y_width, y_height, 16, (uint8*)(Y));
-- img.planes[PLANE_Y] = (uint8*)(Y);
-- img.planes[PLANE_U] = (uint8*)(U);
-- img.planes[PLANE_V] = (uint8*)(V);
-- img.stride[PLANE_Y] = y_stride;
-- img.stride[PLANE_U] = uv_stride;
-- img.stride[PLANE_V] = uv_stride;
-+ img.planes[VPX_PLANE_Y] = (uint8*)(Y);
-+ img.planes[VPX_PLANE_U] = (uint8*)(U);
-+ img.planes[VPX_PLANE_V] = (uint8*)(V);
-+ img.stride[VPX_PLANE_Y] = y_stride;
-+ img.stride[VPX_PLANE_U] = uv_stride;
-+ img.stride[VPX_PLANE_V] = uv_stride;
-
- res = vpx_codec_encode(&enc, &img, 0, 1, 0, VPX_DL_BEST_QUALITY);
-