summaryrefslogtreecommitdiffstats
path: root/abs/extra/ifenslave
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/ifenslave
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/ifenslave')
-rw-r--r--abs/extra/ifenslave/PKGBUILD20
-rw-r--r--abs/extra/ifenslave/bonding.conf.d12
2 files changed, 32 insertions, 0 deletions
diff --git a/abs/extra/ifenslave/PKGBUILD b/abs/extra/ifenslave/PKGBUILD
new file mode 100644
index 0000000..8a75170
--- /dev/null
+++ b/abs/extra/ifenslave/PKGBUILD
@@ -0,0 +1,20 @@
+# $Id: PKGBUILD 12836 2008-09-21 14:41:26Z dan $
+# Maintainer: Judd Vinet <jvinet@zeroflux.org>
+pkgname=ifenslave
+pkgver=1.1.0
+pkgrel=4
+pkgdesc="Utility for bonding ethernet interfaces"
+license=('GPL2')
+arch=(i686 x86_64)
+url="http://www.linuxfoundation.org/en/Net:Bonding"
+depends=('glibc')
+source=(ftp://ftp.archlinux.org/other/ifenslave/ifenslave.c bonding.conf.d)
+md5sums=('b0d8e4c97094155747cc9238f762c7aa'
+ '397fccbf574d5082c7a3c8d3793dc000')
+
+build() {
+ cd $startdir/src
+ gcc $CFLAGS -I/usr/src/linux/include ifenslave.c -o ifenslave || return 1
+ install -D -m755 ifenslave $startdir/pkg/sbin/ifenslave
+ install -D -m644 bonding.conf.d $startdir/pkg/etc/conf.d/bonding
+}
diff --git a/abs/extra/ifenslave/bonding.conf.d b/abs/extra/ifenslave/bonding.conf.d
new file mode 100644
index 0000000..3092c5e
--- /dev/null
+++ b/abs/extra/ifenslave/bonding.conf.d
@@ -0,0 +1,12 @@
+#
+# Settings for ethernet bonding
+#
+# For each bond interface declared in INTERFACES (in rc.conf), declare
+# a bond_${IF} variable that contains the real ethernet interfaces that
+# should be bonded to the bond interface with the ifenslave utility.
+# Then list the bond interface name in the BOND_INTERFACES array.
+#
+
+#bond_bond0="eth0 eth1"
+#BOND_INTERFACES=(bond0)
+