summaryrefslogtreecommitdiffstats
path: root/abs/extra/js52/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-27 13:34:54 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-27 13:34:54 (GMT)
commitef0a21c1b5b942595b706064f4122ed16fc4a0a9 (patch)
tree5b35ade3d85026d56455eb89ba35c815262f2fcf /abs/extra/js52/PKGBUILD
parent168df166590c264c05a7385776d80c30591a6ba6 (diff)
downloadlinhes_pkgbuild-ef0a21c1b5b942595b706064f4122ed16fc4a0a9.zip
linhes_pkgbuild-ef0a21c1b5b942595b706064f4122ed16fc4a0a9.tar.gz
linhes_pkgbuild-ef0a21c1b5b942595b706064f4122ed16fc4a0a9.tar.bz2
js52: dep of polkit
Diffstat (limited to 'abs/extra/js52/PKGBUILD')
-rw-r--r--abs/extra/js52/PKGBUILD75
1 files changed, 75 insertions, 0 deletions
diff --git a/abs/extra/js52/PKGBUILD b/abs/extra/js52/PKGBUILD
new file mode 100644
index 0000000..6338a13
--- /dev/null
+++ b/abs/extra/js52/PKGBUILD
@@ -0,0 +1,75 @@
+# $Id$
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=js52
+pkgver=52.7.3
+pkgrel=1
+_ffver=${pkgver%%.*}
+pkgdesc="JavaScript interpreter and libraries - Version $_ffver"
+arch=(x86_64)
+url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
+license=(MPL)
+depends=(gcc-libs readline zlib sh)
+makedepends=(python2 zip autoconf2.13 mercurial)
+_repo=https://hg.mozilla.org/mozilla-unified
+source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}esr_RELEASE"
+ mozjs52-copy-headers.patch
+ mozjs52-disable-mozglue.patch
+ mozjs52-fix-soname.patch
+ mozjs52-include-configure-script.patch)
+sha256sums=('SKIP'
+ 'c5b3a88e4d10ef149aba6fc48d431db54ff266323fa22a5d549028fd794423cc'
+ '5a84f02521f37de873991dd360a4c4bfdbdd2fb4a218e11be73f9cbbf02050e8'
+ '06389b8e30465bb8e6fab6144dadedffa30595f143a686524da175b5cf5e8a27'
+ 'd91a89acd88bfc747a255050757a0c17139bf5c3508c2e1c3c6bb2056786a344')
+
+prepare() {
+ cd mozilla-unified
+
+ # https://anonscm.debian.org/git/pkg-gnome/mozjs52.git/tree/debian/patches
+ patch -Np1 -i ../mozjs52-fix-soname.patch
+ patch -Np1 -i ../mozjs52-copy-headers.patch
+ patch -Np1 -i ../mozjs52-disable-mozglue.patch
+ patch -Np1 -i ../mozjs52-include-configure-script.patch
+}
+
+build() {
+ unset CPPFLAGS
+ CFLAGS+=' -fno-delete-null-pointer-checks -fno-strict-aliasing -fno-tree-vrp -flto=3'
+ CXXFLAGS+=' -fno-delete-null-pointer-checks -fno-strict-aliasing -fno-tree-vrp -flto=3'
+ export CC=gcc CXX=g++ PYTHON=/usr/bin/python2 SHELL=/bin/bash
+
+ cd mozilla-unified/js/src
+ sh configure \
+ --prefix=/usr \
+ --disable-debug \
+ --disable-debug-symbols \
+ --disable-strip \
+ --enable-gold \
+ --enable-optimize="-O2" \
+ --enable-pie \
+ --enable-posix-nspr-emulation \
+ --enable-readline \
+ --enable-release \
+ --enable-shared-js \
+ --enable-tests \
+ --with-intl-api \
+ --with-system-zlib \
+ --without-system-icu
+ make
+}
+
+check() {
+ cd mozilla-unified/js/src
+ python2 tests/jstests.py -d -s -t 300 --no-progress ../../js/src/js/src/shell/js
+ python2 jit-test/jit_test.py -s -t 300 --no-progress ../../js/src/js/src/shell/js basic
+}
+
+package() {
+ cd mozilla-unified/js/src
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/lib/*.ajs
+ find "$pkgdir"/usr/{lib/pkgconfig,include} -type f -exec chmod -c a-x {} +
+}
+
+# vim:set ts=2 sw=2 et: