summaryrefslogtreecommitdiffstats
path: root/abs/extra/libotf
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-07 15:03:21 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-07 15:03:21 (GMT)
commit04d51a2dda374d5af31cebe06ba7d0f9b4c1b974 (patch)
tree6a338b24f8433008fd8b9b14371ca2f3e4b8a92d /abs/extra/libotf
parent7ddd7405fd1097967e25ae63f62a95ab64d4f873 (diff)
downloadlinhes_pkgbuild-04d51a2dda374d5af31cebe06ba7d0f9b4c1b974.zip
linhes_pkgbuild-04d51a2dda374d5af31cebe06ba7d0f9b4c1b974.tar.gz
linhes_pkgbuild-04d51a2dda374d5af31cebe06ba7d0f9b4c1b974.tar.bz2
emacs: 24.2
required by emacs: libotf mn17n
Diffstat (limited to 'abs/extra/libotf')
-rw-r--r--abs/extra/libotf/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/extra/libotf/PKGBUILD b/abs/extra/libotf/PKGBUILD
new file mode 100644
index 0000000..3c2743f
--- /dev/null
+++ b/abs/extra/libotf/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 172457 2012-12-03 05:46:28Z bisson $
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Ashish Shukla <wahjava.ml@gmail.com>
+
+pkgname=libotf
+pkgver=0.9.13
+pkgrel=1
+pkgdesc='OpenType Font library'
+url='http://www.nongnu.org/m17n/'
+license=('LGPL')
+options=('!libtool')
+arch=('i686' 'x86_64')
+depends=('libxaw' 'freetype2')
+source=("http://download.savannah.gnu.org/releases/m17n//${pkgname}-${pkgver}.tar.gz")
+sha1sums=('66bb81958f5f07ee1f8917d3cb7e359ae559d873')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}