summaryrefslogtreecommitdiffstats
path: root/abs/extra/libva/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-21 20:42:23 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-21 20:42:23 (GMT)
commit7fb1a88facfc7f36f1d2731f3e772065689526d8 (patch)
treebe0e88eb39ce299485eedf7078703445ddc678de /abs/extra/libva/PKGBUILD
parent96f619beddc8dbdd1f704f3b10b8aca598747b4c (diff)
downloadlinhes_pkgbuild-7fb1a88facfc7f36f1d2731f3e772065689526d8.zip
linhes_pkgbuild-7fb1a88facfc7f36f1d2731f3e772065689526d8.tar.gz
linhes_pkgbuild-7fb1a88facfc7f36f1d2731f3e772065689526d8.tar.bz2
libva: update to 2.1.0
Diffstat (limited to 'abs/extra/libva/PKGBUILD')
-rw-r--r--abs/extra/libva/PKGBUILD33
1 files changed, 20 insertions, 13 deletions
diff --git a/abs/extra/libva/PKGBUILD b/abs/extra/libva/PKGBUILD
index 2d6d0e1..b8037c6 100644
--- a/abs/extra/libva/PKGBUILD
+++ b/abs/extra/libva/PKGBUILD
@@ -1,29 +1,36 @@
# $Id$
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
-# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Maintainer: Maxime Gauduin <alucryd@archlonux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=libva
-pkgver=1.7.3
+pkgver=2.1.0
pkgrel=1
pkgdesc='Video Acceleration (VA) API for Linux'
-arch=('i686' 'x86_64')
-url='http://freedesktop.org/wiki/Software/vaapi'
+arch=('x86_64')
+url='https://01.org/linuxmedia/vaapi'
license=('MIT')
-depends=('libgl' 'libdrm' 'libxfixes')
+depends=('glibc' 'libdrm' 'libgl' 'libx11' 'libxext' 'libxfixes' 'wayland')
makedepends=('mesa')
optdepends=('libva-vdpau-driver: backend for Nvidia and AMD cards'
'libva-intel-driver: backend for Intel cards')
-source=(https://freedesktop.org/software/vaapi/releases/$pkgname/$pkgname-$pkgver.tar.bz2)
-sha1sums=('18e46f3d5a0e971eb0ec9fe14bc021e69eb13fb8')
+provides=('libva-drm.so' 'libva-glx.so' 'libva-wayland.so' 'libva-x11.so' 'libva.so')
+source=("https://github.com/01org/libva/releases/download/${pkgver}/libva-${pkgver}.tar.bz2")
+sha256sums=('f3fa953a11d3210c3a4ee79031abdbe0863d5ce13d9b3f93f315f1eec60a4b0f')
build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr
+ cd libva-${pkgver}
+
+ ./configure \
+ --prefix='/usr'
make
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ cd libva-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm 644 COPYING -t "${pkgdir}"/usr/share/licenses/libva
}
+
+# vim: ts=2 sw=2 et: