summaryrefslogtreecommitdiffstats
path: root/abs/extra/libzip/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-15 15:47:52 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-15 15:47:52 (GMT)
commit82bd3af1ac492cb8a5218127774994a5fdb40d0e (patch)
tree1114ab9743c9bad4da4cefe35bcb9ffe2e9182c2 /abs/extra/libzip/PKGBUILD
parent440baa856ce8af1c042b7fb559ff84e4cfa01d0b (diff)
downloadlinhes_pkgbuild-82bd3af1ac492cb8a5218127774994a5fdb40d0e.zip
linhes_pkgbuild-82bd3af1ac492cb8a5218127774994a5fdb40d0e.tar.gz
linhes_pkgbuild-82bd3af1ac492cb8a5218127774994a5fdb40d0e.tar.bz2
libzip: 0.10.1
-new
Diffstat (limited to 'abs/extra/libzip/PKGBUILD')
-rw-r--r--abs/extra/libzip/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/extra/libzip/PKGBUILD b/abs/extra/libzip/PKGBUILD
new file mode 100644
index 0000000..b95a3a4
--- /dev/null
+++ b/abs/extra/libzip/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 154546 2012-03-30 00:01:03Z eric $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=libzip
+pkgver=0.10.1
+pkgrel=1
+pkgdesc="A C library for reading, creating, and modifying zip archives"
+url="http://www.nih.at/libzip/index.html"
+license=('BSD')
+arch=('i686' 'x86_64')
+depends=('zlib')
+options=('!libtool')
+source=("http://www.nih.at/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+ 'fix-headers.patch')
+md5sums=('d3e933ae049204badccf605f20aaecde'
+ '249395bd3a426c4c4e993e9d4753e1dd')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -p1 -i "${srcdir}/fix-headers.patch"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}