summaryrefslogtreecommitdiffstats
path: root/abs/extra/lua
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-05 17:53:40 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-05 17:53:40 (GMT)
commitbfa4f69671e32edd3b6a27f73fc6a35b5bc25413 (patch)
tree7f8c0da603b5e1659f4cf9ba61c8353cab4bb562 /abs/extra/lua
parentbdc75bc0a99e901e6b0a0eefb3abed17bdb7de70 (diff)
downloadlinhes_pkgbuild-bfa4f69671e32edd3b6a27f73fc6a35b5bc25413.zip
linhes_pkgbuild-bfa4f69671e32edd3b6a27f73fc6a35b5bc25413.tar.gz
linhes_pkgbuild-bfa4f69671e32edd3b6a27f73fc6a35b5bc25413.tar.bz2
lua: update to 5.2.3
Diffstat (limited to 'abs/extra/lua')
-rw-r--r--abs/extra/lua/LICENSE30
-rw-r--r--abs/extra/lua/PKGBUILD65
-rw-r--r--abs/extra/lua/liblua.so.patch57
-rw-r--r--abs/extra/lua/lua-5.1-cflags.diff13
-rw-r--r--abs/extra/lua/lua-arch.patch66
-rw-r--r--abs/extra/lua/lua.pc20
6 files changed, 145 insertions, 106 deletions
diff --git a/abs/extra/lua/LICENSE b/abs/extra/lua/LICENSE
new file mode 100644
index 0000000..3ef2940
--- /dev/null
+++ b/abs/extra/lua/LICENSE
@@ -0,0 +1,30 @@
+License
+
+Lua is free software distributed under the terms of the MIT license
+reproduced below; it may be used for any purpose, including commercial
+purposes, at absolutely no cost without having to ask us. The only
+requirement is that if you do use Lua, then you should give us credit
+by including the appropriate copyright notice somewhere in your
+product or its documentation.
+
+ Copyright © 1994–2012 Lua.org, PUC-Rio.
+
+ Permission is hereby granted, free of charge, to any person
+ obtaining a copy of this software and associated documentation
+ files (the "Software"), to deal in the Software without
+ restriction, including without limitation the rights to use, copy,
+ modify, merge, publish, distribute, sublicense, and/or sell copies
+ of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+
+ The above copyright notice and this permission notice shall be
+ included in all copies or substantial portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+ HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ DEALINGS IN THE SOFTWARE.
diff --git a/abs/extra/lua/PKGBUILD b/abs/extra/lua/PKGBUILD
index 9ed38d8..5f10af4 100644
--- a/abs/extra/lua/PKGBUILD
+++ b/abs/extra/lua/PKGBUILD
@@ -1,42 +1,53 @@
-# $Id: PKGBUILD 156332 2012-04-17 10:35:09Z bluewind $
-# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
+# $Id$
+# Maintainer: Sébastien Luttringer <seblu@archlinux.org>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
-pkgname=lua
-pkgver=5.1.5
-pkgrel=2
-pkgdesc="A powerful light-weight programming language designed for extending applications"
+pkgname=lua
+pkgver=5.2.3
+pkgrel=1
+pkgdesc='Powerful light-weight programming language designed for extending applications'
arch=('i686' 'x86_64')
-url="http://www.lua.org/"
+url='http://www.lua.org/'
depends=('readline')
license=('MIT')
options=('!makeflags' '!emptydirs')
-source=(http://www.lua.org/ftp/${pkgname}-${pkgver}.tar.gz
- lua-arch.patch lua-5.1-cflags.diff)
-md5sums=('2e115fe26e435e33b0d5c022e4490567'
- 'fa25feb70ef9fec975b1c20da5098b3c'
- '249582bf1fd861ccf492d2c35a9fe732')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 -i "${srcdir}/lua-arch.patch"
- patch -p1 -i "${srcdir}/lua-5.1-cflags.diff"
+source=(http://www.lua.org/ftp/$pkgname-$pkgver.tar.gz
+ liblua.so.patch
+ lua.pc
+ LICENSE)
+md5sums=('dc7f94ec6ff15c985d2d6ad0f1b35654'
+ 'bdc663c7b82ffc0b5df67611621fb625'
+ 'e7ba6c2b695b0b84a5ea0cbff5fc9067'
+ '0e2bd67b909b9ff673da844ca3480df2')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p1 -i ../liblua.so.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+
export CFLAGS="$CFLAGS -fPIC"
+ make MYCFLAGS="$CFLAGS" MYLDFLAGS="$LDFLAGS" linux
- make INSTALL_DATA="cp -d" TO_LIB="liblua.a liblua.so liblua.so.5.1" \
- INSTALL_TOP="${pkgdir}/usr" INSTALL_MAN="${pkgdir}/usr/share/man/man1" \
- linux
+ sed "s/%VER%/${pkgver%.*}/g;s/%REL%/$pkgver/g" ../lua.pc > lua.pc
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make INSTALL_DATA="cp -d" TO_LIB="liblua.a liblua.so liblua.so.5.1 liblua.so.$pkgver" \
- INSTALL_TOP="${pkgdir}/usr" INSTALL_MAN="${pkgdir}/usr/share/man/man1" \
+ cd $pkgname-$pkgver
+
+ make \
+ TO_LIB='liblua.a liblua.so liblua.so.5.2 liblua.so.5.2.3' \
+ INSTALL_DATA='cp -d' \
+ INSTALL_TOP="$pkgdir"/usr \
+ INSTALL_MAN="$pkgdir"/usr/share/man/man1 \
install
- install -D -m644 etc/lua.pc "${pkgdir}/usr/lib/pkgconfig/lua.pc"
- install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+ install -Dm644 lua.pc "$pkgdir"/usr/lib/pkgconfig/lua.pc
# Install the documentation
- install -d "${pkgdir}/usr/share/doc/lua"
- install -m644 doc/*.{gif,png,css,html} "${pkgdir}/usr/share/doc/lua"
+ install -d "$pkgdir"/usr/share/doc/lua
+ install -m644 doc/*.{gif,png,css,html} "$pkgdir"/usr/share/doc/lua
+ install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/abs/extra/lua/liblua.so.patch b/abs/extra/lua/liblua.so.patch
new file mode 100644
index 0000000..92c1f3a
--- /dev/null
+++ b/abs/extra/lua/liblua.so.patch
@@ -0,0 +1,57 @@
+diff -ru lua-5.2.1/Makefile lua-5.2.1.new/Makefile
+--- lua-5.2.1/Makefile 2012-05-17 16:05:54.000000000 +0200
++++ lua-5.2.1.new/Makefile 2012-09-12 22:39:07.162748096 +0200
+@@ -52,7 +52,7 @@
+ all: $(PLAT)
+
+ $(PLATS) clean:
+- cd src && $(MAKE) $@
++ cd src && $(MAKE) $@ V=$(V) R=$(R)
+
+ test: dummy
+ src/lua -v
+diff -ru lua-5.2.1/src/luaconf.h lua-5.2.1.new/src/luaconf.h
+--- lua-5.2.1/src/luaconf.h 2012-05-11 16:14:42.000000000 +0200
++++ lua-5.2.1.new/src/luaconf.h 2012-09-12 22:40:27.986622772 +0200
+@@ -100,7 +100,7 @@
+ #else /* }{ */
+
+ #define LUA_VDIR LUA_VERSION_MAJOR "." LUA_VERSION_MINOR "/"
+-#define LUA_ROOT "/usr/local/"
++#define LUA_ROOT "/usr/"
+ #define LUA_LDIR LUA_ROOT "share/lua/" LUA_VDIR
+ #define LUA_CDIR LUA_ROOT "lib/lua/" LUA_VDIR
+ #define LUA_PATH_DEFAULT \
+diff -ru lua-5.2.1/src/Makefile lua-5.2.1.new/src/Makefile
+--- lua-5.2.1/src/Makefile 2012-03-09 17:32:16.000000000 +0100
++++ lua-5.2.1.new/src/Makefile 2012-09-12 22:38:08.591386896 +0200
+@@ -29,6 +29,7 @@
+ PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
+
+ LUA_A= liblua.a
++LUA_SO= liblua.so
+ CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
+ lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
+ ltm.o lundump.o lvm.o lzio.o
+@@ -43,7 +44,7 @@
+ LUAC_O= luac.o
+
+ ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
+-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
++ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) $(LUA_SO)
+ ALL_A= $(LUA_A)
+
+ # Targets start here.
+@@ -59,6 +60,12 @@
+ $(AR) $@ $(BASE_O)
+ $(RANLIB) $@
+
++$(LUA_SO): $(CORE_O) $(LIB_O)
++ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
++ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
++ ln -sf $(LUA_SO).$(R) $(LUA_SO)
++
++
+ $(LUA_T): $(LUA_O) $(LUA_A)
+ $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
+
diff --git a/abs/extra/lua/lua-5.1-cflags.diff b/abs/extra/lua/lua-5.1-cflags.diff
deleted file mode 100644
index db658ae..0000000
--- a/abs/extra/lua/lua-5.1-cflags.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -Naur lua-5.1.orig/src/Makefile lua-5.1/src/Makefile
---- lua-5.1.orig/src/Makefile 2006-02-16 16:45:09.000000000 +0100
-+++ lua-5.1/src/Makefile 2006-03-01 14:55:29.000000000 +0100
-@@ -8,7 +8,8 @@
- PLAT= none
-
- CC= gcc
--CFLAGS= -O2 -Wall $(MYCFLAGS)
-+CFLAGS ?= -O2 -Wall
-+CFLAGS += $(MYCFLAGS)
- AR= ar rcu
- RANLIB= ranlib
- RM= rm -f
diff --git a/abs/extra/lua/lua-arch.patch b/abs/extra/lua/lua-arch.patch
deleted file mode 100644
index d8650c3..0000000
--- a/abs/extra/lua/lua-arch.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff -ur lua-5.1.4/etc/lua.pc lua-5.1.4-new/etc/lua.pc
---- lua-5.1.4/etc/lua.pc 2008-08-08 14:46:11.000000000 +0200
-+++ lua-5.1.4-new/etc/lua.pc 2012-02-23 18:25:34.000000000 +0100
-@@ -8,6 +8,6 @@
-
- # grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
--prefix= /usr/local
-+prefix= /usr
- INSTALL_BIN= ${prefix}/bin
- INSTALL_INC= ${prefix}/include
- INSTALL_LIB= ${prefix}/lib
-diff -ur lua-5.1.4/src/luaconf.h lua-5.1.4-new/src/luaconf.h
---- lua-5.1.4/src/luaconf.h 2008-02-11 17:25:08.000000000 +0100
-+++ lua-5.1.4-new/src/luaconf.h 2012-02-23 18:25:34.000000000 +0100
-@@ -94,7 +94,7 @@
- ".\\?.dll;" LUA_CDIR"?.dll;" LUA_CDIR"loadall.dll"
-
- #else
--#define LUA_ROOT "/usr/local/"
-+#define LUA_ROOT "/usr/"
- #define LUA_LDIR LUA_ROOT "share/lua/5.1/"
- #define LUA_CDIR LUA_ROOT "lib/lua/5.1/"
- #define LUA_PATH_DEFAULT \
-diff -ur lua-5.1.4/src/Makefile lua-5.1.4-new/src/Makefile
---- lua-5.1.4/src/Makefile 2008-01-19 20:37:58.000000000 +0100
-+++ lua-5.1.4-new/src/Makefile 2012-02-23 18:26:43.000000000 +0100
-@@ -23,6 +23,7 @@
- PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
-
- LUA_A= liblua.a
-+LUA_SO= liblua.so
- CORE_O= lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o \
- lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o \
- lundump.o lvm.o lzio.o
-@@ -36,7 +37,7 @@
- LUAC_O= luac.o print.o
-
- ALL_O= $(CORE_O) $(LIB_O) $(LUA_O) $(LUAC_O)
--ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
-+ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
- ALL_A= $(LUA_A)
-
- default: $(PLAT)
-@@ -51,6 +52,11 @@
- $(AR) $@ $?
- $(RANLIB) $@
-
-+$(LUA_SO): $(CORE_O) $(LIB_O)
-+ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
-+ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
-+ ln -sf $(LUA_SO).$(R) $(LUA_SO)
-+
- $(LUA_T): $(LUA_O) $(LUA_A)
- $(CC) -o $@ $(MYLDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
-
---- lua-5.1.4/Makefile 2008-08-12 02:40:48.000000000 +0200
-+++ lua-5.1.4-new/Makefile 2012-02-23 19:06:32.000000000 +0100
-@@ -53,7 +53,7 @@
- all: $(PLAT)
-
- $(PLATS) clean:
-- cd src && $(MAKE) $@
-+ cd src && $(MAKE) $@ V=$(V) R=$(R)
-
- test: dummy
- src/lua test/hello.lua
diff --git a/abs/extra/lua/lua.pc b/abs/extra/lua/lua.pc
new file mode 100644
index 0000000..bf7977b
--- /dev/null
+++ b/abs/extra/lua/lua.pc
@@ -0,0 +1,20 @@
+V=%VER%
+R=%REL%
+
+prefix=/usr
+INSTALL_BIN=${prefix}/bin
+INSTALL_INC=${prefix}/include
+INSTALL_LIB=${prefix}/lib
+INSTALL_MAN=${prefix}/man/man1
+INSTALL_LMOD=${prefix}/share/lua/${V}
+INSTALL_CMOD=${prefix}/lib/lua/${V}
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: Lua
+Description: An Extensible Extension Language
+Version: ${R}
+Requires:
+Libs: -L${libdir} -llua -lm
+Cflags: -I${includedir}